summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-05-28 23:48:17 +0800
committerChih-Hsuan Yen2018-05-28 23:48:17 +0800
commit7896a99e863aacd0c3c7050bd0770f5f832f098d (patch)
treef55c116d24f162b36386d9b736c221f86913134f
parent7dc3f3efb50c98725259d6d185f6a6fd8ec2a819 (diff)
downloadaur-7896a99e863aacd0c3c7050bd0770f5f832f098d.tar.gz
the Python bug is worked around upstream
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 5 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8257b83b5b13..b7e65ffc8caa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyalpm-git
pkgdesc = Libalpm bindings for Python 3 (Git version)
- pkgver = 0.8.2.r1.g1f95811
+ pkgver = 0.8.3.r0.g284d480
pkgrel = 1
url = https://git.archlinux.org/pyalpm.git/
arch = i686
@@ -9,12 +9,10 @@ pkgbase = pyalpm-git
makedepends = git
depends = python>=3.6
depends = pacman>=5
- provides = pyalpm=0.8.2.r1.g1f95811
+ provides = pyalpm=0.8.3.r0.g284d480
conflicts = pyalpm
source = git+https://projects.archlinux.org/git/pyalpm.git
- source = bpo33012.patch::https://patchwork.archlinux.org/patch/544/raw/
sha256sums = SKIP
- sha256sums = 8006c0252733f76c2af6f69bdaed20c91d8710cb0ce96ce69650b7518c66064d
pkgname = pyalpm-git
diff --git a/PKGBUILD b/PKGBUILD
index 049f66f513e4..c261a421a2cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=pyalpm
pkgname=$_pkgname-git
-pkgver=0.8.2.r1.g1f95811
+pkgver=0.8.3.r0.g284d480
pkgrel=1
pkgdesc="Libalpm bindings for Python 3 (Git version)"
arch=('i686' 'x86_64')
@@ -13,10 +13,8 @@ depends=('python>=3.6' 'pacman>=5')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
makedepends=('git')
-source=('git+https://projects.archlinux.org/git/pyalpm.git'
- bpo33012.patch::'https://patchwork.archlinux.org/patch/544/raw/')
-sha256sums=('SKIP'
- '8006c0252733f76c2af6f69bdaed20c91d8710cb0ce96ce69650b7518c66064d')
+source=('git+https://projects.archlinux.org/git/pyalpm.git')
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
@@ -26,15 +24,8 @@ pkgver() {
)
}
-prepare() {
- cd $_pkgname
-
- patch -Np1 -i ../bpo33012.patch
-}
-
package() {
cd $_pkgname
python setup.py install --root="$pkgdir" --optimize=1
}
-