summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpozar2016-07-03 21:34:17 +0200
committerpozar2016-07-03 21:34:17 +0200
commit9dc8c29d90d6e63d7cb46a9ce0ff335b29730526 (patch)
tree5f68ffd84934f827f906943001beffeeb8ee4322
parentef9baffce0ea4a42b7d52f6c4a4082c46fbfd723 (diff)
downloadaur-pyarchey.tar.gz
update to 0.7
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
-rw-r--r--arch.patch31
3 files changed, 30 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7043827b5eed..043d9815f6ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jul 3 19:33:58 UTC 2016
pkgbase = pyarchey
pkgdesc = A simple python scrip to display an OS logo in ASCII art along with basic system information.
- pkgver = 0.6.8
+ pkgver = 0.7
pkgrel = 1
- url = https://pypi.python.org/pypi/pyarchey/
+ url = https://github.com/walchko/pyarchey
arch = any
license = GPL
depends = python
depends = python-psutil
depends = python-setuptools
- source = https://pypi.python.org/packages/source/p/pyarchey/pyarchey-0.6.8.tar.gz
+ source = https://pypi.python.org/packages/b5/92/f14e25f1aac20ec32870954697375e310a3052b17d8420450169cfeb1432/pyarchey-0.7.tar.gz
source = arch.patch
- md5sums = e25b2fb36e483befd6e6d1fa42b2fced
- md5sums = 675768afc3bec92439577408a5d3aad0
+ md5sums = b953c5e1d135fafbb8ea1096b25e23bb
+ md5sums = d67e7cf939bc93d632faf6e2da1cc4e2
pkgname = pyarchey
diff --git a/PKGBUILD b/PKGBUILD
index c355cf87da57..40cb52932537 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,28 @@
pkgname=pyarchey
pkgdesc="A simple python scrip to display an OS logo in ASCII art along with basic system information."
-pkgver=0.6.8
+pkgver=0.7
pkgrel=1
arch=('i686','x86_64')
-url="https://pypi.python.org/pypi/pyarchey/"
+url="https://github.com/walchko/pyarchey"
license=('GPL')
arch=('any')
depends=('python'
- 'python-psutil'
- 'python-setuptools')
-source=("https://pypi.python.org/packages/source/p/pyarchey/pyarchey-${pkgver}.tar.gz"
- 'arch.patch')
-md5sums=('e25b2fb36e483befd6e6d1fa42b2fced'
- '675768afc3bec92439577408a5d3aad0')
+'python-psutil'
+'python-setuptools')
+source=("https://pypi.python.org/packages/b5/92/f14e25f1aac20ec32870954697375e310a3052b17d8420450169cfeb1432/pyarchey-${pkgver}.tar.gz"
+'arch.patch')
+md5sums=('b953c5e1d135fafbb8ea1096b25e23bb'
+ 'd67e7cf939bc93d632faf6e2da1cc4e2')
prepare(){
- tar -zxvf pyarchey-${pkgver}.tar.gz
- # some fixes
- patch -p1 -i "${srcdir}/arch.patch"
+ tar -zxvf pyarchey-${pkgver}.tar.gz
+ # some fixes
+ patch -p1 -i "${srcdir}/arch.patch"
}
package(){
- cd pyarchey-${pkgver}
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd pyarchey-${pkgver}
+ python setup.py install --root="${pkgdir}" --optimize=1
}
diff --git a/arch.patch b/arch.patch
index 18b495bfbbf8..a85e7834b616 100644
--- a/arch.patch
+++ b/arch.patch
@@ -1,18 +1,9 @@
---- src/pyarchey-0.6.8/pyarchey/pyarchey.py 2015-09-26 17:16:41.076808842 +0200
-+++ src/pyarchey-0.6.8/pyarchey/pyarchey.py 2015-09-26 17:21:38.420151890 +0200
-@@ -444,7 +444,7 @@
- Does the printing. Either picture and info to screen or dumps json.
- """
- if js:
-- print json.dumps(self.json)
-+ print(json.dumps(self.json))
- else:
- print(logosDict[self.distro].format(color = colorDict[self.distro], results = self.results))
-
-@@ -555,9 +555,13 @@
+--- src/pyarchey-0.7/pyarchey/pyarchey.py 2016-07-03 21:06:51.984648092 +0200
++++ src/pyarchey-0.7/pyarchey/pyarchey.py 2016-07-03 21:12:46.701437069 +0200
+@@ -563,9 +563,11 @@
class Disk(object):
- def __init__(self,json=False):
+ def __init__(self, json=False):
- p = ps.disk_usage('/')
- total = p.total
- used = p.used
@@ -21,12 +12,10 @@
+ #used = p.used
+ total = sum([ps.disk_usage(part.mountpoint).total for part in ps.disk_partitions()])
+ used = sum([ps.disk_usage(part.mountpoint).used for part in ps.disk_partitions()])
-+
-+
- used,total,size = autoSize(used,total)
+ used, total, size = autoSize(used, total)
-@@ -566,11 +570,11 @@
+@@ -574,11 +576,11 @@
if json:
disk = '%s / %s %s' % (used, total, size)
else:
@@ -41,13 +30,13 @@
disk = '%s%s %s/ %s %s' % (colorDict['Sensors'][0], used, colorDict['Clear'][0], total, size)
self.key = 'Disk'
self.value = disk
-@@ -592,7 +596,8 @@
+@@ -601,7 +603,8 @@
if host.find('.local') < 0:
- host=host + '.local'
+ host = host + '.local'
- ip = socket.gethostbyname(host)
+ #ip = socket.gethostbyname(host)
-+ ip = [(s.connect(('8.8.8.8', 80)), s.getsockname()[0], s.close()) for s in [socket.socket(socket.AF_INET, socket.SOCK_DGRAM)]][0][1]
++ ip = [(s.connect(('8.8.8.8', 80)), s.getsockname()[0], s.close()) for s in [socket.socket(socket.AF_INET, socket.SOCK_DGRAM)]][0][1]
except:
print('Error in IP()')
-
+