summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2015-08-18 22:51:52 +0200
committerAlad Wenter2015-08-18 22:51:52 +0200
commitdb8db81508a4ed5b4ac85519b2c371a7b75ec584 (patch)
tree2bfd1165be08d85d63d776880522d5dbd2da34c7
parent6eee822a42c67136b8dcabd40c65ddac18c53eb6 (diff)
downloadaur-db8db81508a4ed5b4ac85519b2c371a7b75ec584.tar.gz
Move to git repository
-rw-r--r--PKGBUILD25
-rw-r--r--pybgsetter.install3
2 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75874ee0b956..0bd4d8ddddee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
# Contributor: Pável Varela Rodríguez [NeOnsKuLL] <neonskull@gmail.com>
-
pkgname=pybgsetter
pkgver=0.5
-pkgrel=3
+pkgrel=4
-pkgdesc="Multi-backend (hsetroot, Esetroot, habak, feh) User Friendly GUI/CLI tool to set desktop wallpaper"
+pkgdesc="Multi-backend GUI/CLI tool to set the desktop wallpaper."
url="http://bbs.archlinux.org/viewtopic.php?id=88997"
arch=('any')
license=('GPL')
depends=('python2' 'pygtk' 'imagemagick')
-optdepends=('hsetroot: to activate support for Hsetroot'
- 'esetroot: to activate support for Esetroot'
- 'habak: to activate support for Habak'
- 'feh: to activate support for Feh')
-source=($pkgname-$pkgver.tar.bz2)
-sha256sums=('7b430784ce0e7f3d7508ac2bcba2b422252270de82c913294628bb4c110cbc4b'
- 'ce72846ec5d40061736ebc977bedeef8002c0504bb08efe3b85b127c13b951da')
+optdepends=(
+ 'hsetroot: to activate support for Hsetroot'
+ 'esetroot: to activate support for Esetroot'
+ 'habak: to activate support for Habak'
+ 'feh: to activate support for Feh'
+)
+
+source=(git+https://github.com/stefanhusmann/pybgsetter)
+sha256sums=('SKIP')
install=pybgsetter.install
package() {
- $pkgname-$pkgver/install.sh "$pkgdir"/
+ cd "$pkgname"
+ ./install.sh "$pkgdir"/
}
+
diff --git a/pybgsetter.install b/pybgsetter.install
index d040b34d6c23..af958bc4d87c 100644
--- a/pybgsetter.install
+++ b/pybgsetter.install
@@ -1,5 +1,6 @@
post_install(){
- printf '\nPlease install at least one of the optional dependencies.\n'
+ update-desktop-database -q
+ printf '\n%s\n' 'Please install at least one of the optional dependencies.'
}
post_upgrade(){