summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2016-11-14 14:57:11 -0500
committerDavid Parrish2016-11-14 14:57:11 -0500
commitf35c36a677a299fbd2ca1cc2a266c5daaebaa586 (patch)
treeedaf200278d270660ea38e1be9dfc9f6180539a2
parent50ffd524a6a0cf289493362014444204879d62ca (diff)
downloadaur-f35c36a677a299fbd2ca1cc2a266c5daaebaa586.tar.gz
Update patch and add python-msgpack dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rw-r--r--bitmsglib_location.patch7
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4a30efc89aa..ffeafa401a6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jul 20 23:15:46 UTC 2016
+# Mon Nov 14 19:54:54 UTC 2016
pkgbase = pybitmessage-dev-git
pkgdesc = Decentralized and trustless P2P communications protocol for sending encrypted messages to another person or to many subscribers
- pkgver = 0.6.0.r28.g36a04fd
+ pkgver = 0.6.1.r61.g612333a
pkgrel = 1
url = https://github.com/Bitmessage/PyBitmessage
arch = i686
@@ -13,13 +13,14 @@ pkgbase = pybitmessage-dev-git
depends = python2-pyqt4
depends = qt4
depends = sqlite
+ depends = python-msgpack
optdepends = mpg123: MP3 sounds support
optdepends = alsa-utils: WAV sounds support
provides = pybitmessage
source = pybitmessage-dev-git::git+https://github.com/Bitmessage/PyBitmessage.git#branch=v0.6
source = bitmsglib_location.patch
sha256sums = SKIP
- sha256sums = 22f1a248cc915e5b58b4b96b60c9fe71344c596d33be4e0fb87b719a5db65b77
+ sha256sums = 95989a9c62780270df160470f860fee2d2115db835f56da9568681b11c5cfd37
pkgname = pybitmessage-dev-git
diff --git a/PKGBUILD b/PKGBUILD
index 7160e8ab7661..b782dc379a01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
# Maintainer: David Parrish <BM-2cU1Bk3fXVo9VrGpo2YQFJ1it31gSuAy5j>
pkgname=pybitmessage-dev-git
-pkgver=0.6.0.r28.g36a04fd
+pkgver=0.6.1.r61.g612333a
pkgrel=1
pkgdesc="Decentralized and trustless P2P communications protocol for sending encrypted messages to another person or to many subscribers"
arch=('i686' 'x86_64')
-depends=('openssl' 'python2' 'python2-pyqt4' 'qt4' 'sqlite')
+depends=('openssl' 'python2' 'python2-pyqt4' 'qt4' 'sqlite' 'python-msgpack')
optdepends=('mpg123: MP3 sounds support'
'alsa-utils: WAV sounds support')
url="https://github.com/Bitmessage/PyBitmessage"
@@ -14,7 +14,7 @@ license=('MIT')
source=("${pkgname}::git+https://github.com/Bitmessage/PyBitmessage.git#branch=v0.6"
"bitmsglib_location.patch")
sha256sums=('SKIP'
- '22f1a248cc915e5b58b4b96b60c9fe71344c596d33be4e0fb87b719a5db65b77')
+ '95989a9c62780270df160470f860fee2d2115db835f56da9568681b11c5cfd37')
provides=('pybitmessage')
pkgver() {
diff --git a/bitmsglib_location.patch b/bitmsglib_location.patch
index 52e459d3e17f..2dffc0025503 100644
--- a/bitmsglib_location.patch
+++ b/bitmsglib_location.patch
@@ -1,12 +1,13 @@
diff --git a/src/proofofwork.py b/src/proofofwork.py
-index 9d53b39..bd5e85c 100644
+index 701f34b..4bcaac6 100644
--- a/src/proofofwork.py
+++ b/src/proofofwork.py
-@@ -200,7 +200,9 @@ if "win32" == sys.platform:
+@@ -223,7 +223,10 @@ if "win32" == sys.platform:
bso = None
else:
try:
-- bso = ctypes.CDLL(os.path.join(codePath(), "bitmsghash", bitmsglib))
+- bso = ctypes.CDLL(os.path.join(shared.codePath(), "bitmsghash", bitmsglib))
++
+ # Modified by Arch Linux PKGBUILD
+ # https://aur.archlinux.org/packages/pybitmessage-dev-git/
+ bso = ctypes.CDLL(os.path.join("/usr/lib/pybitmessage-dev-git", bitmsglib))