summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2017-04-27 00:19:52 +0200
committerJake2017-04-27 00:19:52 +0200
commit1218f9c6c16e6a727979ca90f63b2928cbee0c89 (patch)
tree55111eb4dfaa64f6d49e05038c0104c91f360e38
parent82be69e8dc890f2d3d5adc0e5f4f3a0a452a6701 (diff)
downloadaur-1218f9c6c16e6a727979ca90f63b2928cbee0c89.tar.gz
Update to 0.6.1
Based on the PKGBUILD from Yinameah
-rw-r--r--.SRCINFO17
-rw-r--r--GLUTfix.patch9
-rw-r--r--PKGBUILD42
-rw-r--r--memoryfix.patch36
-rwxr-xr-xpycam2
5 files changed, 42 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb0a504bfc6b..d9925a7d8aa8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = pycam
pkgdesc = Toolpath generator for 3-axis CNC machining, written in Python.
- pkgver = 0.5.1
- pkgrel = 5
+ pkgver = 0.6.1
+ pkgrel = 1
url = http://pycam.sourceforge.net/
arch = i686
arch = x86_64
license = GPL3
depends = python2
+ depends = pygtk
depends = python2-opengl
depends = python2-rsvg
depends = python2-gtkglext
- depends = pstoedit
- optdepends = psyco
- source = http://downloads.sourceforge.net/project/pycam/pycam/0.5.1/pycam-0.5.1.tar.gz
- source = memoryfix.patch
- sha512sums = f880d960f82eb374465a593f3b27e9f72148b3ceb99fde15bee4ccf1078acc8ef44ddfd9ee12f89e5b5e5ee14706b6e5d76eff7d0334c9526866ff263a057994
- sha512sums = fe6720e0afc2018ce16c37bacf6e905c3e4396c74759da600bd0f8268c6dca695d08da904b40816e43c84587e0812d599a1f61eaead02b8f739a6b467c473f09
+ source = https://github.com/SebKuzminsky/pycam/releases/download/v0.6.1/pycam-0.6.1.tar.gz
+ source = GLUTfix.patch
+ source = pycam
+ sha512sums = 962d6ba5b5790d244ac47684c2d67b791b91725a30c014a821925706e322b0cb43ce29b5b90b5e917e04151fdd5806916132ef8d9bfb3bd7fb854b558066827a
+ sha512sums = 8d3a4610acad8a8f0dfcbcb62273f420f44b0db4c5e2c236eacbf49d5abd73394de3e302dfec1a6109160869513304274c74f784dc7f3c0fae505348868e90d5
+ sha512sums = fbb1b026dfa821caea352f44aa5eddb34fcb8ec87e27bf1390fb791b58733c011f5476203a5195bb1e737cd6194000c8ec30ac7444f638c2b70965071757c092
pkgname = pycam
diff --git a/GLUTfix.patch b/GLUTfix.patch
new file mode 100644
index 000000000000..e450860eaf56
--- /dev/null
+++ b/GLUTfix.patch
@@ -0,0 +1,9 @@
+diff -ur pycam-0.6.1.orig/pycam/Gui/OpenGLTools.py pycam-0.6.1/pycam/Gui/OpenGLTools.py
+-- pycam-0.6.1.orig/pycam/Gui/OpenGLTools.py 2017-04-03 20:54:31.975806360 +0200
++++ pycam-0.6.1/pycam/Gui/OpenGLTools.py 2017-03-11 03:50:16.000000000 +0100
+@@ -91,4 +91,4 @@
+ # center the cone
+ GL.glTranslatef(0, 0, -cone_length * position)
+ # draw the cone
+- #GLUT.glutSolidCone(cone_radius, cone_length, precision, 1)
++ GLUT.glutSolidCone(cone_radius, cone_length, precision, 1)
diff --git a/PKGBUILD b/PKGBUILD
index 15764cc6ed72..46f83c6bb713 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,40 @@
-# Maintainer: David Manouchehri <manouchehri@riseup.net>
-# Contributor: Peter-Paul van Gemerden <info@ppvg.nl>
-# Contributor: Karsten Hinz <k.hinz@tu-bs.de>
+# Maintainer: Jake <ja.ke@posteo.de>
+# Contributor: Aurelien Cibrario <aurelien.cibrario at gmail dot com>
+# Contributor: David Manouchehri <manouchehri at riseup dot net>
+# Contributor: Peter-Paul van Gemerden <info at ppvg dot nl>
+# Contributor: Karsten Hinz <k.hinz at tu-bs dot de>
pkgname=pycam
-pkgver=0.5.1
-pkgrel=5
+pkgver=0.6.1
+pkgrel=1
pkgdesc="Toolpath generator for 3-axis CNC machining, written in Python."
arch=('i686' 'x86_64')
url="http://pycam.sourceforge.net/"
license=('GPL3')
-depends=('python2' 'python2-opengl' 'python2-rsvg' 'python2-gtkglext' 'pstoedit')
-optdepends=('psyco')
-options=()
-source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- memoryfix.patch)
-sha512sums=('f880d960f82eb374465a593f3b27e9f72148b3ceb99fde15bee4ccf1078acc8ef44ddfd9ee12f89e5b5e5ee14706b6e5d76eff7d0334c9526866ff263a057994'
- 'fe6720e0afc2018ce16c37bacf6e905c3e4396c74759da600bd0f8268c6dca695d08da904b40816e43c84587e0812d599a1f61eaead02b8f739a6b467c473f09')
+depends=('python2' 'pygtk' 'python2-opengl' 'python2-rsvg' 'python2-gtkglext')
+source=("https://github.com/SebKuzminsky/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "GLUTfix.patch"
+ "${pkgname}")
+sha512sums=('962d6ba5b5790d244ac47684c2d67b791b91725a30c014a821925706e322b0cb43ce29b5b90b5e917e04151fdd5806916132ef8d9bfb3bd7fb854b558066827a'
+ '8d3a4610acad8a8f0dfcbcb62273f420f44b0db4c5e2c236eacbf49d5abd73394de3e302dfec1a6109160869513304274c74f784dc7f3c0fae505348868e90d5'
+ 'fbb1b026dfa821caea352f44aa5eddb34fcb8ec87e27bf1390fb791b58733c011f5476203a5195bb1e737cd6194000c8ec30ac7444f638c2b70965071757c092')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}/"
- patch -p1 -i "${srcdir}/memoryfix.patch"
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -R -p1 -i "${srcdir}/GLUTfix.patch"
}
-package() {
+package() {
+ # Application
mkdir -p "${pkgdir}/usr/share/"
cp -R "${srcdir}/${pkgname}-${pkgver}" "${pkgdir}/usr/share/${pkgname}"
- mkdir -p "${pkgdir}/usr/bin/"
- echo -e "#! /bin/sh\npython2 /usr/share/${pkgname}/${pkgname}" > "${pkgdir}/usr/bin/${pkgname}"
- chmod a+x "${pkgdir}/usr/bin/${pkgname}"
+ # Start script
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
# freedesktop.org compatibility
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/share/desktop/pycam.desktop" "${pkgdir}/usr/share/applications/pycam.desktop"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/share/mime/icons/32x32/application-sla.png" "${pkgdir}/usr/share/pixmaps/pycam.png"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/share/mime/application-sla.svg" "${pkgdir}/usr/share/pixmaps/pycam.svg"
install -Dm644 "${srcdir}/${pkgname}-${pkgver}/share/mime/pycam.xml" "${pkgdir}/usr/share/mime/application/pycam.xml"
-} \ No newline at end of file
+}
diff --git a/memoryfix.patch b/memoryfix.patch
deleted file mode 100644
index 9680f63e3760..000000000000
--- a/memoryfix.patch
+++ /dev/null
@@ -1,36 +0,0 @@
--- pycam-0.5.1.orig/src/pycam/Utils/threading.py 2011-06-10 10:54:51.000000000 -0400
-+++ pycam-0.5.1/src/pycam/Utils/threading.py 2011-11-13 15:50:34.294437639 -0500
-@@ -639,18 +639,21 @@
- if __multiprocessing and not disable_multiprocessing:
- # use the number of CPUs as the default number of worker threads
- pool = __multiprocessing.Pool(__num_of_processes)
-- if unordered:
-- imap_func = pool.imap_unordered
-- else:
-- imap_func = pool.imap
-- # Beware: we may not return "pool.imap" or "pool.imap_unordered"
-- # directly. It would somehow loose the focus and just hang infinitely.
-- # Thus we wrap our own generator around it.
-- for result in imap_func(func, args):
-- if callback and callback():
-- # cancel requested
-- break
-- yield result
-+ try:
-+ if unordered:
-+ imap_func = pool.imap_unordered
-+ else:
-+ imap_func = pool.imap
-+ # Beware: we may not return "pool.imap" or "pool.imap_unordered"
-+ # directly. It would somehow loose the focus and just hang infinitely.
-+ # Thus we wrap our own generator around it.
-+ for result in imap_func(func, args):
-+ if callback and callback():
-+ # cancel requested
-+ break
-+ yield result
-+ finally:
-+ pool.terminate()
- else:
- for arg in args:
- if callback and callback():
diff --git a/pycam b/pycam
new file mode 100755
index 000000000000..d73b1e55bca4
--- /dev/null
+++ b/pycam
@@ -0,0 +1,2 @@
+#! /bin/sh
+python2 /usr/share/pycam/scripts/pycam