summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Manouchehri2015-08-26 11:02:21 -0400
committerDavid Manouchehri2015-08-26 11:02:21 -0400
commited25a3298a67c65bee4b8810728e13e41c8c0a0e (patch)
tree4a3d661b7ea68439dd7a01ec873753c6bc2a242d
downloadaur-ed25a3298a67c65bee4b8810728e13e41c8c0a0e.tar.gz
Initial import from AUR3.
-rw-r--r--.AURINFO20
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
-rw-r--r--memoryfix.patch36
-rw-r--r--memoryfix.patch.sigbin0 -> 543 bytes
5 files changed, 124 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a809051fff4e
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,20 @@
+pkgbase = pycam
+ pkgdesc = Toolpath generator for 3-axis CNC machining, written in Python.
+ pkgver = 0.5.1
+ pkgrel = 4
+ url = http://pycam.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python2
+ depends = python2-opengl
+ depends = python2-rsvg
+ depends = python2-gtkglext
+ depends = pstoedit
+ optdepends = psyco
+ source = http://downloads.sourceforge.net/project/pycam/pycam/0.5.1/pycam-0.5.1.tar.gz
+ source = memoryfix.patch
+ source = memoryfix.patch.sig
+
+pkgname = pycam
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1551f269f50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = pycam
+ pkgdesc = Toolpath generator for 3-axis CNC machining, written in Python.
+ pkgver = 0.5.1
+ pkgrel = 4
+ url = http://pycam.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python2
+ depends = python2-opengl
+ depends = python2-rsvg
+ depends = python2-gtkglext
+ depends = pstoedit
+ optdepends = psyco
+ source = http://downloads.sourceforge.net/project/pycam/pycam/0.5.1/pycam-0.5.1.tar.gz
+ source = memoryfix.patch
+ source = memoryfix.patch.sig
+ sha512sums = f880d960f82eb374465a593f3b27e9f72148b3ceb99fde15bee4ccf1078acc8ef44ddfd9ee12f89e5b5e5ee14706b6e5d76eff7d0334c9526866ff263a057994
+ sha512sums = fe6720e0afc2018ce16c37bacf6e905c3e4396c74759da600bd0f8268c6dca695d08da904b40816e43c84587e0812d599a1f61eaead02b8f739a6b467c473f09
+ sha512sums = SKIP
+
+pkgname = pycam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c3ec62544a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: David Manouchehri <d@32t.ca>
+# Former Maintainer: Peter-Paul van Gemerden <info@ppvg.nl>
+# Contributor: Karsten Hinz <k.hinz@tu-bs.de>
+
+pkgname=pycam
+pkgver=0.5.1
+pkgrel=4
+pkgdesc="Toolpath generator for 3-axis CNC machining, written in Python."
+arch=('i686' 'x86_64')
+url="http://pycam.sourceforge.net/"
+license=('GPL3')
+depends=('python2' 'python2-opengl' 'python2-rsvg' 'python2-gtkglext' 'pstoedit')
+optdepends=('psyco')
+options=()
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+ memoryfix.patch{,.sig})
+sha512sums=('f880d960f82eb374465a593f3b27e9f72148b3ceb99fde15bee4ccf1078acc8ef44ddfd9ee12f89e5b5e5ee14706b6e5d76eff7d0334c9526866ff263a057994'
+ 'fe6720e0afc2018ce16c37bacf6e905c3e4396c74759da600bd0f8268c6dca695d08da904b40816e43c84587e0812d599a1f61eaead02b8f739a6b467c473f09'
+ 'SKIP')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver/
+ patch -p1 -i $srcdir/memoryfix.patch
+}
+
+package() {
+
+ mkdir -p "$pkgdir/usr/share/"
+ cp -R "$srcdir/$pkgname-$pkgver" "$pkgdir/usr/share/$pkgname"
+
+ mkdir -p "$pkgdir/usr/bin/"
+ echo -e "#! /bin/sh\npython2 /usr/share/$pkgname/$pkgname" > "$pkgdir/usr/bin/$pkgname"
+ chmod a+x "$pkgdir/usr/bin/$pkgname"
+
+ # Thanks to Karsten for these additions
+ # install some freedesktop.org compatibility
+ install -D -m644 "$srcdir/$pkgname-$pkgver/share/desktop/pycam.desktop" \
+ "$pkgdir/usr/share/applications/pycam.desktop"
+
+ #install -Dm644 "$srcdir/$pkgname-$pkgver/share/mime/icons/32x32/application-sla.png" "$pkgdir/usr/share/pixmaps/pycam.png"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/share/mime/application-sla.svg" "$pkgdir/usr/share/pixmaps/pycam.svg"
+
+ install -Dm644 "$srcdir/$pkgname-$pkgver/share/mime/pycam.xml" "$pkgdir/usr/share/mime/application/pycam.xml"
+
+}
diff --git a/memoryfix.patch b/memoryfix.patch
new file mode 100644
index 000000000000..9680f63e3760
--- /dev/null
+++ b/memoryfix.patch
@@ -0,0 +1,36 @@
+-- pycam-0.5.1.orig/src/pycam/Utils/threading.py 2011-06-10 10:54:51.000000000 -0400
++++ pycam-0.5.1/src/pycam/Utils/threading.py 2011-11-13 15:50:34.294437639 -0500
+@@ -639,18 +639,21 @@
+ if __multiprocessing and not disable_multiprocessing:
+ # use the number of CPUs as the default number of worker threads
+ pool = __multiprocessing.Pool(__num_of_processes)
+- if unordered:
+- imap_func = pool.imap_unordered
+- else:
+- imap_func = pool.imap
+- # Beware: we may not return "pool.imap" or "pool.imap_unordered"
+- # directly. It would somehow loose the focus and just hang infinitely.
+- # Thus we wrap our own generator around it.
+- for result in imap_func(func, args):
+- if callback and callback():
+- # cancel requested
+- break
+- yield result
++ try:
++ if unordered:
++ imap_func = pool.imap_unordered
++ else:
++ imap_func = pool.imap
++ # Beware: we may not return "pool.imap" or "pool.imap_unordered"
++ # directly. It would somehow loose the focus and just hang infinitely.
++ # Thus we wrap our own generator around it.
++ for result in imap_func(func, args):
++ if callback and callback():
++ # cancel requested
++ break
++ yield result
++ finally:
++ pool.terminate()
+ else:
+ for arg in args:
+ if callback and callback():
diff --git a/memoryfix.patch.sig b/memoryfix.patch.sig
new file mode 100644
index 000000000000..1ac7f23b5b8f
--- /dev/null
+++ b/memoryfix.patch.sig
Binary files differ