summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Haugh2018-02-05 14:43:18 -0600
committerSean Haugh2018-02-05 15:23:16 -0600
commit84be0587261b66de7ccc08a08e1ea32468bbfc84 (patch)
treee61e4d22b4a81eb82c9a9e4c00b15eddaaa03852
downloadaur-84be0587261b66de7ccc08a08e1ea32468bbfc84.tar.gz
nil → 0.2.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--pycflow2dot-0.2.1-fix-install-requires.patch11
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8962a7d8346
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pycflow2dot
+ pkgdesc = Layout C call graphs from cflow using GraphViz dot
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/johnyf/pycflow2dot
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pydot
+ depends = python-networkx
+ provides = pycflow2dot=0.2.1-1
+ source = https://github.com/johnyf/pycflow2dot/archive/v0.2.1.tar.gz
+ source = pycflow2dot-0.2.1-fix-install-requires.patch
+ md5sums = bc3be47765e019c4dce0dd4c73444416
+ md5sums = 69d5c78fb719661f900741f82bfffa64
+
+pkgname = pycflow2dot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a924f47044da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sean Haugh <seanphaugh@gmail.com>
+_pkgname=pycflow2dot
+_owner=johnyf
+pkgname=pycflow2dot
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="Layout C call graphs from cflow using GraphViz dot"
+arch=('any')
+url="https://github.com/$_owner/$_pkgname"
+license=('BSD')
+depends=('python'
+ 'python-pydot'
+ 'python-networkx')
+makedepends=('python-setuptools')
+provides=("$pkgname=$pkgver-$pkgrel")
+source=("https://github.com/$_owner/$_pkgname/archive/v$pkgver.tar.gz"
+ 'pycflow2dot-0.2.1-fix-install-requires.patch')
+md5sums=('bc3be47765e019c4dce0dd4c73444416'
+ '69d5c78fb719661f900741f82bfffa64')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -i "${srcdir}/pycflow2dot-0.2.1-fix-install-requires.patch"
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+# vim: set ts=2 sw=2 noet:
diff --git a/pycflow2dot-0.2.1-fix-install-requires.patch b/pycflow2dot-0.2.1-fix-install-requires.patch
new file mode 100644
index 000000000000..0e1f6366fd15
--- /dev/null
+++ b/pycflow2dot-0.2.1-fix-install-requires.patch
@@ -0,0 +1,11 @@
+--- setup.py 2017-03-09 16:02:06.000000000 -0600
++++ setup.py~ 2018-02-05 15:15:16.945059419 -0600
+@@ -25,7 +25,7 @@
+ author_email='jfilippidis@gmail.com',
+ url='https://github.com/johnyf/pycflow2dot',
+ install_requires=[
+- 'networkx == 1.10',
++ 'networkx >= 1.10',
+ 'pydot >= 1.2.3'],
+ entry_points={
+ 'console_scripts': ['cflow2dot = pycflow2dot:main']},