summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2020-09-17 16:34:27 +0200
committerKr1ss2020-09-17 16:34:27 +0200
commit951140d1db10bc4bfbb6bc220f934ecd4c83911f (patch)
tree9b818d652900f78876f1bf4e431788e0e778ce12
parentcde3085e8c70ffaa87379864bee825f4ee4339d9 (diff)
downloadaur-951140d1db10bc4bfbb6bc220f934ecd4c83911f.tar.gz
fix dependencies
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0756c08dd850..cef08f6043f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,12 @@ pkgbase = pycharm-community-eap
arch = any
license = Apache
makedepends = python-setuptools
+ depends = python
+ depends = glib2
depends = libdbusmenu-glib
+ optdepends = python2: Support for Python 2 language
+ optdepends = ipython: Alternative Python shell
+ optdepends = ipython2: Alternative Python 2 shell
provides = pycharm-community-edition
conflicts = pycharm-community-edition
options = !strip
diff --git a/PKGBUILD b/PKGBUILD
index d3447f6bb65e..e8ecfa7e5b30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,7 +25,10 @@ provides=('pycharm-community-edition')
conflicts=('pycharm-community-edition')
makedepends=('python-setuptools') # 'python2-setuptools'
-depends=('libdbusmenu-glib')
+depends=('python' 'glib2' 'libdbusmenu-glib')
+optdepends=('python2: Support for Python 2 language'
+ 'ipython: Alternative Python shell'
+ 'ipython2: Alternative Python 2 shell')
options=('!strip')
@@ -46,7 +49,8 @@ build() {
# using absolute paths to the python executables so that users with an activated virtual env
# (like e.g. anaconda) can build without issues
/usr/bin/python3 ./setup_cython.py build_ext --inplace
- if pacman -Qq python2-setuptools &>/dev/null; then
+ if [ -z "$(pacman -T python2-setuptools)" ]; then
+ # only compile the py2-debugger if `python2-setuptools’ is already installed
/usr/bin/python2 ./setup_cython.py build_ext --inplace
fi
}