summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonid Vaiman2022-01-04 17:05:00 +0200
committerLeonid Vaiman2022-01-04 17:05:00 +0200
commit52f538ce6402dbedc0cea211af57c2fcbba09318 (patch)
treed49a503a0f6e0b57c1bab90abc0643395657dc51
downloadaur-52f538ce6402dbedc0cea211af57c2fcbba09318.tar.gz
First version
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD55
-rw-r--r--fsnotifier-aarch64bin0 -> 25304 bytes
-rw-r--r--pycharm.desktop11
-rw-r--r--pycharm.sh8
6 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c4f900b5f0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = pycharm-community-jre-aarch64
+ pkgdesc = PyCharm Community Edition IDE for Python with bundled JRE with aarch64 support
+ pkgver = 2021.3.1
+ pkgrel = 1
+ url = https://www.jetbrains.com/pycharm/
+ arch = x86_64
+ arch = aarch64
+ license = APACHE
+ conflicts = pycharm-community-eap
+ conflicts = pycharm-community-edition
+ conflicts = pycharm-community-jre
+ source = https://download.jetbrains.com/python/pycharm-community-2021.3.1.tar.gz
+ source = pycharm.desktop
+ source = pycharm.sh
+ sha256sums = f5dd6e642ee65fa96d0ea8447d4a75589ce4258434222c4d9df00d1e5a46a8f5
+ sha256sums = f727119ec7c8b96820e80712b1ee342de6a94ff72402e8f2d390cbff702f9b21
+ sha256sums = b6f0518e59c4744ded38de63efba91205bcba406fa74944a1f3a8937566d8acc
+ source_aarch64 = https://cache-redirector.jetbrains.com/intellij-jbr/jbr-11_0_13-linux-aarch64-b1751.21.tar.gz
+ source_aarch64 = fsnotifier-aarch64
+ sha256sums_aarch64 = 56309fcb763c5cc7a52fa2565866a1fcc2cddd9b515a7bce7401f7f8a8c9d2fe
+ sha256sums_aarch64 = 8e8aecc0770fe6d7fdc78753c4ac8acc5fe28f94fc28d196fadc01a4aede348f
+
+pkgname = pycharm-community-jre-aarch64
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..49b101069d7e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pycharm-community-*
+jbr-*.tar.gz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee971adfd022
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Leonid Vaiman <vleon1@gmail.com>
+pkgname=pycharm-community-jre-aarch64
+pkgver=2021.3.1
+pkgrel=1
+pkgdesc="PyCharm Community Edition IDE for Python with bundled JRE with aarch64 support"
+arch=(x86_64 aarch64)
+url="https://www.jetbrains.com/pycharm/"
+license=('APACHE')
+conflicts=(
+ "pycharm-community-eap"
+ "pycharm-community-edition"
+ "pycharm-community-jre"
+)
+source=(
+ "https://download.jetbrains.com/python/pycharm-community-${pkgver}.tar.gz"
+ pycharm.desktop
+ pycharm.sh
+)
+source_aarch64=(
+ "https://cache-redirector.jetbrains.com/intellij-jbr/jbr-11_0_13-linux-aarch64-b1751.21.tar.gz"
+ fsnotifier-aarch64
+)
+sha256sums=(
+ 'f5dd6e642ee65fa96d0ea8447d4a75589ce4258434222c4d9df00d1e5a46a8f5'
+ 'f727119ec7c8b96820e80712b1ee342de6a94ff72402e8f2d390cbff702f9b21'
+ 'b6f0518e59c4744ded38de63efba91205bcba406fa74944a1f3a8937566d8acc'
+)
+sha256sums_aarch64=(
+ '56309fcb763c5cc7a52fa2565866a1fcc2cddd9b515a7bce7401f7f8a8c9d2fe'
+ '8e8aecc0770fe6d7fdc78753c4ac8acc5fe28f94fc28d196fadc01a4aede348f'
+)
+
+package() {
+ cd "pycharm-community-${pkgver}"
+
+ # https://youtrack.jetbrains.com/articles/IDEA-A-48/JetBrains-IDEs-on-AArch64#linux
+ if [ "${CARCH}" == "aarch64" ]; then
+ rm -rf jbr
+ cp -r ../jbr .
+ cp ../fsnotifier-aarch64 bin/
+ chmod +x bin/fsnotifier-aarch64
+ echo "idea.filewatcher.executable.path=/usr/share/pycharm/bin/fsnotifier-aarch64" >> bin/idea.properties
+ fi
+
+ # workaround FS#40934
+ # see https://bugs.archlinux.org/task/40934
+ sed -i 's/lcd/on/' bin/*.vmoptions
+
+ install -dm 755 "${pkgdir}"/usr/share/{licenses,pixmaps,pycharm}
+ cp -dr --no-preserve='ownership' bin jbr lib plugins "${pkgdir}"/usr/share/pycharm/
+ cp -dr --no-preserve='ownership' license "${pkgdir}"/usr/share/licenses/pycharm/
+ ln -s /usr/share/pycharm/bin/pycharm.png "${pkgdir}"/usr/share/pixmaps/
+ install -Dm 644 ../pycharm.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm 755 ../pycharm.sh "${pkgdir}"/usr/bin/pycharm
+}
diff --git a/fsnotifier-aarch64 b/fsnotifier-aarch64
new file mode 100644
index 000000000000..cd6c6fd50f2c
--- /dev/null
+++ b/fsnotifier-aarch64
Binary files differ
diff --git a/pycharm.desktop b/pycharm.desktop
new file mode 100644
index 000000000000..5cc49d923d15
--- /dev/null
+++ b/pycharm.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=PyCharm Community Edition
+Comment=Python IDE for Professional Developers
+Exec=/usr/bin/pycharm %f
+Icon=pycharm
+Terminal=false
+StartupNotify=true
+StartupWMClass=jetbrains-pycharm-ce
+Categories=Development;IDE;Python;
diff --git a/pycharm.sh b/pycharm.sh
new file mode 100644
index 000000000000..aae5733bf3aa
--- /dev/null
+++ b/pycharm.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+if [ -z "$PYCHARM_JDK" ] ; then
+ PYCHARM_JDK="/usr/share/pycharm/jbr/"
+fi
+exec env PYCHARM_JDK="$PYCHARM_JDK" /usr/share/pycharm/bin/pycharm.sh "$@"
+
+# vim: ts=2 sw=2 et: