summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2020-04-20 12:51:40 -0700
committerXavierCLL2020-04-20 12:51:40 -0700
commit3113357fc07d80af9dfa1594883512ee523b6906 (patch)
treeb524042cc85a0434bfa78706ec5a7b2ae07e1bc2
parenta2e4b809f86f11f6fbfce87f8c0e89e90c5f3d59 (diff)
downloadaur-3113357fc07d80af9dfa1594883512ee523b6906.tar.gz
Fix: remove internal fonts, instead use system fonts
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ed7f13d5964..f2b76f8eca1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,8 @@ sha256sums=('8263bb3707de2eaf88b689cf19667dc24508da40418b7fb00ad1280d1d168deb'
'773f169fac40fa5df69ccf90680238524f99c42aaa2b037e78e01cfc8c545280'
'db54c71d65ac938bb0e4c058481463b71d784ba113a872e419c66975cbc94a3f')
makedepends=('python2-setuptools' 'python-setuptools')
-optdepends=('ipython2: For enhanced interactive Python shell v2 inside Pycharm'
+optdepends=('ttf-jetbrains-mono: Official mono font by JetBrains'
+ 'ipython2: For enhanced interactive Python shell v2 inside Pycharm'
'ipython: For enhanced interactive Python shell v3 inside Pycharm'
'openssh: For deployment and remote connections'
'python2-setuptools: Packages manager for Python 2, for project interpreter'
@@ -68,6 +69,9 @@ package() {
install -Dm 644 $pkgdir/opt/$pkgname/bin/pycharm.png $pkgdir/usr/share/pixmaps/pycharm.png
install -Dm 644 pycharm-professional.desktop $pkgdir/usr/share/applications/
+ # remove internal fonts, instead use system fonts
+ sudo rm -rf $pkgdir/opt/pycharm-professional/jbr/lib/fonts
+
# exec
install -dm 755 $pkgdir/usr/bin/
install -Dm 755 pycharm $pkgdir/usr/bin/