summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2016-07-21 11:10:53 -0500
committerXavierCLL2016-07-21 11:10:53 -0500
commiteb2a39f5ae122258f375b4fa4be8eb68dd78e910 (patch)
treec73cf0568bb37808574bbe738e3f867b4cb638d6
parent00050964ad020697ecd954fd195c288ad5912912 (diff)
downloadaur-eb2a39f5ae122258f375b4fa4be8eb68dd78e910.tar.gz
Updated charm
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD2
-rwxr-xr-xcharm8
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a107670fbdc3..85a4b174a075 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Jul 21 16:09:29 UTC 2016
+# Thu Jul 21 16:10:25 UTC 2016
pkgbase = pycharm-professional
pkgdesc = Powerful Python and Django IDE. Professional edition.
pkgver = 2016.2
@@ -44,7 +44,7 @@ pkgbase = pycharm-professional
sha256sums = c1a74303d9e870918bd8068f761c8251b996694b1b96b3537fbca317679c4958
sha256sums = 43e79e5a786fc76385634dc0a9f1c3489b25031745b840b0822b059fc91d1060
sha256sums = a90a2b645e733627fefe568ae82fc96716772c13b4431760a822c0c64b0596e9
- sha256sums = f31a41ab02ba39a08aa218b1239ff7a0156e3b7d68c109eb0249ac6d1db32331
+ sha256sums = dbe4055a0e4980dba5c5104b6a9ec30a3e429e4e3ef5ef92efef2627403e7ac5
pkgname = pycharm-professional
diff --git a/PKGBUILD b/PKGBUILD
index e3795abb474c..819a4af1434c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,7 +39,7 @@ sha256sums=('3b938aeb08a72acad535e27ab1db44330c2c99cc36ac0eaf895518710437b6ab'
'c1a74303d9e870918bd8068f761c8251b996694b1b96b3537fbca317679c4958'
'43e79e5a786fc76385634dc0a9f1c3489b25031745b840b0822b059fc91d1060'
'a90a2b645e733627fefe568ae82fc96716772c13b4431760a822c0c64b0596e9'
- 'f31a41ab02ba39a08aa218b1239ff7a0156e3b7d68c109eb0249ac6d1db32331')
+ 'dbe4055a0e4980dba5c5104b6a9ec30a3e429e4e3ef5ef92efef2627403e7ac5')
package() {
# base
diff --git a/charm b/charm
index 77ead9bb8ec1..e360842ccf78 100755
--- a/charm
+++ b/charm
@@ -1,17 +1,17 @@
#!/usr/bin/env python
# -*- coding: utf-8 -*-
-import os
import socket
import struct
import sys
+import os
import time
# see com.intellij.idea.SocketLock for the server side of this interface
RUN_PATH = u'/opt/pycharm-professional/bin/pycharm.sh'
-CONFIG_PATH = u'~/.PyCharm2016.1/config'
-SYSTEM_PATH = u'~/.PyCharm2016.1/system'
+CONFIG_PATH = u'~/.PyCharm2016.2/config'
+SYSTEM_PATH = u'~/.PyCharm2016.2/system'
args = []
skip_next = False
@@ -92,7 +92,7 @@ if os.path.exists(port_path) and os.path.exists(token_path):
launch_with_port(port, token)
except:
type, value, traceback = sys.exc_info()
- print('No IDE instance has been found. New one will be started.') # todo error
+ print('Cannot activate a running instance: ' + str(value))
else:
print('No IDE instance has been found. New one will be started.')
if sys.platform == "darwin":