summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2022-09-23 20:08:14 +0200
committerClaudia Pellegrino2022-09-23 20:08:14 +0200
commit6eb895e7e1c0e75b89d528a16814cdc5a3123d74 (patch)
treec1e3f90ad9eb0cab970601081a1fbddea685d66d
downloadaur-6eb895e7e1c0e75b89d528a16814cdc5a3123d74.tar.gz
pychess-db 20170627
-rw-r--r--.SRCINFO14
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD33
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d80255281b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pychess-db
+ pkgdesc = Chess game database, PGN format, curated by the PyChess organization
+ pkgver = 20170627
+ pkgrel = 1
+ url = https://github.com/pychess/chess_db
+ arch = any
+ license = GPL3
+ optdepends = pychess: browse and analyze games
+ conflicts = pychess-db-git
+ options = !strip
+ source = pychess-db-20170627.tar.gz::https://github.com/pychess/chess_db/archive/refs/tags/20170627.tar.gz
+ sha512sums = 6fef6225c6cfb95873268a04a37bb286470a2d39a63c4381b21f2f9c310f316d9b035495a4442f44af0d98941744dfab98abcf5c5c293769d04607ed3389762c
+
+pkgname = pychess-db
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..29215c86a3df
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37dd117487ab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/.vscode/
+/src
+/pkg
+*.log
+*.pkg.*
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27d16967f530
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+
+pkgname=pychess-db
+_gitpkgname=chess_db
+pkgver=20170627
+pkgrel=1
+pkgdesc='Chess game database, PGN format, curated by the PyChess organization'
+arch=('any')
+url='https://github.com/pychess/chess_db'
+license=('GPL3')
+optdepends=('pychess: browse and analyze games')
+conflicts=('pychess-db-git')
+options=('!strip')
+
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/pychess/chess_db/archive/refs/tags/${pkgver}.tar.gz"
+)
+
+sha512sums=(
+ '6fef6225c6cfb95873268a04a37bb286470a2d39a63c4381b21f2f9c310f316d9b035495a4442f44af0d98941744dfab98abcf5c5c293769d04607ed3389762c'
+)
+
+package() {
+ echo >&2 'Packaging PGN files'
+ mkdir -p "${pkgdir}/usr/share/pychess-db/pgn"
+ cp -r --preserve=mode -T \
+ "${srcdir}/${_gitpkgname}-${pkgver}/pgn" \
+ "${pkgdir}/usr/share/pychess-db/pgn"
+
+ echo >&2 'Packaging the license'
+ install -D -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" \
+ "${srcdir}/${_gitpkgname}-${pkgver}/Copying.txt"
+}