summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShadowKyogre2015-06-08 07:34:35 -0700
committerShadowKyogre2015-06-08 07:34:35 -0700
commit03347c43c0078e21078e295dc7a0a8819fc71a14 (patch)
tree5f192df6fc83df90ece02e3026dd467607b74a32
downloadaur-03347c43c0078e21078e295dc7a0a8819fc71a14.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--pyching.desktop12
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe8e0ac3201e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pyching
+ pkgdesc = pyChing is a program that allows you to 'consult' the I Ching using the coin oracle and then to look up a brief interpretation.
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = http://pyching.sourceforge.net/
+ arch = any
+ license = GPL
+ depends = python2
+ source = http://sourceforge.net/projects/pyching/files/pyChing/1.2.2/pyching-1.2.2.tar.gz
+ source = pyching.desktop
+ md5sums = a11f3b34d195ed72514ffad68912329c
+ md5sums = e014b26d6bd3d3d4b037ef8563728ded
+
+pkgname = pyching
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbc732bc746f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sapphira Armageddos <shadowkyogre.public+aur@gmail.com>
+pkgname=pyching
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="pyChing is a program that allows you to 'consult' the I Ching using the coin oracle and then to look up a brief interpretation."
+arch=(any)
+url="http://pyching.sourceforge.net/"
+license=('GPL')
+depends=('python2')
+source=("http://sourceforge.net/projects/pyching/files/pyChing/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+"pyching.desktop")
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/usr/{bin,share/{pixmaps,applications,pyching,man/man1}}
+ install -Dm644 pyching.1 "$pkgdir/usr/share/man/man1/pyching.1"
+ install -Dm755 pyching.sh "$pkgdir/usr/bin/pyching"
+ sed -e 's|#! /usr/bin/env python|#! /usr/bin/env python2|g' -i pyching.py
+ install -m644 *.py icon.xbm "$pkgdir/usr/share/pyching"
+ install -m644 pyching.png "$pkgdir/usr/share/pixmaps"
+ install -m644 pyching.desktop "$pkgdir/usr/share/applications"
+ chmod +x "$pkgdir/usr/share/pyching/pyching.py"
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('a11f3b34d195ed72514ffad68912329c'
+ 'e014b26d6bd3d3d4b037ef8563728ded')
diff --git a/pyching.desktop b/pyching.desktop
new file mode 100644
index 000000000000..b0c63273bee8
--- /dev/null
+++ b/pyching.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Exec=pyching
+GenericName[en_US]=I Ching Coin Oracle
+GenericName=I Ching Coin Oracle
+Icon=pyching
+Name[en_US]=PyChing
+Name=PyChing
+StartupNotify=true
+Terminal=false
+Category=Accessories
+Type=Application
+