summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112017-01-05 23:15:00 +0100
committerjose17112017-01-05 23:15:00 +0100
commit0a33f6323b7383e8411ef26ccf9f23628dec0811 (patch)
treee90b429fafc8a42592d2cc695c51dab2e51ee7c7
downloadaur-0a33f6323b7383e8411ef26ccf9f23628dec0811.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
-rw-r--r--lopyupdate.desktop10
-rw-r--r--lopyupdate.sh2
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5423405ddcde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Thu Jan 5 22:14:51 UTC 2017
+pkgbase = pycom-firmware-updater
+ pkgdesc = Pycom firmware updater for WiPy and LoPy IOT boards
+ pkgver = 1.0.0b2
+ pkgrel = 1
+ url = https://www.pycom.io/
+ arch = any
+ license = unknown
+ depends = dialog
+ depends = python2
+ optdepends = python2-qscintilla-qt4: gui
+ optdepends = python2-pyserial: gui
+ optdepends = python2-setuptools: gui
+ optdepends = python2-requests: gui
+ source = https://software.pycom.io/findupgrade?product=pycom-firmware-updater&type=all&platform=unix&redirect=true
+ source = lopyupdate.sh
+ source = lopyupdate.desktop
+ md5sums = dba756d3e78ee8ccb8478f2808189984
+ md5sums = 268d38fbb3f7d8ee962760abb6169505
+ md5sums = 6af9152e7aa93baa74b59cbc0af2ba71
+
+pkgname = pycom-firmware-updater
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b26aa99e3a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jose Riha < jose 1711 gmail com >
+
+pkgname=pycom-firmware-updater
+pkgver=1.0.0b2
+pkgrel=1
+pkgdesc="Pycom firmware updater for WiPy and LoPy IOT boards"
+url="https://www.pycom.io/"
+license=('unknown')
+arch=('any')
+depends=('dialog' 'python2')
+optdepends=('python2-qscintilla-qt4: gui'
+ 'python2-pyserial: gui'
+ 'python2-setuptools: gui'
+ 'python2-requests: gui')
+source=('https://software.pycom.io/findupgrade?product=pycom-firmware-updater&type=all&platform=unix&redirect=true'
+ 'lopyupdate.sh'
+ 'lopyupdate.desktop')
+md5sums=('dba756d3e78ee8ccb8478f2808189984'
+ '268d38fbb3f7d8ee962760abb6169505'
+ '6af9152e7aa93baa74b59cbc0af2ba71')
+
+prepare() {
+ cd $srcdir
+ find . -name '*py' -exec sed -i '1s%python%python2%' '{}' \;
+}
+
+package() {
+ mkdir -p $pkgdir/usr/{share,bin}
+ cd $srcdir
+ cp -r pyupgrade $pkgdir/usr/share
+ ln -s /usr/share/pyupgrade/update $pkgdir/usr/bin/pycom-firmware-update
+ install -Dm755 $srcdir/lopyupdate.sh $pkgdir/usr/bin/lopyupdate.sh
+ install -Dm644 lopyupdate.desktop "$pkgdir"/usr/share/applications/lopyupdate.desktop
+}
diff --git a/lopyupdate.desktop b/lopyupdate.desktop
new file mode 100644
index 000000000000..0e53cbb15e50
--- /dev/null
+++ b/lopyupdate.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Exec=/usr/bin/lopyupdate.sh
+Terminal=false
+Name=PyCom Firmware Update tool
+Comment=Firmware update tool for LoPy and WiPy boards
+GenericName=Firmware updater by PyCom
+Categories=Development;
+StartupNotify=true
diff --git a/lopyupdate.sh b/lopyupdate.sh
new file mode 100644
index 000000000000..c561f5fc8a3f
--- /dev/null
+++ b/lopyupdate.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/sh
+exec python2 /usr/share/pyupgrade/lopyupdate.py "$@"