summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Bell2015-10-22 02:48:17 -0400
committerStephen Bell2015-10-22 02:48:17 -0400
commit5f90309259f5b05ca486b2f885c644ccd3b31fcc (patch)
tree94bc4fd4580e16696972723d8afa100e843066b7
downloadaur-5f90309259f5b05ca486b2f885c644ccd3b31fcc.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d195c6b3332d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pycraft-git
+ pkgdesc = A Minecraft-inspired game for the terminal
+ pkgver = 20150909.89f9d57
+ pkgrel = 1
+ url = https://github.com/itsapi/pycraft
+ arch = i686
+ arch = x86_64
+ license = GPL V2
+ makedepends = git
+ depends = python
+ source = pycraft::git+https://github.com/itsapi/pycraft.git
+ sha1sums = SKIP
+
+pkgname = pycraft-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42b906d36c37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Stephen Bell <theredbaron1834 @ yahoo.com>
+
+pkgname=pycraft-git
+pkgver=20150909.89f9d57
+pkgrel=1
+pkgdesc='A Minecraft-inspired game for the terminal '
+url='https://github.com/itsapi/pycraft'
+arch=('i686' 'x86_64')
+license=('GPL V2')
+makedepends=('git')
+source=("pycraft::git+https://github.com/itsapi/pycraft.git")
+sha1sums=('SKIP')
+depends=('python')
+
+pkgver() {
+ cd "${srcdir}/pycraft"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+package() {
+ cd "${srcdir}/"
+ install -m777 -d "${pkgdir}/opt/pycraft"
+ cp -R "${srcdir}/pycraft" "${pkgdir}/opt/"
+ mkdir -p "$pkgdir/usr/share/applications/"
+ mkdir -p "$pkgdir/usr/bin/"
+ echo "[Desktop Entry]
+Name=PyCraft
+GenericName=pycraft
+Comment=A Minecraft-inspired game for the terminal
+Exec=pycraft
+Icon=utilities-terminal
+Terminal=true
+Type=Application
+Categories=Game;" > "$pkgdir/usr/share/applications/pycraft.desktop"
+ echo "cd /opt/pycraft/
+python3 /opt/pycraft/main.py" > "$pkgdir/usr/bin/pycraft"
+ chmod +x "$pkgdir/usr/bin/pycraft"
+}
+