summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSevz2021-03-15 12:38:20 -0600
committerSevz2021-03-15 12:38:20 -0600
commitf1575ad7958387127ca06c41b9e7c17e7baf2486 (patch)
treeadb9cbdc3b532cb7a3809961d69d35a68a02bece
downloadaur-f1575ad7958387127ca06c41b9e7c17e7baf2486.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd39bd1dbd70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pycritty
+ pkgdesc = CLI program that allows you to change your Alacritty config with one command without editing the config file.
+ pkgver = 0.3.5
+ pkgrel = 1
+ url = https://github.com/antoniosarosi/pycritty
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/antoniosarosi/pycritty/archive/v0.3.5.tar.gz
+ sha512sums = f0eafd34223fce6f05f75ca21a1054d2feae0841933a9b859ebe9c8adc5a0231c421bf72effd1013eeae3b6befb63cecf5bed7e94d31e6cb9acf32ea7a1a3992
+
+pkgname = pycritty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fa551c0b4d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Leonardo Hernández <leohdz172@outlook.com>
+
+pkgname=pycritty
+pkgver=0.3.5
+pkgrel=1
+pkgdesc='CLI program that allows you to change your Alacritty config with one command without editing the config file.'
+url='https://github.com/antoniosarosi/pycritty'
+arch=('any')
+license=('MIT')
+depends=('python')
+source=(${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('f0eafd34223fce6f05f75ca21a1054d2feae0841933a9b859ebe9c8adc5a0231c421bf72effd1013eeae3b6befb63cecf5bed7e94d31e6cb9acf32ea7a1a3992')
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd $pkgname-$pkgver
+ python -B setup.py test
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --prefix=/usr --root="${pkgdir}" -O1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -Dm 644 README.md -t "${pkgdir}"/usr/share/doc/${pkgname}
+}