summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Sarboni2015-12-21 11:15:07 +0100
committerThomas Sarboni2015-12-21 11:15:07 +0100
commitc1f1268ba4f3ae5dd71dddcd2b2e1cb92327bdf8 (patch)
tree22c20568d083f6a7d548c6277fef1b56aa78bb5b
parent28667ed55d8d234618b52013187e9264164768b0 (diff)
downloadaur-c1f1268ba4f3ae5dd71dddcd2b2e1cb92327bdf8.tar.gz
Updated to 6.2.1 + update exemple ssl vhost
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--example_nginx_vhost_ssl.conf15
3 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5627f2c67804..caa91e6e621b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 10:13:39 UTC 2015
pkgbase = pydio
pkgdesc = PHP file sharing platform, formerly AjaXplorer.
- pkgver = 6.2.0
+ pkgver = 6.2.1
pkgrel = 1
url = http://pyd.io/
install = pydio.install
@@ -23,7 +25,7 @@ pkgbase = pydio
optdepends = php-aws-sdk: Access an AWS server
optdepends = pecl-rsync: Use desktop sync client
options = !strip
- source = http://sourceforge.net/projects/ajaxplorer/files/pydio/stable-channel/6.2.0/pydio-core-6.2.0.tar.gz
+ source = http://sourceforge.net/projects/ajaxplorer/files/pydio/stable-channel/6.2.1/pydio-core-6.2.1.tar.gz
source = https://raw.githubusercontent.com/pydio/pydio-core/develop/dist/scripts/misc/5.2.5-6.0.0.mysql
source = https://raw.githubusercontent.com/pydio/pydio-core/develop/dist/scripts/misc/5.2.5-6.0.0.pgsql
source = https://raw.githubusercontent.com/pydio/pydio-core/develop/dist/scripts/misc/5.2.5-6.0.0.sqlite
@@ -31,13 +33,13 @@ pkgbase = pydio
source = example_nginx_vhost.conf
source = example_nginx_vhost_ssl.conf
source = pydio.install
- md5sums = e557215a2ed98b953aa338cae5f3dcb4
+ md5sums = f3d4ee0cbe59c4c136ed257fcfc497fc
md5sums = b93ccc2869b485a3c7cd760e5435645c
md5sums = 85c19235373da52b97e0b6073ba45635
md5sums = e3c4ea819d6790c61c9b81dc48a34e05
md5sums = 4852094d1b423d62fee10bf5fde38b63
md5sums = be74fee97c60b4ae7e8b194187b553ea
- md5sums = ebe3fa7e400a213a57203b67e7602769
+ md5sums = 272007089a6c8ca65d1bdde705d91e05
md5sums = 837e3fc09a4fcfdc8a20c758083cfb99
pkgname = pydio
diff --git a/PKGBUILD b/PKGBUILD
index 0a1e1cb74691..eae14b566482 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: max-k <max-k AT post DOT com>
pkgname=pydio
-pkgver=6.2.0
+pkgver=6.2.1
pkgrel=1
pkgdesc='PHP file sharing platform, formerly AjaXplorer.'
arch=('any')
@@ -37,13 +37,13 @@ source=("${_srcbase}/${pkgver}/${pkgname}-core-${pkgver}.tar.gz"
"example_nginx_vhost_ssl.conf"
"${pkgname}.install")
-md5sums=('e557215a2ed98b953aa338cae5f3dcb4'
+md5sums=('f3d4ee0cbe59c4c136ed257fcfc497fc'
'b93ccc2869b485a3c7cd760e5435645c'
'85c19235373da52b97e0b6073ba45635'
'e3c4ea819d6790c61c9b81dc48a34e05'
'4852094d1b423d62fee10bf5fde38b63'
'be74fee97c60b4ae7e8b194187b553ea'
- 'ebe3fa7e400a213a57203b67e7602769'
+ '272007089a6c8ca65d1bdde705d91e05'
'837e3fc09a4fcfdc8a20c758083cfb99')
package() {
diff --git a/example_nginx_vhost_ssl.conf b/example_nginx_vhost_ssl.conf
index 2f9dca374160..16e15509c3bc 100644
--- a/example_nginx_vhost_ssl.conf
+++ b/example_nginx_vhost_ssl.conf
@@ -4,7 +4,7 @@
server {
listen 80;
server_name pydio.local;
- rewrite ^ https://$server_name$request_uri? permanent;
+ return 301 https://$server_name$request_uri? permanent;
}
server {
@@ -17,17 +17,18 @@ server {
access_log /var/log/nginx/pydio6.access.log;
error_log /var/log/nginx/pydio6.error.log;
- client_max_body_size 20G;
+ client_max_body_size 5G;
client_body_buffer_size 128k;
ssl_certificate /etc/ssl/pydio.local.pem;
ssl_certificate_key /etc/ssl/pydio.local_key.pem;
- ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;
- ssl_ciphers RC4:HIGH:!aNULL:!MD5;
+ ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
+ ssl_ciphers 'EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH';
ssl_prefer_server_ciphers on;
- keepalive_timeout 70;
- ssl_session_cache shared:SSL:10m;
- ssl_session_timeout 10m;
+ keepalive_requests 10;
+ keepalive_timeout 60 60;
+ #ssl_session_cache shared:SSL:10m;
+ #ssl_session_timeout 10m;
location ^~ (/dashboard|/settings|/welcome|/ws-) {
try_files /index.php =404;