summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:13:08 -0600
committernot_anonymous2015-07-05 18:13:08 -0600
commit9bc8ec38c4f9c9e013dce837f963fa2eaab91753 (patch)
tree74fca5f3135b6bf5bc5727083eb336235d8c642a
downloadaur-9bc8ec38c4f9c9e013dce837f963fa2eaab91753.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD45
-rw-r--r--pydxcluster.15
-rw-r--r--pydxcluster.desktop16
-rw-r--r--pydxcluster.install11
-rw-r--r--pydxcluster.pngbin0 -> 3661 bytes
6 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed5ca736ddfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = pydxcluster
+ pkgdesc = Python2 (tk) Ham Radio DX-Cluster GUI
+ pkgver = 1.2
+ pkgrel = 2
+ url = http://sourceforge.net/projects/pydxcluster/
+ install = pydxcluster.install
+ arch = any
+ license = GPL3
+ depends = python2-requests
+ depends = desktop-file-utils
+ source = http://downloads.sourceforge.net/pydxcluster/pyDxCluster_v1_2.tar.gz
+ source = pydxcluster.desktop
+ source = pydxcluster.png
+ source = pydxcluster.1
+ md5sums = 8ee5150a8f10271557b999ab0b1b07ed
+ md5sums = 047de11f8b1f7a2433008d10732341da
+ md5sums = d03076d6792be993b1d52cece985373d
+ md5sums = 26086372612eb51b3acfabefb94f24fe
+ sha256sums = c3f0dbe2c05dee1ebca9ee19f092332654eee9401492186e6a310b840b30f91c
+ sha256sums = b79a160b020a66a2f02d6bda7c5e1772c01c74fce4caa6a3eb5e8eeeb506a83e
+ sha256sums = 797cd5764b045edf71c95f2b874d2705e8296460730e80e2b32311b6705c33a8
+ sha256sums = ddbded75d30034bde6a206ba9e18c17d08bb1aba9edfe9f8934f10595b0d14bd
+
+pkgname = pydxcluster
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b01c12e8e1f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=pydxcluster
+pkgver=1.2
+pkgrel=2
+pkgdesc="Python2 (tk) Ham Radio DX-Cluster GUI"
+_dist=pyDxCluster
+_ver=v1_2
+arch=('any')
+url="http://sourceforge.net/projects/pydxcluster/"
+license=('GPL3')
+depends=('python2-requests' 'desktop-file-utils')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/$pkgname/${_dist}_${_ver}.tar.gz
+ $pkgname.desktop
+ $pkgname.png
+ $pkgname.1)
+
+prepare() {
+ cd "$srcdir/${_dist}_${_ver}/"
+ mv ${_dist}_${_ver}.py $pkgname.py
+ rm -f *.txt
+ sed -i 's:LICENSE:/usr/share/licenses/common/GPL3/license:' $pkgname.py
+}
+
+package() {
+ cd "$srcdir/${_dist}_${_ver}/"
+ install -d $pkgdir/usr/share/$pkgname
+ cp -a $srcdir/${_dist}_${_ver}/* $pkgdir/usr/share/$pkgname
+
+ mkdir -p $pkgdir/usr/bin
+ install -D -m 755 ../$pkgname.1 $pkgdir/usr/bin/$pkgname
+
+ mkdir -p $pkgdir/usr/share/{applications,pixmaps}
+ install -D -m 644 ../$pkgname.png $pkgdir/usr/share/pixmaps
+ install -D -m 644 ../$pkgname.desktop $pkgdir/usr/share/applications
+}
+md5sums=('8ee5150a8f10271557b999ab0b1b07ed'
+ '047de11f8b1f7a2433008d10732341da'
+ 'd03076d6792be993b1d52cece985373d'
+ '26086372612eb51b3acfabefb94f24fe')
+sha256sums=('c3f0dbe2c05dee1ebca9ee19f092332654eee9401492186e6a310b840b30f91c'
+ 'b79a160b020a66a2f02d6bda7c5e1772c01c74fce4caa6a3eb5e8eeeb506a83e'
+ '797cd5764b045edf71c95f2b874d2705e8296460730e80e2b32311b6705c33a8'
+ 'ddbded75d30034bde6a206ba9e18c17d08bb1aba9edfe9f8934f10595b0d14bd')
diff --git a/pydxcluster.1 b/pydxcluster.1
new file mode 100644
index 000000000000..f3dfc024ae38
--- /dev/null
+++ b/pydxcluster.1
@@ -0,0 +1,5 @@
+#!/bin/sh
+mkdir -p $HOME/pydxcluster
+cd $HOME/pydxcluster
+cp -ua /usr/share/pydxcluster/* .
+exec python2 pydxcluster.py
diff --git a/pydxcluster.desktop b/pydxcluster.desktop
new file mode 100644
index 000000000000..f5de7476d2bc
--- /dev/null
+++ b/pydxcluster.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=pyDxCluster
+Name[en_US]=pyDxCluster
+Comment=Ham Radio DX Cluster GUI
+Comment[en_US]=Ham Radio DX Cluster GUI
+Encoding=UTF-8
+Exec=/usr/bin/pydxcluster
+Icon=pydxcluster.png
+MimeType=text/plain
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+Categories=Application;HamRadio
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/pydxcluster.install b/pydxcluster.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/pydxcluster.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/pydxcluster.png b/pydxcluster.png
new file mode 100644
index 000000000000..e8bdfc8de18b
--- /dev/null
+++ b/pydxcluster.png
Binary files differ