summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrealitygaps2015-07-06 16:52:54 +0200
committerrealitygaps2015-07-06 16:52:54 +0200
commitdb6c53f14f1af7689668f45640fc66d7433845bc (patch)
tree744f25a88a0ddafd11b5c3b10c7216d6e5f891f1
downloadaur-db6c53f14f1af7689668f45640fc66d7433845bc.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..199c5424c113
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pyechonest
+ pkgdesc = Tap into the Echo Nest's Musical Brain for the best music search, information, recommendations and remix tools on the web.
+ pkgver = 8.0.1
+ pkgrel = 1
+ url = http://code.google.com/p/pyechonest
+ arch = any
+ license = BSD
+ depends = python
+ options = !emptydirs
+ source = https://github.com/echonest/pyechonest/archive/8.0.1.tar.gz
+ md5sums = 3cd9744feffd0fdadbefac5b5c7582b1
+
+pkgname = pyechonest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b251ccde2fae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: realitygaps <realitygaps AT yahoo DOT com>
+pkgname=pyechonest
+pkgver=8.0.1
+pkgrel=1
+pkgdesc="Tap into the Echo Nest's Musical Brain for the best music search, information, recommendations and remix tools on the web."
+arch=(any)
+url="http://code.google.com/p/pyechonest"
+license=(BSD)
+depends=('python')
+options=(!emptydirs)
+source=(https://github.com/echonest/${pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('3cd9744feffd0fdadbefac5b5c7582b1')
+install=
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ python setup.py install --root=$pkgdir/ --optimize=1 || return 1
+
+ # Remember to install licenses if the license is not a common license!
+ # install -D -m644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+