summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarkfish Tech2023-01-11 01:51:45 +1100
committerDarkfish Tech2023-01-11 01:51:45 +1100
commit4efc1be4cba15a095d048840dfb2d8bcd163146f (patch)
tree37b6ae033a0b0ffe95c6c2aa4fc748b2aadd000d
parentf730ff8fd45e430fddc4551650b8e5bace34690f (diff)
downloadaur-4efc1be4cba15a095d048840dfb2d8bcd163146f.tar.gz
Upgpkg: pyenv-virtualenv 1:1.2.0-1
Update pyenv-virtualenv to 1.2.0 Remove patch for 308 that has been merged upstream Update list of maintainers and contributors This pyenv plugin now installs under /usr/share
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
-rw-r--r--fix-symlink-308.patch54
3 files changed, 16 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9bc2dbcc7b0..47852389112a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pyenv-virtualenv
pkgdesc = pyenv plugin to manage virtualenv (a.k.a. python-virtualenv)
- pkgver = 1.1.5
- pkgrel = 3
+ pkgver = 1.2.0
+ pkgrel = 1
epoch = 1
url = https://github.com/pyenv/pyenv-virtualenv
arch = any
@@ -9,10 +9,7 @@ pkgbase = pyenv-virtualenv
makedepends = patch
depends = pyenv
depends = bash
- source = https://github.com/pyenv/pyenv-virtualenv/archive/v1.1.5.tar.gz
- source = fix-symlink-308.patch
- md5sums = 2ebab171a403915d695c383855ac78e4
- md5sums = 476790c1f9643d76efbb188b35ed19e0
+ source = https://github.com/pyenv/pyenv-virtualenv/archive/v1.2.0.tar.gz
+ md5sums = 0c09e896a343ce8cb7d6f57d7e71f9a6
pkgname = pyenv-virtualenv
-
diff --git a/PKGBUILD b/PKGBUILD
index 85be83911667..be166ee2f885 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Ayrton Araujo <root@ayr-ton.net>
-# Maintainer: Kevin Del Castillo R. <lans9831@gmail.com>
+# Maintainer: Darkfish Tech <arch@darkfish.com.au>
+# Contributor: Ayrton Araujo <root@ayr-ton.net>
+# Contributor: Kevin Del Castillo R. <lans9831@gmail.com>
# Contributor: Nuno Araujo <nuno.araujo@russo79.com>
pkgname=pyenv-virtualenv
-pkgver=1.1.5
-pkgrel=3
+pkgver=1.2.0
+pkgrel=1
epoch=1
pkgdesc="pyenv plugin to manage virtualenv (a.k.a. python-virtualenv)"
arch=('any')
@@ -11,29 +12,22 @@ url="https://github.com/pyenv/pyenv-virtualenv"
license=('MIT')
depends=('pyenv' 'bash')
makedepends=('patch')
-source=("https://github.com/pyenv/$pkgname/archive/v$pkgver.tar.gz"
- "fix-symlink-308.patch")
-md5sums=('2ebab171a403915d695c383855ac78e4'
- '476790c1f9643d76efbb188b35ed19e0')
-
-prepare() {
- cd "${srcdir?}/$pkgname-$pkgver"
-
- # Fix issue #308
- patch -p1 < ../fix-symlink-308.patch
-}
+source=("https://github.com/pyenv/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('0c09e896a343ce8cb7d6f57d7e71f9a6')
package() {
- mkdir -p "${pkgdir?}"/{opt/pyenv/plugins/pyenv-virtualenv,usr/bin}
+ _install_dir="usr/share/pyenv/plugins/pyenv-virtualenv"
+
+ mkdir -p "${pkgdir?}"/{${_install_dir},usr/bin}
cd "${srcdir?}/$pkgname-$pkgver"
# Intall using the script
- PREFIX="${pkgdir}/opt/pyenv/plugins/pyenv-virtualenv" ./install.sh
+ PREFIX="${pkgdir}/${_install_dir}" ./install.sh
# Link binaries
pushd bin &> /dev/null
for bin in *; do
- ln -s /opt/pyenv/plugins/pyenv-virtualenv/bin/"$bin" "$pkgdir/usr/bin/$bin"
+ ln -s "/${_install_dir}/bin/$bin" "$pkgdir/usr/bin/$bin"
done
popd &> /dev/null
diff --git a/fix-symlink-308.patch b/fix-symlink-308.patch
deleted file mode 100644
index 00e5e3c30a40..000000000000
--- a/fix-symlink-308.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff --git a/bin/pyenv-virtualenv-prefix b/bin/pyenv-virtualenv-prefix
-index aa71777..bbe5871 100755
---- a/bin/pyenv-virtualenv-prefix
-+++ b/bin/pyenv-virtualenv-prefix
-@@ -6,7 +6,21 @@
-
- set -e
- [ -n "$PYENV_DEBUG" ] && set -x
--. "${BASH_SOURCE%/*}"/../libexec/pyenv-virtualenv-realpath
-+if [ -L "${BASH_SOURCE}" ]; then
-+ READLINK=$(type -p greadlink readlink | head -1)
-+ if [ -z "$READLINK" ]; then
-+ echo "pyenv: cannot find readlink - are you missing GNU coreutils?" >&2
-+ exit 1
-+ fi
-+ resolve_link() {
-+ $READLINK -f "$1"
-+ }
-+ script_path=$(resolve_link ${BASH_SOURCE})
-+else
-+ script_path=${BASH_SOURCE}
-+fi
-+
-+. ${script_path%/*}/../libexec/pyenv-virtualenv-realpath
-
- if [ -z "$PYENV_ROOT" ]; then
- PYENV_ROOT="${HOME}/.pyenv"
-diff --git a/bin/pyenv-virtualenvs b/bin/pyenv-virtualenvs
-index 173278b..b441e78 100755
---- a/bin/pyenv-virtualenvs
-+++ b/bin/pyenv-virtualenvs
-@@ -7,7 +7,21 @@
-
- set -e
- [ -n "$PYENV_DEBUG" ] && set -x
--. "${BASH_SOURCE%/*}"/../libexec/pyenv-virtualenv-realpath
-+if [ -L "${BASH_SOURCE}" ]; then
-+ READLINK=$(type -p greadlink readlink | head -1)
-+ if [ -z "$READLINK" ]; then
-+ echo "pyenv: cannot find readlink - are you missing GNU coreutils?" >&2
-+ exit 1
-+ fi
-+ resolve_link() {
-+ $READLINK -f "$1"
-+ }
-+ script_path=$(resolve_link ${BASH_SOURCE})
-+else
-+ script_path=${BASH_SOURCE}
-+fi
-+
-+. ${script_path%/*}/../libexec/pyenv-virtualenv-realpath
-
- if [ -z "$PYENV_ROOT" ]; then
- PYENV_ROOT="${HOME}/.pyenv"