summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commit464dc4b08aace37cc540a8d5395c96ba23075ad9 (patch)
tree51408950fd23ef141d9e1335cbc0abf158fbad8c
downloadaur-464dc4b08aace37cc540a8d5395c96ba23075ad9.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD60
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d953dcaf8339
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = pyethereum-git
+ pkgdesc = Ethereum Python client
+ pkgver = 20150519
+ pkgrel = 1
+ url = https://github.com/ethereum/pyethereum
+ arch = any
+ groups = ethereum
+ license = MIT
+ makedepends = git
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-bitcoin
+ depends = python2-pyethash
+ depends = python2-pysha3
+ depends = python2-repoze.lru
+ depends = python2-rlp
+ depends = python2-structlog
+ depends = python2-yaml
+ provides = pyethereum
+ conflicts = pyethereum
+ source = git+https://github.com/ethereum/pyethereum#branch=develop
+ sha256sums = SKIP
+
+pkgname = pyethereum-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d398a53c729d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=pyethereum-git
+pkgver=20150519
+pkgrel=1
+pkgdesc="Ethereum Python client"
+arch=('any')
+depends=('python2'
+ 'python2-bitcoin'
+ 'python2-pyethash'
+ 'python2-pysha3'
+ 'python2-repoze.lru'
+ 'python2-rlp'
+ 'python2-structlog'
+ 'python2-yaml')
+makedepends=('git' 'python2-setuptools')
+groups=('ethereum')
+url="https://github.com/ethereum/pyethereum"
+license=('MIT')
+source=(git+https://github.com/ethereum/pyethereum#branch=develop)
+sha256sums=('SKIP')
+provides=('pyethereum')
+conflicts=('pyethereum')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+
+ msg 'Fixing Python version...'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/python#/usr/bin/python2#g'
+ find . -type f -print0 | xargs -0 sed -i 's#/usr/bin/env python#/usr/bin/env python2#g'
+}
+
+building() {
+ cd ${pkgname%-git}
+
+ msg 'Building...'
+ python2 setup.py build
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg 'Installing license...'
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/pyethereum/LICENSE"
+
+ msg 'Installing docs...'
+ install -Dm 644 README.rst "$pkgdir/usr/share/doc/pyethereum/README.rst"
+
+ msg 'Installing...'
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}