summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Dewender2015-10-21 12:55:39 +0200
committerJohannes Dewender2015-10-21 12:55:39 +0200
commit4280f3cac3dfd7def1ffdf667e0b3f2b415333e3 (patch)
tree38f0847e7f0e70beee5066af3678f5763caa13ad
parentae753f76a8609b7df978aafdfdcb6cd447c63821 (diff)
downloadaur-4280f3cac3dfd7def1ffdf667e0b3f2b415333e3.tar.gz
add net/if.h include for libnl 3.2.26
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--libnl3.2.26_net_if.patch19
3 files changed, 32 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcc207b35319..7df6b60c012b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = python2-ethtool
pkgdesc = python bindings for the ethtool kernel interface
pkgver = 0.11
- pkgrel = 1
+ pkgrel = 2
url = https://fedorahosted.org/python-ethtool/
arch = i686
arch = x86_64
license = GPL2
makedepends = asciidoc
depends = python2
- depends = libnl
+ depends = libnl>=3.2.26
options = !emptydirs
source = https://fedorahosted.org/releases/p/y/python-ethtool/python-ethtool-0.11.tar.bz2
+ source = libnl3.2.26_net_if.patch
sha256sums = 686756e4b2b239319e8513025debcc0d97103815b0879f94d8234cbbca6ada24
+ sha256sums = 15a748723cd361112de59d843ee0b4e4230e495ba89dcafcfdb578d039083001
pkgname = python2-ethtool
diff --git a/PKGBUILD b/PKGBUILD
index 93a716abcd56..63f15f834b60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=python2-ethtool
_pkgname=python-ethtool
pkgver=0.11
-pkgrel=1
+pkgrel=2
pkgdesc="python bindings for the ethtool kernel interface"
arch=('i686' 'x86_64')
url="https://fedorahosted.org/python-ethtool/"
license=('GPL2')
groups=()
-depends=('python2' 'libnl')
+depends=('python2' 'libnl>=3.2.26')
makedepends=('asciidoc')
provides=()
conflicts=()
@@ -16,8 +16,13 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=(https://fedorahosted.org/releases/p/y/$_pkgname/$_pkgname-$pkgver.tar.bz2)
-sha256sums=('686756e4b2b239319e8513025debcc0d97103815b0879f94d8234cbbca6ada24')
+source=(https://fedorahosted.org/releases/p/y/$_pkgname/$_pkgname-$pkgver.tar.bz2 libnl3.2.26_net_if.patch)
+sha256sums=('686756e4b2b239319e8513025debcc0d97103815b0879f94d8234cbbca6ada24'
+ '15a748723cd361112de59d843ee0b4e4230e495ba89dcafcfdb578d039083001')
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 < ../libnl3.2.26_net_if.patch
+}
build() {
cd "$srcdir/$_pkgname-$pkgver"
diff --git a/libnl3.2.26_net_if.patch b/libnl3.2.26_net_if.patch
new file mode 100644
index 000000000000..bc30c9665ad9
--- /dev/null
+++ b/libnl3.2.26_net_if.patch
@@ -0,0 +1,19 @@
+add previously conflicting net/if.h include
+
+Previously netlink/route/link.h included
+linux/if.h, conflicting with net/if.h.
+Starting with libnl 3.2.26 this include was removed.
+So we have to include net/if.h now.
+
+See: https://github.com/thom311/libnl/pull/73
+or 50a76998ac36ace3716d3c979b352fac73cfc80a in libnl
+--- a/python-ethtool/ethtool.c
++++ b/python-ethtool/ethtool.c
+@@ -27,6 +27,7 @@
+ #include <sys/types.h>
+ #include <ifaddrs.h>
+ #include <netlink/route/addr.h>
++#include <net/if.h>
+
+ #include "etherinfo_struct.h"
+ #include "etherinfo_obj.h"