summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwereii2021-10-29 15:51:51 +0200
committerwereii2022-08-15 15:54:30 +0200
commit35ec4082a456f61780f4ba7a6f58a5a3b767c1e7 (patch)
tree7ef5816b3bc2bed7c842cb64ddca38105d2a6bf4
parent85bfee2eb3c60a13a9f48618ecbb9a130b56dca0 (diff)
downloadaur-35ec4082a456f61780f4ba7a6f58a5a3b767c1e7.tar.gz
Update to 2.44.0
-rw-r--r--.SRCINFO14
-rw-r--r--0001-python-3.10-compatibility.patch96
-rw-r--r--PKGBUILD23
3 files changed, 99 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dba6587f4ece..6507d894116e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyfa
pkgdesc = EVE Online Fitting Assistant
- pkgver = 2.40.0
+ pkgver = 2.44.0
pkgrel = 1
url = https://github.com/pyfa-org/Pyfa
arch = any
@@ -25,15 +25,13 @@ pkgbase = pyfa
depends = python-requests-cache
depends = webkit2gtk
options = !strip
- source = pyfa-2.40.0.tar.gz::https://github.com/pyfa-org/Pyfa/archive/v2.40.0.tar.gz
+ source = pyfa-2.44.0.tar.gz::https://github.com/pyfa-org/Pyfa/archive/v2.44.0.tar.gz
source = pyfa.desktop
source = pyfa-start.sh
source = 0001-python-3.10-compatibility.patch
- source = add_broken_warning.patch
- sha256sums = ce50635e73e0cb61ddee802523785a9d4cfd6cd88142a677870ff3b6a453792f
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = 5a68c569bc6b999021476843899fb9b48619aaeb1a235ec4ddda20dc776dd7c3
+ sha256sums = b54ef367e93d7916f6ef3106a27018571d35afc1aa9eadcccc79463050e70786
+ sha256sums = 0fa4a1cb835ddbb764957cd00426f9bfa52b17bcb6d5dc7428afc256da5e01da
+ sha256sums = f3e1ec098917ef88b579f1d847e29819d396dd8ae91e3ea6d7e984effe9a299c
pkgname = pyfa
diff --git a/0001-python-3.10-compatibility.patch b/0001-python-3.10-compatibility.patch
index 16cb1f2849b2..f269e4774993 100644
--- a/0001-python-3.10-compatibility.patch
+++ b/0001-python-3.10-compatibility.patch
@@ -1,25 +1,95 @@
-From d3e85ab762682e290525768388213959461e3088 Mon Sep 17 00:00:00 2001
+From e0e6d51f8ca1847801c2821b9f0dc5964dc460be Mon Sep 17 00:00:00 2001
From: Martin Petrus <martin.petrus@example.com>
Date: Tue, 4 Jan 2022 13:27:30 +0100
Subject: [PATCH] python 3.10 compatibility
---
- gui/builtinMarketBrowser/pfSearchBox.py | 6 +++---
+ graphs/gui/vector.py | 26 ++++++++++-----------
+ gui/builtinMarketBrowser/pfSearchBox.py | 6 ++---
gui/builtinShipBrowser/categoryItem.py | 4 ++--
- gui/builtinShipBrowser/fitItem.py | 16 +++++++-------
- gui/builtinShipBrowser/navigationPanel.py | 6 +++---
- gui/builtinShipBrowser/pfListPane.py | 12 +++++------
+ gui/builtinShipBrowser/fitItem.py | 16 ++++++-------
+ gui/builtinShipBrowser/navigationPanel.py | 6 ++---
+ gui/builtinShipBrowser/pfListPane.py | 12 +++++-----
gui/builtinShipBrowser/pfWidgetContainer.py | 4 ++--
gui/builtinShipBrowser/raceSelector.py | 8 +++----
- gui/builtinShipBrowser/sfBrowserItem.py | 6 +++---
- gui/builtinShipBrowser/shipItem.py | 18 ++++++++--------
- gui/chrome_tabs.py | 24 ++++++++++-----------
- gui/pyfa_gauge.py | 12 +++++------
+ gui/builtinShipBrowser/sfBrowserItem.py | 6 ++---
+ gui/builtinShipBrowser/shipItem.py | 18 +++++++-------
+ gui/chrome_tabs.py | 24 +++++++++----------
+ gui/pyfa_gauge.py | 12 +++++-----
gui/utils/anim.py | 2 +-
- gui/utils/color.py | 10 ++++-----
- gui/utils/draw.py | 6 +++---
- 14 files changed, 67 insertions(+), 67 deletions(-)
+ gui/utils/color.py | 10 ++++----
+ gui/utils/draw.py | 6 ++---
+ 15 files changed, 80 insertions(+), 80 deletions(-)
+diff --git a/graphs/gui/vector.py b/graphs/gui/vector.py
+index 8542e7e8c..31c67478e 100644
+--- a/graphs/gui/vector.py
++++ b/graphs/gui/vector.py
+@@ -35,10 +35,10 @@ class VectorPicker(wx.Window):
+ self._label = str(kwargs.pop('label', ''))
+ self._labelpos = int(kwargs.pop('labelpos', 0))
+ self._offset = float(kwargs.pop('offset', 0))
+- self._size = max(0, float(kwargs.pop('size', 50)))
++ self._size = max(0, int(kwargs.pop('size', 50)))
+ self._directionOnly = kwargs.pop('directionOnly', False)
+ super().__init__(*args, **kwargs)
+- self._fontsize = max(1, float(kwargs.pop('fontsize', 8 / self.GetContentScaleFactor())))
++ self._fontsize = int(max(1, kwargs.pop('fontsize', 8 / self.GetContentScaleFactor())))
+ self._font = wx.Font(self._fontsize, wx.FONTFAMILY_DEFAULT, wx.FONTSTYLE_NORMAL, wx.FONTWEIGHT_NORMAL, False)
+ self._angle = 0
+ self.__length = 1
+@@ -110,7 +110,7 @@ class VectorPicker(wx.Window):
+ def GetScaledClientSize(self):
+ return tuple([dim / self.GetContentScaleFactor() for dim in self.GetClientSize()])
+
+- def Draw(self, dc):
++ def Draw(self, dc: wx.BufferedPaintDC):
+ width, height = self.GetScaledClientSize()
+ if not width or not height:
+ return
+@@ -119,17 +119,17 @@ class VectorPicker(wx.Window):
+ dc.SetTextForeground(wx.Colour(0))
+ dc.SetFont(self._font)
+
+- radius = min(width, height) / 2 - 2
++ radius = int(min(width, height) / 2 - 2)
+ dc.SetBrush(wx.WHITE_BRUSH)
+ dc.DrawCircle(radius + 2, radius + 2, radius)
+ a = math.radians(self._angle + self._offset)
+- x = math.cos(a) * radius
+- y = math.sin(a) * radius
++ x = int(math.cos(a) * radius)
++ y = int(math.sin(a) * radius)
+ # See PR #2260 on why this is needed
+- pointRadius = 2 / self.GetContentScaleFactor() if 'wxGTK' in wx.PlatformInfo else 2
+- dc.DrawLine(radius + 2, radius + 2, radius + 2 + x * self._length, radius + 2 - y * self._length)
++ pointRadius = int(2 / self.GetContentScaleFactor() if 'wxGTK' in wx.PlatformInfo else 2)
++ dc.DrawLine(radius + 2, radius + 2, radius + 2 + x * int(self._length), radius + 2 - y * int(self._length))
+ dc.SetBrush(wx.BLACK_BRUSH)
+- dc.DrawCircle(radius + 2 + x * self._length, radius + 2 - y * self._length, pointRadius)
++ dc.DrawCircle(int(radius + 2 + x * self._length), int(radius + 2 - y * self._length), pointRadius)
+
+ if self._label:
+ labelText = self._label
+@@ -141,14 +141,14 @@ class VectorPicker(wx.Window):
+ if not self._directionOnly:
+ lengthText = '%d%%' % (100 * self._length,)
+ lengthTextW, lengthTextH = dc.GetTextExtent(lengthText)
+- lengthTextX = radius + 2 + x / 2 - y / 3 - lengthTextW / 2
+- lengthTextY = radius + 2 - y / 2 - x / 3 - lengthTextH / 2
++ lengthTextX = radius + 2 + x // 2 - y // 3 - lengthTextW // 2
++ lengthTextY = radius + 2 - y // 2 - x // 3 - lengthTextH // 2
+ dc.DrawText(lengthText, lengthTextX, lengthTextY)
+
+ angleText = '%d\u00B0' % (self._angle,)
+ angleTextW, angleTextH = dc.GetTextExtent(angleText)
+- angleTextX = radius + 2 - x / 2 - angleTextW / 2
+- angleTextY = radius + 2 + y / 2 - angleTextH / 2
++ angleTextX = radius + 2 - x // 2 - angleTextW // 2
++ angleTextY = radius + 2 + y // 2 - angleTextH // 2
+ dc.DrawText(angleText, angleTextX, angleTextY)
+
+ def OnEraseBackground(self, event):
diff --git a/gui/builtinMarketBrowser/pfSearchBox.py b/gui/builtinMarketBrowser/pfSearchBox.py
index d1e8f2f40..ea068a08f 100644
--- a/gui/builtinMarketBrowser/pfSearchBox.py
@@ -516,5 +586,5 @@ index 4e486afda..95e975f32 100644
mdc.GradientFillLinear(r, gMid, gEnd, wx.SOUTH)
--
-2.34.1
+2.37.2
diff --git a/PKGBUILD b/PKGBUILD
index b3ab58570bda..ad22799fb372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Fabian Schoelzel <myfirstname.mylastname@googlemail.com>
pkgname=pyfa
-pkgver=2.40.0
+pkgver=2.44.0
pkgrel=1
_distname="Pyfa-${pkgver}"
pkgdesc="EVE Online Fitting Assistant"
@@ -20,10 +20,11 @@ source=(${pkgname}-${pkgver}.tar.gz::https://github.com/pyfa-org/Pyfa/archive/v$
pyfa.desktop
pyfa-start.sh
0001-python-3.10-compatibility.patch
- add_broken_warning.patch
)
-sha256sums=('ce50635e73e0cb61ddee802523785a9d4cfd6cd88142a677870ff3b6a453792f'
- SKIP SKIP SKIP SKIP)
+sha256sums=('5a68c569bc6b999021476843899fb9b48619aaeb1a235ec4ddda20dc776dd7c3'
+ 'b54ef367e93d7916f6ef3106a27018571d35afc1aa9eadcccc79463050e70786'
+ '0fa4a1cb835ddbb764957cd00426f9bfa52b17bcb6d5dc7428afc256da5e01da'
+ 'f3e1ec098917ef88b579f1d847e29819d396dd8ae91e3ea6d7e984effe9a299c')
build() {
cd "${srcdir}"/"${_distname}"
@@ -32,11 +33,8 @@ build() {
echo "Applying 0001-python-3.10-compatibility.patch"
patch --binary -l -p1 < ../0001-python-3.10-compatibility.patch
- echo "Applying add_broken_warning.patch"
- patch --binary -l -p1 < ../add_broken_warning.patch
-
- python db_update.py
- find . -name "__pycache__" -type d -prune -exec rm -r "{}" \;
+ PYTHONDONTWRITEBYTECODE=1 python db_update.py
+ #find . -name "__pycache__" -type d -prune -exec rm -r "{}" \;
}
package() {
@@ -65,9 +63,8 @@ package() {
install -Dm644 "${srcdir}"/pyfa.desktop "${pkgdir}"/usr/share/applications/pyfa.desktop
install -Dm755 "${srcdir}"/pyfa-start.sh "${pkgdir}"/usr/bin/pyfa
- echo -e "\n!!! THIS PACKAGE IS PARTIALLY BROKEN !!!"
- echo "wxPython, dependency of Pyfa, is incomaptible with python3.10 (for now)."
- echo "For more details (and place for bug reports) see: https://github.com/pyfa-org/Pyfa/issues/2391"
- echo -e "Known issues:\n- Implants tab does not work and will keep erroring out until closed\n"
+ echo -e "\nWARNING: This build of pyfa is running with un-tested dependencies (python3.10, wxPython 3.2)"
+ echo "Expect bugs and crashes."
+ echo -e "For more details (and place for bug reports) see: https://github.com/pyfa-org/Pyfa/issues/2391\n"
}