summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwereii2021-10-29 15:51:51 +0200
committerwereii2022-02-13 19:42:21 +0100
commit5cb6837f9cd3feb55c4f689c11a69d37c78a15d8 (patch)
tree15d5ada060f445ca4fff4ce2a66da6053935f8ab
parentc73b86ce81ff1b2205d4395379331e9ec26a7641 (diff)
downloadaur-5cb6837f9cd3feb55c4f689c11a69d37c78a15d8.tar.gz
Update to 2.39.3, added partially broken warnings
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
-rw-r--r--add_broken_warning.patch35
3 files changed, 56 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cdcdc5092d4..6995a81b0c7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyfa
pkgdesc = EVE Online Fitting Assistant
- pkgver = 2.39.2
+ pkgver = 2.39.3
pkgrel = 2
url = https://github.com/pyfa-org/Pyfa
arch = any
@@ -25,11 +25,13 @@ pkgbase = pyfa
depends = python-requests-cache
depends = webkit2gtk
options = !strip
- source = pyfa-2.39.2.tar.gz::https://github.com/pyfa-org/Pyfa/archive/v2.39.2.tar.gz
+ source = pyfa-2.39.3.tar.gz::https://github.com/pyfa-org/Pyfa/archive/v2.39.3.tar.gz
source = pyfa.desktop
source = pyfa-start.sh
source = 0001-python-3.10-compatibility.patch
- sha256sums = 2a16ca0f1c2c34aebe9698aa84cae3695eea509eaa7496011d1bab0f8ac78a1f
+ source = add_broken_warning.patch
+ sha256sums = e2c168129e19011bf7d138914df87fb5ea85f12a4d253bc6f1740fd1d060c670
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6cca8bfea086..abcdecaf7f21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Fabian Schoelzel <myfirstname.mylastname@googlemail.com>
pkgname=pyfa
-pkgver=2.39.2
+pkgver=2.39.3
pkgrel=2
_distname="Pyfa-${pkgver}"
pkgdesc="EVE Online Fitting Assistant"
@@ -20,17 +20,24 @@ source=(${pkgname}-${pkgver}.tar.gz::https://github.com/pyfa-org/Pyfa/archive/v$
pyfa.desktop
pyfa-start.sh
0001-python-3.10-compatibility.patch
+ add_broken_warning.patch
)
-sha256sums=('2a16ca0f1c2c34aebe9698aa84cae3695eea509eaa7496011d1bab0f8ac78a1f'
- SKIP SKIP SKIP)
+sha256sums=('e2c168129e19011bf7d138914df87fb5ea85f12a4d253bc6f1740fd1d060c670'
+ SKIP SKIP SKIP SKIP)
build() {
cd "${srcdir}"/"${_distname}"
+
# "Temporary" fix for python310 and wxPython>4.0.6
echo "Applying 0001-python-3.10-compatibility.patch"
patch --binary -l -p1 < ../0001-python-3.10-compatibility.patch
+
+ echo "Applying add_broken_warning.patch"
+ patch --binary -l -p1 < ../add_broken_warning.patch
+
python db_update.py
+ find . -name "__pycache__" -type d -prune -exec rm -r "{}" \;
}
package() {
@@ -52,11 +59,16 @@ package() {
cp -a "${srcdir}"/"${_distname}"/imgs "${pkgdir}"/usr/share/pyfa
cp -a "${srcdir}"/"${_distname}"/service "${pkgdir}"/usr/share/pyfa
cp -a "${srcdir}"/"${_distname}"/utils "${pkgdir}"/usr/share/pyfa
-
+
install -dm755 "${pkgdir}"/usr/share/pixmaps
install -Dm644 "${srcdir}"/"${_distname}"/imgs/gui/pyfa64.png "${pkgdir}"/usr/share/pixmaps/pyfa.png
install -Dm644 "${srcdir}"/pyfa.desktop "${pkgdir}"/usr/share/applications/pyfa.desktop
install -Dm755 "${srcdir}"/pyfa-start.sh "${pkgdir}"/usr/bin/pyfa
+
+ echo -e "\n!!! THIS PACKAGE IS PARTIALLY BROKEN !!!"
+ echo "wxPython, dependency of Pyfa, is incomaptible with python3.10 (for now)."
+ echo "For more details (and place for bug reports) see: https://github.com/pyfa-org/Pyfa/issues/2391"
+ echo -e "Known issues:\n- Implants tab does not work and will keep erroring out until closed\n"
}
diff --git a/add_broken_warning.patch b/add_broken_warning.patch
new file mode 100644
index 000000000000..d312636125bf
--- /dev/null
+++ b/add_broken_warning.patch
@@ -0,0 +1,35 @@
+From 2de69a76165678e50df8975a3434a2a11fb4c88b Mon Sep 17 00:00:00 2001
+From: wereii <8504482+wereii@users.noreply.github.com>
+Date: Sun, 13 Feb 2022 19:00:39 +0100
+Subject: [PATCH] Add broken warning to error dialog
+
+---
+ gui/errorDialog.py | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/gui/errorDialog.py b/gui/errorDialog.py
+index 769821091..32c2fda5c 100644
+--- a/gui/errorDialog.py
++++ b/gui/errorDialog.py
+@@ -83,6 +83,18 @@ class ErrorFrame(AuxiliaryFrame):
+ "information about how this was triggered. Please contact the developers with the \n"
+ "information provided through the EVE Online forums or file a GitHub issue.")
+
++ desc = desc + "\n".join(
++ (
++ "\n!!!", # yep, double newline
++ "AUR PACKAGER WARNING: Pyfa is currently BROKEN on Arch Linux, many errors are to be expected.",
++ "There are some incompatibilites between Pyfa's dependency - wxPython and python3.10.",
++ "Until that is resolved some functionality of Pyfa will not work.",
++ "",
++ "PLEASE do not create new issues in Pyfa repository, instead use Pyfa's AUR page or this issue:",
++ "https://github.com/pyfa-org/Pyfa/issues/2391",
++ )
++ )
++
+ self.SetSizeHints(wx.DefaultSize, wx.DefaultSize)
+
+ mainSizer = wx.BoxSizer(wx.VERTICAL)
+--
+2.35.1
+