summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRustam Aliyev2020-04-15 16:57:45 +0900
committerRustam Aliyev2020-04-15 16:57:45 +0900
commit2a02e5acb290e40bde6e05c6a521ca27e2c02699 (patch)
tree0b4697a1ca127fb39943be9e2e5a3d380c60a915
parent8f84de552efd0f6b6abad95326652f5154facaef (diff)
downloadaur-2a02e5acb290e40bde6e05c6a521ca27e2c02699.tar.gz
Update to 0.2.5.1
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md15
-rw-r--r--PKGBUILD6
3 files changed, 19 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0237048e4f48..1563f7362599 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyflow
pkgdesc = An installation and dependency system for Python
- pkgver = 0.2.4
+ pkgver = 0.2.5.1
pkgrel = 1
url = https://github.com/David-OConnor/pyflow
changelog = CHANGELOG.md
@@ -10,9 +10,9 @@ pkgbase = pyflow
checkdepends = cargo
makedepends = cargo
depends = xz
- source = https://github.com/David-OConnor/pyflow/archive/0.2.4.tar.gz
+ source = https://github.com/David-OConnor/pyflow/archive/0.2.5.1.tar.gz
validpgpkeys = B3D4420410BC16F84C358DF6AF36488D565A347A
- b2sums = 75cf6463928ed34ac9234973d00ea9b087df8b6fb0aff75e11b99b91eb1bef76c32c898e81d9f5dff5350efbf7d51c816200cc89052837ce54c2a875c2a126f5
+ b2sums = d1b97ad55a7571aa8dfb6e1cd863d49207185a1895957b5776f710fa5b60474c27da120907b4d8973ca7c59ce22ef8fa67dc66a898bdb381c32fa8aedb29ec07
pkgname = pyflow
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 5b0ab4348c31..83e4f6e10262 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,5 +1,16 @@
# Changelog
+## v0.2.5
+- Added support for `manylinux2014` spec
+- If a dependencies dependencies are specified multiple times, merge `extras`
+by omission. This led to bugs where dependencies didn't get installed when
+specified both as an extras and as not
+- Dependencies specifying `sys_platform == "win32"` now applies to 64-bit
+Windows installations as well. This should fix cases where Windows dependencies
+weren't being installed.
+- Fixed a dependency-installation bug triggered by symlinks inside Pypi source archives
+- `pyflow new` no longer creates a `LICENSE` file
+
## v0.2.4
- Fixed a bug where `pyflow script` was broken
- Fixed a bug where `pyflow init` was broken
@@ -21,7 +32,7 @@ in the current path.
## v0.1.9
- Can now parse subdependencies of `path` requirements from built-wheels
-- Fixed a bug where subdep contraints specified on multiple lines would
+- Fixed a bug where subdep constraints specified on multiple lines would
cause resolution to fail
- Fixed a bug parsing METADATA requirements that includes extras, but no version
@@ -69,7 +80,7 @@ pip now to install `twine`.
## v0.1.1
- Fixed a bug, where spaces could prevent console scripts from being installed
-- Fixed parsing pypi requirements that ommit parenthesis
+- Fixed parsing pypi requirements that omit parentheses
- Now uses `~/.local/share/pyflow` on Linux, `~\AppData\Roaming\pyflow` on Windows, and
`~/Library/Application Support/pyflow` on Mac, instead of `~/.python-installs`
diff --git a/PKGBUILD b/PKGBUILD
index 80cddc9ca5cb..2fee97d83ae5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Rustam Aliyev <ru5j4r0@google.com>
pkgname=pyflow
-pkgver=0.2.4
+pkgver=0.2.5.1
pkgrel=1
pkgdesc="An installation and dependency system for Python"
arch=('x86_64' 'i686')
@@ -10,8 +10,8 @@ depends=('xz')
makedepends=('cargo')
checkdepends=('cargo')
changelog=CHANGELOG.md
-source=("https://github.com/David-OConnor/pyflow/archive/0.2.4.tar.gz")
-b2sums=(75cf6463928ed34ac9234973d00ea9b087df8b6fb0aff75e11b99b91eb1bef76c32c898e81d9f5dff5350efbf7d51c816200cc89052837ce54c2a875c2a126f5)
+source=("https://github.com/David-OConnor/pyflow/archive/0.2.5.1.tar.gz")
+b2sums=(d1b97ad55a7571aa8dfb6e1cd863d49207185a1895957b5776f710fa5b60474c27da120907b4d8973ca7c59ce22ef8fa67dc66a898bdb381c32fa8aedb29ec07)
validpgpkeys=(B3D4420410BC16F84C358DF6AF36488D565A347A)
build() {