summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracd4072024-04-18 09:27:43 +0800
committeracd4072024-04-18 09:27:43 +0800
commitd37711dbef92748e2de5223e371a2bde925a6f3b (patch)
tree5aca6437d9dfcb143a6695c2349524f1f04b56a9
downloadaur-d37711dbef92748e2de5223e371a2bde925a6f3b.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f0ec497cfde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pyfluidsynth-git
+ pkgdesc = Python bindings for FluidSynth
+ pkgver = r66.98b22fb
+ pkgrel = 1
+ url = http://code.google.com/p/pyfluidsynth
+ arch = any
+ license = LGPL
+ makedepends = git
+ depends = fluidsynth
+ conflicts = pyfluidsynth
+ source = pyfluidsynth::git+https://github.com/nwhitehead/pyfluidsynth.git
+ md5sums = SKIP
+
+pkgname = pyfluidsynth-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad8966737e48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: acd407 <acd407@qq.com>
+# Maintainer: masutu <masutu dot arch at gmail dot com>
+# Contributor: masutu <masutu dot arch at gmail dot com>
+
+pkgname=pyfluidsynth-git
+_pkgname=pyfluidsynth
+pkgver=r66.98b22fb
+pkgrel=1
+pkgdesc="Python bindings for FluidSynth"
+arch=('any')
+url="http://code.google.com/p/pyfluidsynth"
+license=('LGPL')
+depends=('fluidsynth')
+makedepends=('git')
+conflicts=("${_pkgname}")
+source=("${_pkgname}"::"git+https://github.com/nwhitehead/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py bdist_wheel
+}
+
+package() {
+ cd "$_pkgname"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}