summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2020-02-02 22:06:02 +0100
committerfunilrys2020-02-02 22:06:02 +0100
commit8609b4d3e7eb8f2aa189d7ad193c2ac2630ed425 (patch)
tree173f665513f9d7c69737a4575d4c2c4f57947fd0
parent0a1b8db43d943906fc88c169e1134a385a4debd6 (diff)
downloadaur-8609b4d3e7eb8f2aa189d7ad193c2ac2630ed425.tar.gz
Update PyFunceble to v3.0.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD25
2 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 350a3b423ee4..002a92e45993 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,29 @@
pkgbase = pyfunceble
- pkgdesc = The tool to check the availability or syntax of domains, IPv4 or URL.
- pkgver = 2.2.0
- pkgrel = 3
+ pkgdesc = The tool to check the availability or syntax of domains, IPv4, IPv6 or URL.
+ pkgver = 3.0.0
+ pkgrel = 1
url = https://funilrys.github.io/PyFunceble/
arch = any
license = MIT
- depends = python3
- depends = python-distribute
- depends = python-setuptools
+ depends = domain2idna
+ depends = python-box
depends = python-colorama
+ depends = python-cryptography
+ depends = python-distribute
+ depends = python-dnspython
+ depends = python-dotenv
depends = python-pyaml
- depends = python-urllib3
+ depends = python-pymysql
depends = python-requests
- depends = domain2idna
- provides = pyfunceble=2.2.0
+ depends = python-setuptools
+ depends = python-urllib3
+ depends = python3
+ provides = pyfunceble=3.0.0
conflicts = pyfunceble-dev
- source = https://files.pythonhosted.org/packages/source/p/pyfunceble/PyFunceble-2.2.0.tar.gz
+ source = https://files.pythonhosted.org/packages/source/p/pyfunceble/PyFunceble-3.0.0.tar.gz
source = https://raw.githubusercontent.com/funilrys/PyFunceble/master/LICENSE
- sha256sums = 0723af172bb6ec6a6e7197b5dc1285360e5edeef93f1d621078e62058501200b
- sha256sums = f03d3823524595a13999f7f0805b4189805e60a620175dc71e89ead03495c49f
+ sha256sums = 69a78960edb9dafb10ad74eb63aba821dd6468cdf4777ccb7849633f2642984a
+ sha256sums = a11e4be5b3b09e157217214008e7f0e23092d26adb03ad593e51cffe18361508
pkgname = pyfunceble
diff --git a/PKGBUILD b/PKGBUILD
index f1d1329c34a0..5b94daea684f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,31 +4,36 @@ _appName="pyfunceble"
pkgname=${_appName}
_name=${pkgname}
upstreamName="PyFunceble"
-pkgver=2.2.0
-pkgrel=3
-pkgdesc="The tool to check the availability or syntax of domains, IPv4 or URL."
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="The tool to check the availability or syntax of domains, IPv4, IPv6 or URL."
arch=('any')
url="https://funilrys.github.io/PyFunceble/"
license=('MIT')
conflicts=('pyfunceble-dev')
provides=("pyfunceble=${pkgver}")
depends=(
- 'python3'
- 'python-distribute'
- 'python-setuptools'
+ 'domain2idna'
+ 'python-box'
'python-colorama'
+ 'python-cryptography'
+ 'python-distribute'
+ 'python-dnspython'
+ 'python-dotenv'
'python-pyaml'
- 'python-urllib3'
+ 'python-pymysql'
'python-requests'
- 'domain2idna'
+ 'python-setuptools'
+ 'python-urllib3'
+ 'python3'
)
source=(
"https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${upstreamName}-${pkgver}.tar.gz"
"https://raw.githubusercontent.com/funilrys/PyFunceble/master/LICENSE"
)
sha256sums=(
- "0723af172bb6ec6a6e7197b5dc1285360e5edeef93f1d621078e62058501200b"
- "f03d3823524595a13999f7f0805b4189805e60a620175dc71e89ead03495c49f"
+ "69a78960edb9dafb10ad74eb63aba821dd6468cdf4777ccb7849633f2642984a"
+ "a11e4be5b3b09e157217214008e7f0e23092d26adb03ad593e51cffe18361508"
)
build() {