summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2020-09-13 12:27:55 +0200
committerfunilrys2020-09-13 12:27:55 +0200
commit96b83d099e07dd576afcaa1abb6de87d826dcbe5 (patch)
tree5c214f96ddfc69af1637da4b74b5061c5467560b
parentda3146c69af91a27d32035fdc891b5f726ec5a11 (diff)
downloadaur-96b83d099e07dd576afcaa1abb6de87d826dcbe5.tar.gz
Update PyFunceble to v3.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--logging214
3 files changed, 220 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1d530c1e809..5129ba2833e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyfunceble
pkgdesc = The tool to check the availability or syntax of domain, IP or URL.
- pkgver = 3.3.1
+ pkgver = 3.3.2
pkgrel = 1
url = https://pyfunceble.github.io
arch = any
@@ -23,11 +23,11 @@ pkgbase = pyfunceble
depends = python-sqlalchemy
depends = python-toml
depends = python3
- provides = pyfunceble=3.3.1
+ provides = pyfunceble=3.3.2
conflicts = pyfunceble-dev
- source = https://files.pythonhosted.org/packages/source/p/pyfunceble/PyFunceble-3.3.1.tar.gz
+ source = https://files.pythonhosted.org/packages/source/p/pyfunceble/PyFunceble-3.3.2.tar.gz
source = https://raw.githubusercontent.com/funilrys/PyFunceble/master/LICENSE
- sha256sums = d1d06554d911e42a91763911248b17715cc7f893a05a3b14281d21213233e906
+ sha256sums = 115bea76dce2cca29e6afb8524dab2112bf335d62a25aae1de5f8f4ab6a6e52f
sha256sums = 2b8dc0c3f5c9a4042778b31496a0bf65f1aa6a516afa556d3d9426dbe2a92d48
pkgname = pyfunceble
diff --git a/PKGBUILD b/PKGBUILD
index a81b118d6fdf..6939a9eec732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _appName="pyfunceble"
pkgname=${_appName}
_name=${pkgname}
upstreamName="PyFunceble"
-pkgver=3.3.1
+pkgver=3.3.2
pkgrel=1
pkgdesc="The tool to check the availability or syntax of domain, IP or URL."
arch=('any')
@@ -37,7 +37,7 @@ source=(
"https://raw.githubusercontent.com/funilrys/PyFunceble/master/LICENSE"
)
sha256sums=(
- "d1d06554d911e42a91763911248b17715cc7f893a05a3b14281d21213233e906"
+ "115bea76dce2cca29e6afb8524dab2112bf335d62a25aae1de5f8f4ab6a6e52f"
"2b8dc0c3f5c9a4042778b31496a0bf65f1aa6a516afa556d3d9426dbe2a92d48"
)
diff --git a/logging b/logging
new file mode 100644
index 000000000000..c598f640e32c
--- /dev/null
+++ b/logging
@@ -0,0 +1,214 @@
+logging {
+ channel default_log {
+ file "/var/named/logs/default.log" versions 3 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+ channel auth_servers_log {
+ file "/var/named/logs/auth_servers.log" versions 100 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+ channel dnssec_log {
+ file "/var/named/logs/dnssec.log" versions 3 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+ channel zone_transfers_log {
+ file "/var/named/logs/zone_transfers.log" versions 3 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+ channel ddns_log {
+ file "/var/named/logs/ddns.log" versions 3 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+ channel client_security_log {
+ file "/var/named/logs/client_security.log" versions 3 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+ channel rate_limiting_log {
+ file "/var/named/logs/rate_limiting.log" versions 3 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+ channel rpz_log {
+ file "/var/named/logs/rpz.log" versions 3 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+ channel dnstap_log {
+ file "/var/named/logs/dnstap.log" versions 3 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity info;
+ };
+//
+// If you have the category ‘queries’ defined, and you don’t want query logging
+// by default, make sure you add option ‘querylog no;’ - then you can toggle
+// query logging on (and off again) using command ‘rndc querylog’
+//
+// channel queries_log {
+// file "/var/named/logs/queries.log" versions 600 size 20m;
+// print-time yes;
+// print-category yes;
+// print-severity yes;
+// severity info;
+// };
+//
+// This channel is dynamic so that when the debug level is increased using
+// rndc while the server is running, extra information will be logged about
+// failing queries.  Other debug information for other categories will be
+// sent to the channel default_debug (which is also dynamic), but without
+// affecting the regular logging.
+//
+ channel query-errors_log {
+ file "/var/named/logs/query.log-errors" versions 5 size 20m;
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ severity dynamic;
+ };
+//
+// This is the default syslog channel, defined here for clarity.  You don’t
+// have to use it if you prefer to log to your own channels.
+// It sends to syslog’s daemon facility, and sends only logged messages
+// of priority info and higher.
+// (The options to print time, category and severity are non-default.)
+//
+ channel default_syslog {
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ syslog daemon;
+ severity info;
+ };
+//
+// This is the default debug output channel, defined here for clarity.  You
+// might want to redefine the output destination if it doesn’t fit with your
+// local system administration plans for logging.  It is also a special
+// channel that only produces output if the debug level is non-zero.
+//
+ channel default_debug {
+ print-time yes;
+ print-category yes;
+ print-severity yes;
+ file "named.run";
+ severity dynamic;
+ };
+//
+// Log routine stuff to syslog and default log:
+//
+ category default { default_syslog; default_debug; default_log; };
+ category config { default_syslog; default_debug; default_log; };
+ category dispatch { default_syslog; default_debug; default_log; };
+ category network { default_syslog; default_debug; default_log; };
+ category general { default_syslog; default_debug; default_log; };
+//
+// From BIND 9.12 and newer, you can direct zone load logging to another
+// channel with the new zoneload logging category.  If this would be useful
+// then firstly, configure the new channel, and then edit the line below
+// to direct the category there instead of to syslog and default log:
+//
+ category zoneload { default_syslog; default_debug; default_log; };
+//
+// Log messages relating to what we got back from authoritative servers during
+// recursion (if lame-servers and edns-disabled are obscuring other messages
+// they can be sent to their own channel or to null).  Sometimes these log
+// messages will be useful to research why some domains don’t resolve or
+// don’t resolve reliably
+//
+ category resolver { auth_servers_log; default_debug; };       
+ category cname { auth_servers_log; default_debug; };       
+ category delegation-only { auth_servers_log; default_debug; };
+ category lame-servers { auth_servers_log; default_debug; };
+ category edns-disabled { auth_servers_log; default_debug; };
+//
+// Log problems with DNSSEC:
+//
+ category dnssec { dnssec_log; default_debug; };
+//
+// Log together all messages relating to authoritative zone propagation
+//
+ category notify { zone_transfers_log; default_debug; };       
+ category xfer-in { zone_transfers_log; default_debug; };       
+ category xfer-out { zone_transfers_log; default_debug; };
+//
+// Log together all messages relating to dynamic updates to DNS zone data:
+//
+ category update{ ddns_log; default_debug; };
+ category update-security { ddns_log; default_debug; };
+//
+// Log together all messages relating to client access and security.
+// (There is an additional category ‘unmatched’ that is by default sent to
+// null but which can be added here if you want more than the one-line
+// summary that is logged for failures to match a view).
+//
+ category client{ client_security_log; default_debug; };       
+ category security { client_security_log; default_debug; };
+//
+// Log together all messages that are likely to be related to rate-limiting.
+// This includes RRL (Response Rate Limiting) - usually deployed on authoritative
+// servers and fetches-per-server|zone.  Note that it does not include
+// logging of changes for clients-per-query (which are logged in category
+// resolver).  Also note that there may on occasions be other log messages
+// emitted by the database category that don’t relate to rate-limiting
+// behaviour by named.
+//
+ category rate-limit { rate_limiting_log; default_debug; };       
+ category spill { rate_limiting_log; default_debug; };       
+ category database { rate_limiting_log; default_debug; };
+//
+// Log DNS-RPZ (Response Policy Zone) messages (if you are not using DNS-RPZ
+// then you may want to comment out this category and associated channel)
+//
+// category rpz { rpz_log; default_debug; };
+//
+// Log messages relating to the "dnstap" DNS traffic capture system  (if you
+// are not using dnstap, then you may want to comment out this category and
+// associated channel).
+//
+// category dnstap { dnstap_log; default_debug; };
+//
+// If you are running a server (for example one of the Internet root
+// nameservers) that is providing RFC 5011 trust anchor updates, then you
+// may be interested in logging trust anchor telemetry reports that your
+// server receives to analyze anchor propagation rates during a key rollover.
+// If this would be useful then firstly, configure the new channel, and then
+// un-comment and the line below to direct the category there instead of to
+// syslog and default log:
+//
+//
+ category trust-anchor-telemetry { default_syslog; default_debug; default_log; };
+//
+// If you have the category ‘queries’ defined, and you don’t want query logging
+// by default, make sure you add option ‘querylog no;’ - then you can toggle
+// query logging on (and off again) using command ‘rndc querylog’
+//
+ category queries { queries_log; };
+//
+// This logging category will only emit messages at debug levels of 1 or
+// higher - it can be useful to troubleshoot problems where queries are
+// resulting in a SERVFAIL response.
+//
+ category query-errors {query-errors_log; };
+};