summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2019-03-01 23:19:22 +0100
committerfunilrys2019-03-01 23:19:22 +0100
commitaffb619ea9613a99a299ff55963ab30f60359ffe (patch)
treeed9881279179b06f6444037d04ab19cabadde221
downloadaur-affb619ea9613a99a299ff55963ab30f60359ffe.tar.gz
Introduction of pyfunceble
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f012fa38455
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pyfunceble
+ pkgdesc = The tool to check the availability or syntax of domains, IPv4 or URL.
+ pkgver = 1.15.1
+ pkgrel = 1
+ url = https://funilrys.github.io/PyFunceble/
+ arch = any
+ license = MIT
+ depends = python3
+ depends = python-distribute
+ depends = python-setuptools
+ depends = python-colorama
+ depends = python-pyaml
+ depends = python-urllib3
+ depends = python-requests
+ depends = domain2idna
+ provides = pyfunceble=1.15.1
+ conflicts = pyfunceble-dev
+ source = https://files.pythonhosted.org/packages/source/p/pyfunceble/PyFunceble-1.15.1.tar.gz
+ source = https://raw.githubusercontent.com/funilrys/PyFunceble/master/LICENSE
+ sha256sums = 42d657b8b4f7f556682b9a11597cb8768d5e88edf5ff69b62cc70c4498cb70c2
+ sha256sums = b6f0b000fe7b60a2d6d8b31454d705d928c6ffa8783722ba5c0419dd2c9084e4
+
+pkgname = pyfunceble
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e53cce52084
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Nissar Chababy <contact at funilrys dot com>
+
+_appName="pyfunceble"
+pkgname=${_appName}
+_name=${pkgname}
+upstreamName="PyFunceble"
+pkgver=1.15.1
+pkgrel=1
+pkgdesc="The tool to check the availability or syntax of domains, IPv4 or URL."
+arch=('any')
+url="https://funilrys.github.io/PyFunceble/"
+license=('MIT')
+conflicts=('pyfunceble-dev')
+provides=("pyfunceble=${pkgver}")
+depends=(
+ 'python3'
+ 'python-distribute'
+ 'python-setuptools'
+ 'python-colorama'
+ 'python-pyaml'
+ 'python-urllib3'
+ 'python-requests'
+ 'domain2idna'
+)
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${upstreamName}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/funilrys/PyFunceble/master/LICENSE"
+)
+sha256sums=(
+ "42d657b8b4f7f556682b9a11597cb8768d5e88edf5ff69b62cc70c4498cb70c2"
+ "b6f0b000fe7b60a2d6d8b31454d705d928c6ffa8783722ba5c0419dd2c9084e4"
+)
+
+build() {
+ cd ${srcdir}/${upstreamName}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd ${srcdir}/${upstreamName}-${pkgver}
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}