summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2013-06-06 22:14:06 +0900
committerBenjamin Chrétien2013-06-06 22:14:06 +0900
commit5e85f30d5130928b7bb70231e45bf54a474d4fa8 (patch)
tree5f209a81d7e19811d0d45dabe9820a0849ba83e6
downloadaur-5e85f30d5130928b7bb70231e45bf54a474d4fa8.tar.gz
Add original pygccxml PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa2147e9a6be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pygccxml
+ pkgdesc = The purpose of pygccxml is to read a generated file and provide a simple framework to navigate C++ declarations, using Python classes.
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = http://www.language-binding.net/pygccxml/pygccxml.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gccxml-cvs
+ depends = python2
+ options = !strip
+ source = http://jaist.dl.sourceforge.net/sourceforge/pygccxml/pygccxml-1.0.0.zip
+ md5sums = 44badbf8c4bcd3095290a90f2f2a9234
+
+pkgname = pygccxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf6aa3b3e037
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: zarra <zarraxx@gmail.com>
+pkgname=pygccxml
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="The purpose of pygccxml is to read a generated file and provide a simple framework to navigate C++ declarations, using Python classes."
+arch=('i686' 'x86_64')
+url="http://www.language-binding.net/pygccxml/pygccxml.html"
+license=('custom')
+depends=('gccxml-cvs' 'python2')
+options=(!strip)
+
+source=(http://jaist.dl.sourceforge.net/sourceforge/pygccxml/pygccxml-${pkgver}.zip)
+
+md5sums=('44badbf8c4bcd3095290a90f2f2a9234')
+
+
+build() {
+ cd "$srcdir/pygccxml-${pkgver}"
+
+ python2 setup.py build || return 1
+ python2 setup.py install --prefix=/usr --root=$startdir/pkg
+
+}
+
+# vim:set ts=2 sw=2 et: