summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2015-07-22 19:21:45 +0800
committerwangjiezhe2015-07-22 19:21:45 +0800
commit7530212d369656a59bad5f7581812c740f2791a2 (patch)
tree70ed16ee10ce22b7a36d288c77e5f3c783bec6c3
parent1ea33984a5d0a6ca1bd43e8610c2f18dff201f62 (diff)
downloadaur-7530212d369656a59bad5f7581812c740f2791a2.tar.gz
Change pkgbase
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 125318d44a1e..8224e7f74bdf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = pygobject
+pkgbase = pygobject-patched
pkgver = 3.16.2
pkgrel = 1
url = https://live.gnome.org/PyGObject
diff --git a/PKGBUILD b/PKGBUILD
index 12b28b1a4263..1e04c028d8ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# $Id: PKGBUILD 241024 2015-06-18 22:16:52Z heftig $
# Maintainer: Ionut Biru <ibiru@archlinux.org>
-pkgbase=pygobject
+pkgbase=pygobject-patched
pkgname=(python-gobject-patched python2-gobject-patched)
pkgver=3.16.2
pkgrel=1
@@ -9,25 +9,25 @@ arch=(i686 x86_64)
url="https://live.gnome.org/PyGObject"
license=(LGPL)
makedepends=(python python2 python-cairo python2-cairo gobject-introspection gnome-common)
-source=("http://ftp.gnome.org/pub/gnome/sources/$pkgbase/${pkgver:0:4}/$pkgbase-$pkgver.tar.xz"
+source=("http://ftp.gnome.org/pub/gnome/sources/${pkgbase%-patched}/${pkgver:0:4}/${pkgbase%-patched}-$pkgver.tar.xz"
"01_cairo_region.patch")
sha256sums=('de620e00fe7ecb788aa2dc0d664e41f71b8e718e728168e8d982cf193a9e7e64'
'194fc7946beb01d02a3fba587a214f2f38da56e3b63ecc9b7de37da210488919')
prepare() {
mkdir -p build-py2 build-py3
- cd ${pkgbase}-${pkgver}
+ cd ${pkgbase%-patched}-${pkgver}
sed -i '/Werror=format/d' configure # gcc 4.8
patch -Np1 -i ../01_cairo_region.patch
}
build() {
cd build-py2
- ../${pkgbase}-${pkgver}/configure --prefix=/usr --with-python=/usr/bin/python2
+ ../${pkgbase%-patched}-${pkgver}/configure --prefix=/usr --with-python=/usr/bin/python2
make
cd ../build-py3
- ../${pkgbase}-${pkgver}/configure --prefix=/usr
+ ../${pkgbase%-patched}-${pkgver}/configure --prefix=/usr
make
}