summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2016-04-10 10:57:04 +0800
committerwangjiezhe2016-04-10 10:57:04 +0800
commitcfe9ea2b84147aef44bde9ad067afc6e3414e96f (patch)
tree662c272cc7fc6cbdedcd222ae645fb713e93b714
parentc2d49017b620d9447e17db30a0e96fe62e9435bc (diff)
downloadaur-cfe9ea2b84147aef44bde9ad067afc6e3414e96f.tar.gz
Updpkg to 3.20.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51bcf4afdbc8..eec9bb145958 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,7 @@
+# Generated by mksrcinfo v8
+# Sun Apr 10 02:56:55 UTC 2016
pkgbase = pygobject-patched
- pkgver = 3.18.2
+ pkgver = 3.20.0
pkgrel = 1
url = https://live.gnome.org/PyGObject
arch = i686
@@ -10,27 +12,26 @@ pkgbase = pygobject-patched
makedepends = python-cairo
makedepends = python2-cairo
makedepends = gobject-introspection
- makedepends = gnome-common
- source = http://ftp.gnome.org/pub/gnome/sources/pygobject/3.18/pygobject-3.18.2.tar.xz
+ source = https://download.gnome.org/sources/pygobject/3.20/pygobject-3.20.0.tar.xz
source = 01_cairo_region.patch
- sha256sums = 2a3cad1517916b74e131e6002c3824361aee0671ffb0d55ded119477fc1c2c5f
+ sha256sums = 31ab4701f40490082aa98af537ccddba889577abe66d242582f28577e8807f46
sha256sums = 194fc7946beb01d02a3fba587a214f2f38da56e3b63ecc9b7de37da210488919
pkgname = python-gobject-patched
pkgdesc = Python 3 bindings for GObject, with a patch for cairo
depends = gobject-introspection-runtime
- depends = pygobject-devel=3.18.2
+ depends = pygobject-devel=3.20.0
depends = python
depends = cairo
- provides = python-gobject=3.18.2
+ provides = python-gobject=3.20.0
conflicts = python-gobject
pkgname = python2-gobject-patched
pkgdesc = Python 2 bindings for GObject, with a patch for cairo
depends = gobject-introspection-runtime
- depends = pygobject-devel=3.18.2
+ depends = pygobject-devel=3.20.0
depends = python2
depends = cairo
- provides = python2-gobject=3.18.2
+ provides = python2-gobject=3.20.0
conflicts = python2-gobject
diff --git a/PKGBUILD b/PKGBUILD
index ff515db8c625..b91fbb4b2da0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
-# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
+# Contrubutor: Ionut Biru <ibiru@archlinux.org>
+# Maintainer: wangjiezhe <wangjiezhe AT yandex DOT com>
_pkgbase=pygobject
pkgbase=pygobject-patched
pkgname=(python-gobject-patched python2-gobject-patched)
-pkgver=3.18.2
+pkgver=3.20.0
pkgrel=1
arch=(i686 x86_64)
url="https://live.gnome.org/PyGObject"
license=(LGPL)
-makedepends=(python python2 python-cairo python2-cairo gobject-introspection gnome-common)
-source=("http://ftp.gnome.org/pub/gnome/sources/${_pkgbase}/${pkgver:0:4}/${_pkgbase}-$pkgver.tar.xz"
+makedepends=(python python2 python-cairo python2-cairo gobject-introspection)
+source=("https://download.gnome.org/sources/${_pkgbase}/${pkgver:0:4}/${_pkgbase}-${pkgver}.tar.xz"
"01_cairo_region.patch")
-sha256sums=('2a3cad1517916b74e131e6002c3824361aee0671ffb0d55ded119477fc1c2c5f'
+sha256sums=('31ab4701f40490082aa98af537ccddba889577abe66d242582f28577e8807f46'
'194fc7946beb01d02a3fba587a214f2f38da56e3b63ecc9b7de37da210488919')
prepare() {
@@ -24,10 +24,12 @@ prepare() {
build() {
cd build-py2
../${_pkgbase}-${pkgver}/configure --prefix=/usr --with-python=/usr/bin/python2
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
cd ../build-py3
../${_pkgbase}-${pkgver}/configure --prefix=/usr --with-python=/usr/bin/python
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
@@ -53,5 +55,3 @@ package_python2-gobject-patched() {
rm -r "$pkgdir"/usr/{include,lib/pkgconfig}
python2 -m compileall "$pkgdir"//usr/lib/python2.7/site-packages/gi
}
-
-# vim:set ts=2 sw=2 et: