summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchuvke2016-05-28 23:30:16 +0200
committerchuvke2016-05-28 23:30:16 +0200
commit41fc18a51bceaf023d5cf22e4f6d3396cf8f1d7a (patch)
tree126489cc1ac27cf9b37d287b4b574fb52497aafe
downloadaur-41fc18a51bceaf023d5cf22e4f6d3396cf8f1d7a.tar.gz
Initial version of pygrid
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
-rw-r--r--pygrid.desktop3
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faacab35049d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pygrid
+ pkgdesc = Quickly place and move windows around the X11 desktop using a grid
+ pkgver = 307e7fb
+ pkgrel = 1
+ url = https://github.com/mjs7231/pygrid
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = python
+ depends = python-gobject
+ depends = python-xlib
+ source = pygrid::git+https://github.com/mjs7231/pygrid.git#commit=307e7fbecf043d2ed9f9129bec177dc8d93185c7
+ source = pygrid.desktop
+ sha256sums = SKIP
+ sha256sums = d39d8dae7f8326a41309132101175a36bd042e42f2cfde15cf8c12a69b5ef945
+
+pkgname = pygrid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74b617ef8e2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: chuvke <chuvke AT gmail DOT com>
+pkgname=pygrid
+pkgver=307e7fb
+pkgrel=1
+pkgdesc="Quickly place and move windows around the X11 desktop using a grid"
+arch=('i686' 'x86_64')
+url="https://github.com/mjs7231/pygrid"
+license=('GPL2')
+depends=(python python-gobject python-xlib)
+makedepends=('git')
+source=("$pkgname::git+https://github.com/mjs7231/pygrid.git#commit=307e7fbecf043d2ed9f9129bec177dc8d93185c7"
+ "pygrid.desktop")
+sha256sums=('SKIP'
+ 'd39d8dae7f8326a41309132101175a36bd042e42f2cfde15cf8c12a69b5ef945')
+
+package() {
+ install -Dm 644 "pygrid.desktop" "${pkgdir}/etc/xdg/autostart/pygrid.desktop"
+
+ cd "$pkgname"
+ install -Dm 755 "pygrid.py" "${pkgdir}/usr/bin/pygrid"
+}
diff --git a/pygrid.desktop b/pygrid.desktop
new file mode 100644
index 000000000000..c469d226a1f9
--- /dev/null
+++ b/pygrid.desktop
@@ -0,0 +1,3 @@
+[Desktop Entry]
+Type=Application
+Exec=pygrid