summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-03-29 19:09:42 +0000
committerAntonio Rojas2020-03-29 19:09:42 +0000
commit5adb45c8a63145d6a712d52e20fea95d2893a494 (patch)
tree477f1d0638589be2a17f648bb3a02dca43faf23d
downloadaur-5adb45c8a63145d6a712d52e20fea95d2893a494.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
-rw-r--r--fix-leaks-of-pango-objects.patch59
-rw-r--r--python27.patch50
4 files changed, 180 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd5d1901a07a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pygtk
+ pkgdesc = Python bindings for the GTK widget set
+ pkgver = 2.24.0
+ pkgrel = 8
+ url = http://www.pygtk.org/
+ arch = x86_64
+ license = LGPL
+ makedepends = python2-numpy
+ makedepends = pygobject2-devel
+ depends = libglade
+ depends = python2-cairo
+ depends = python2-gobject2
+ optdepends = python2-numpy
+ source = https://download.gnome.org/sources/pygtk/2.24/pygtk-2.24.0.tar.bz2
+ source = python27.patch
+ source = fix-leaks-of-pango-objects.patch
+ sha256sums = cd1c1ea265bd63ff669e92a2d3c2a88eb26bcd9e5363e0f82c896e649f206912
+ sha256sums = 39a30456cba055a452bb55c74ef1ff2f5f7bfaad22855b4dd569ab009b56b682
+ sha256sums = 0ca9e910e9bb88897089dd19752a419aa78de15463df766cb19a1d0c2dd45bcb
+
+pkgname = pygtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93cded0d49bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
+
+pkgname=pygtk
+pkgver=2.24.0
+pkgrel=8
+pkgdesc="Python bindings for the GTK widget set"
+url="http://www.pygtk.org/"
+arch=('x86_64')
+license=('LGPL')
+depends=('libglade' 'python2-cairo' 'python2-gobject2')
+makedepends=('python2-numpy' 'pygobject2-devel')
+optdepends=('python2-numpy')
+source=(https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ python27.patch
+ fix-leaks-of-pango-objects.patch)
+sha256sums=('cd1c1ea265bd63ff669e92a2d3c2a88eb26bcd9e5363e0f82c896e649f206912'
+ '39a30456cba055a452bb55c74ef1ff2f5f7bfaad22855b4dd569ab009b56b682'
+ '0ca9e910e9bb88897089dd19752a419aa78de15463df766cb19a1d0c2dd45bcb')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=623965
+ patch -Np1 -i "${srcdir}/python27.patch"
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=660216
+ patch -Np1 -i "${srcdir}/fix-leaks-of-pango-objects.patch"
+
+ # Python 2
+ sed -i -e 's#env python$#env python2#' examples/pygtk-demo/{,demos/}*.py
+
+ # No docs
+ sed -i '/^SUBDIRS =/s/docs//' Makefile.in
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --disable-docs
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -m644 gtk/gtk-extrafuncs.defs "${pkgdir}/usr/share/pygtk/2.0/defs/"
+}
diff --git a/fix-leaks-of-pango-objects.patch b/fix-leaks-of-pango-objects.patch
new file mode 100644
index 000000000000..c935dd6f2c23
--- /dev/null
+++ b/fix-leaks-of-pango-objects.patch
@@ -0,0 +1,59 @@
+From eca72baa5616fbe4dbebea43c7e5940847dc5ab8 Mon Sep 17 00:00:00 2001
+From: "Owen W. Taylor" <otaylor@fishsoup.net>
+Date: Tue, 27 Sep 2011 00:17:52 -0400
+Subject: Fix leaks of Pango objects
+
+Gtk.PrintContext.create_pango_context()
+Gtk.PrintContext.create_pango_layout()
+pangocairo.CairoContext.create_layout()
+
+were leaking the objects they returned.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=660216
+
+diff --git a/gtk/gtk-2.10.defs b/gtk/gtk-2.10.defs
+index 69c7e0c..faa45e1 100644
+--- a/gtk/gtk-2.10.defs
++++ b/gtk/gtk-2.10.defs
+@@ -1388,12 +1388,14 @@
+ (define-method create_pango_context
+ (of-object "GtkPrintContext")
+ (c-name "gtk_print_context_create_pango_context")
++ (caller-owns-return #t)
+ (return-type "PangoContext*")
+ )
+
+ (define-method create_pango_layout
+ (of-object "GtkPrintContext")
+ (c-name "gtk_print_context_create_pango_layout")
++ (caller-owns-return #t)
+ (return-type "PangoLayout*")
+ )
+
+diff --git a/pangocairo.override b/pangocairo.override
+index bb923e6..5101107 100644
+--- a/pangocairo.override
++++ b/pangocairo.override
+@@ -118,11 +118,16 @@ _wrap_pango_cairo_update_context(PyGObject *self, PyObject *args, PyObject *kwar
+ static PyObject *
+ _wrap_pango_cairo_create_layout(PyGObject *self)
+ {
+- PangoLayout *ret;
++ PangoLayout *layout;
++ PyObject *ret;
+
+- ret = pango_cairo_create_layout(PycairoContext_GET(self));
++ layout = pango_cairo_create_layout(PycairoContext_GET(self));
+ /* pygobject_new handles NULL checking */
+- return pygobject_new((GObject *)ret);
++ ret = pygobject_new((GObject *)layout);
++ if (layout)
++ g_object_unref(layout);
++
++ return ret;
+ }
+
+ static PyObject *
+--
+cgit v0.10.2
+
diff --git a/python27.patch b/python27.patch
new file mode 100644
index 000000000000..9bbe2b5ae20b
--- /dev/null
+++ b/python27.patch
@@ -0,0 +1,50 @@
+diff --git a/gtk/gtkmodule.c b/gtk/gtkmodule.c
+index c0e1493..aa8cf10 100644
+--- a/gtk/gtkmodule.c
++++ b/gtk/gtkmodule.c
+@@ -227,8 +227,12 @@ init_gtk(void)
+ pygtk_add_stock_items(d);
+
+ /* extension API */
+- PyDict_SetItemString(d, "_PyGtk_API",
+- o=PyCObject_FromVoidPtr(&functions, NULL));
++#if PY_VERSION_HEX >= 0x02070000
++ o = PyCapsule_New(&functions, "gtk._gtk._PyGtk_API", NULL);
++#else
++ o = PyCObject_FromVoidPtr(&functions, NULL);
++#endif
++ PyDict_SetItemString(d, "_PyGtk_API", o);
+ Py_DECREF(o);
+
+ PyGtkDeprecationWarning = PyErr_NewException("gtk.GtkDeprecationWarning",
+diff --git a/gtk/pygtk.h b/gtk/pygtk.h
+index 573c3b9..e4c680f 100644
+--- a/gtk/pygtk.h
++++ b/gtk/pygtk.h
+@@ -60,6 +60,18 @@ struct _PyGtk_FunctionStruct *_PyGtk_API;
+
+
+ /* a function to initialise the pygtk functions */
++
++/* Python 2.7 introduced the PyCapsule API and deprecated the CObject API */
++#if PY_VERSION_HEX >= 0x02070000
++#define init_pygtk() G_STMT_START { \
++ void *capsule = PyCapsule_Import("gtk._gtk._PyGtk_API", 0); \
++ if (!capsule) { \
++ return; \
++ } \
++ _PyGtk_API = (struct _PyGtk_FunctionStruct*)capsule; \
++} G_STMT_END
++#else /* PY_VERSION_HEX */
++/* Python 2.6 and earlier use the CObject API */
+ #define init_pygtk() G_STMT_START { \
+ PyObject *pygtk = PyImport_ImportModule("gtk"); \
+ if (pygtk != NULL) { \
+@@ -79,6 +91,7 @@ struct _PyGtk_FunctionStruct *_PyGtk_API;
+ return; \
+ } \
+ } G_STMT_END
++#endif /* PY_VERSION_HEX */
+
+ #endif
+