summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-21 18:26:50 +0300
committerDimitris Kiziridis2020-04-21 18:26:50 +0300
commitdab3e270b43664439a445debef45995ed0540074 (patch)
tree875f303c8a8c3e11cb209c4f20c282d6e8bbe315
parent6bd0b521a678b7589f720ebbee5b0dccfcd7ed68 (diff)
downloadaur-dab3e270b43664439a445debef45995ed0540074.tar.gz
add drop-pangofont.patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--drop-pangofont.patch41
3 files changed, 44 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d2bb3ac73cc..6fbdae9163d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = pygtk
depends = python2-gobject2
optdepends = python2-numpy
source = https://download.gnome.org/sources/pygtk/2.24/pygtk-2.24.0.tar.bz2
- source = https://gitlab.gnome.org/Archive/pygtk/-/commit/4aaa48eb80c6802aec6d03e5695d2a0ff20e0fc2.patch
+ source = drop-pangofont.patch
source = python27.patch
source = fix-leaks-of-pango-objects.patch
sha512sums = 64f4344fcf7636e0b2016ffd5310250b5c02a1bf87e44aef39b5d4cf4a5fc50d27cb4f030d4c6802cff61fffb88dee7752821e3d8a4cd1c34dc3745d9ff2f0da
diff --git a/PKGBUILD b/PKGBUILD
index 82bb1680f116..08b96880d904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ depends=('libglade' 'python2-cairo' 'python2-gobject2')
makedepends=('python2-numpy' 'pygobject2-devel')
optdepends=('python2-numpy')
source=("https://download.gnome.org/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
- "https://gitlab.gnome.org/Archive/pygtk/-/commit/4aaa48eb80c6802aec6d03e5695d2a0ff20e0fc2.patch"
+ 'drop-pangofont.patch'
'python27.patch'
'fix-leaks-of-pango-objects.patch')
sha512sums=('64f4344fcf7636e0b2016ffd5310250b5c02a1bf87e44aef39b5d4cf4a5fc50d27cb4f030d4c6802cff61fffb88dee7752821e3d8a4cd1c34dc3745d9ff2f0da'
@@ -29,7 +29,7 @@ prepare() {
patch -Np1 -i "${srcdir}/fix-leaks-of-pango-objects.patch"
# fix build with new pango:
# https://gitlab.gnome.org/Archive/pygtk/-/merge_requests/1
- patch -p1 -i ../4aaa48eb80c6802aec6d03e5695d2a0ff20e0fc2.patch
+ patch -p1 -i ../drop-pangofont.patch
# Python 2
sed -i -e 's#env python$#env python2#' examples/pygtk-demo/{,demos/}*.py
# No docs
diff --git a/drop-pangofont.patch b/drop-pangofont.patch
new file mode 100644
index 000000000000..0e549c1da8f7
--- /dev/null
+++ b/drop-pangofont.patch
@@ -0,0 +1,41 @@
+From 4aaa48eb80c6802aec6d03e5695d2a0ff20e0fc2 Mon Sep 17 00:00:00 2001
+From: Jordan Petridis <jpetridis@gnome.org>
+Date: Thu, 24 Oct 2019 22:58:36 +0200
+Subject: [PATCH] Drop the PangoFont find_shaper virtual method
+
+This API has been removed from Pango 1.44.6, because it was completely
+unused by anything.
+
+However, PyGTK tries to bind everything, even unused API.
+
+Removing this from PyGTK means we can build it against the latest Pango
+again.
+
+https://gitlab.gnome.org/GNOME/pango/issues/417
+---
+ pango.defs | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/pango.defs b/pango.defs
+index 6935c964..da968f58 100644
+--- a/pango.defs
++++ b/pango.defs
+@@ -1391,15 +1391,6 @@
+ )
+ )
+
+-(define-virtual find_shaper
+- (of-object "PangoFont")
+- (return-type "PangoEngineShape*")
+- (parameters
+- '("PangoLanguage*" "lang")
+- '("guint32" "ch")
+- )
+-)
+-
+ (define-virtual get_glyph_extents
+ (of-object "PangoFont")
+ (return-type "none")
+--
+2.24.2
+