summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStuart Cardall2022-09-04 10:36:03 +0100
committerStuart Cardall2022-09-04 10:36:03 +0100
commitaa3cd8dd0d811d219e0a67687bdeebbfeb6fe57d (patch)
treef20d8563d365247f18b9642cdf3ff40040c1841b
downloadaur-aa3cd8dd0d811d219e0a67687bdeebbfeb6fe57d.tar.gz
new PKGBUILD for pygubu-designer version 0.10
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
-rw-r--r--pygubu-designer.desktop10
-rw-r--r--tk-logo.svg38
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b85f066a51a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = pygubu-designer
+ pkgdesc = A simple GUI designer for the python tkinter module
+ pkgver = 0.10
+ pkgrel = 0
+ url = https://github.com/alejandroautalan/pygubu-designer
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python
+ depends = python-pygubu
+ depends = python-mako
+ depends = python-black
+ depends = python-screeninfo
+ depends = tk
+ depends = python-appdirs
+ source = pygubu-designer-0.10::https://github.com/alejandroautalan/pygubu-designer/archive/v0.10.tar.gz
+ source = tk-logo.svg
+ source = pygubu-designer.desktop
+ md5sums = 4840ae8bf7acfa4a149914cb31d1ceeb
+ md5sums = f60d13e5f87d15d764276387fc4627c2
+ md5sums = e745be7853e0343ff34e97d17607ec18
+
+pkgname = pygubu-designer
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfe15f4d2827
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Stuart Cardall <developer at it-offshore.co.uk>
+pkgname=pygubu-designer
+pkgver=0.10
+pkgrel=0
+pkgdesc="A simple GUI designer for the python tkinter module"
+url="https://github.com/alejandroautalan/pygubu-designer"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('python' 'python-pygubu' 'python-mako' 'python-black' 'python-screeninfo' 'tk'
+ 'python-appdirs')
+source=("${pkgname}-${pkgver}::https://github.com/alejandroautalan/${pkgname}/archive/v$pkgver.tar.gz"
+ "tk-logo.svg"
+ "pygubu-designer.desktop")
+md5sums=('4840ae8bf7acfa4a149914cb31d1ceeb'
+ 'f60d13e5f87d15d764276387fc4627c2'
+ 'e745be7853e0343ff34e97d17607ec18')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm755 "$srcdir/tk-logo.svg" "$pkgdir/usr/share/icons/pygubu.svg"
+ install -Dm755 "$srcdir/pygubu-designer.desktop" "$pkgdir/usr/share/applications/pygubu-designer.desktop"
+}
diff --git a/pygubu-designer.desktop b/pygubu-designer.desktop
new file mode 100644
index 000000000000..b38b3d5f3e51
--- /dev/null
+++ b/pygubu-designer.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Pygubu Designer
+GenericName=GUI Designer (TkInter)
+Comment=Create or open user interface designs for Python TkInter applications.
+Exec=pygubu-designer %F
+Terminal=false
+StartupNotify=false
+Type=Application
+Icon=pygubu.svg
+Categories=Development;GUIDesigner;
diff --git a/tk-logo.svg b/tk-logo.svg
new file mode 100644
index 000000000000..5be0cb965cc5
--- /dev/null
+++ b/tk-logo.svg
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+<svg xmlns:svg="http://www.w3.org/2000/svg" xmlns="http://www.w3.org/2000/svg" xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape" version="1.0" width="48" height="48" id="svg11507">
+ <defs id="defs11510">
+ <filter id="filter5442" height="1.224921" y="-0.1124605" width="1.2461377" x="-0.12306885">
+ <feGaussianBlur id="feGaussianBlur5444" stdDeviation="1.3184307" inkscape:collect="always"/>
+ </filter>
+ <clipPath id="clipPath6420">
+ <path d="M 19.523245,38.153057 C 20.642358,35.955842 20.90653,34.747159 22.26081,32.365297 C 23.495036,30.396857 23.956492,29.170123 25.034064,27.473901 C 26.611504,24.990831 27.212541,23.537048 28.9171,21.908257 C 30.909651,20.004277 30.960602,18.989238 30.158776,17.365591 C 29.03032,15.484213 28.12197,13.563947 24.710658,13.493464 C 21.254673,13.554808 16.853028,13.694786 12.332037,14.962776 C 9.8011985,15.861909 8.4600105,16.496242 6.4450385,18.713886 C 5.4776485,19.789683 3.9534329,21.881641 5.8053355,23.318147 C 8.281433,24.623225 9.5346983,24.744403 11.24229,25.225638 C 13.020565,26.045721 13.71421,23.442098 11.391664,23.439029 C 5.595222,21.582372 14.60597,20.313273 16.339607,20.02574 C 19.079329,19.571343 21.947434,19.297926 24.714805,19.729635 C 26.204044,21.455045 25.318831,23.34639 23.5883,25.190573 C 22.292762,26.885226 20.313194,28.848319 19.104878,30.691981 C 17.854636,32.322403 17.048431,33.439017 15.709347,35.348329 C 14.482931,37.027917 12.208133,39.37471 14.672203,41.297973 C 17.212774,42.308472 18.040259,40.941081 19.523245,38.153057 z " style="fill:none;fill-opacity:1;stroke:#c80000;stroke-opacity:1;filter:url(#filter5442)" id="path6422"/>
+ </clipPath>
+ <clipPath id="clipPath6431">
+ <path d="M 19.591335,38.071847 C 20.710448,35.874632 20.97462,34.665949 22.3289,32.284087 C 23.563126,30.315647 24.024582,29.088913 25.102154,27.392691 C 26.679594,24.909621 27.280631,23.455838 28.98519,21.827047 C 30.977741,19.923067 31.028692,18.908028 30.226866,17.284381 C 29.09841,15.403003 28.19006,13.482737 24.778748,13.412254 C 21.322763,13.473598 16.921118,13.613576 12.400127,14.881566 C 9.8692879,15.780699 8.5280999,16.415032 6.5131279,18.632676 C 5.5457379,19.708473 4.0215223,21.800431 5.8734249,23.236937 C 8.3495224,24.542015 9.6027877,24.663193 11.31038,25.144428 C 13.088655,25.964511 13.7823,23.360888 11.459754,23.357819 C 5.6633114,21.501162 14.67406,20.232063 16.407697,19.94453 C 19.147419,19.490133 22.015524,19.216716 24.782895,19.648425 C 26.272134,21.373835 25.386921,23.26518 23.65639,25.109363 C 22.360852,26.804016 20.381284,28.767109 19.172968,30.610771 C 17.922726,32.241193 17.116521,33.357807 15.777437,35.267119 C 14.551021,36.946707 12.276223,39.2935 14.740293,41.216763 C 17.280864,42.227262 18.108349,40.859871 19.591335,38.071847 z " style="fill:#ff3300;fill-opacity:1;display:inline" id="path6433"/>
+ </clipPath>
+ <clipPath id="clipPath6451">
+ <path d="M 19.523245,38.153057 C 20.642358,35.955842 20.90653,34.747159 22.26081,32.365297 C 23.495036,30.396857 23.956492,29.170123 25.034064,27.473901 C 26.611504,24.990831 27.212541,23.537048 28.9171,21.908257 C 30.909651,20.004277 30.960602,18.989238 30.158776,17.365591 C 29.03032,15.484213 28.12197,13.563947 24.710658,13.493464 C 21.254673,13.554808 16.853028,13.694786 12.332037,14.962776 C 9.8011985,15.861909 8.4600105,16.496242 6.4450385,18.713886 C 5.4776485,19.789683 3.9534329,21.881641 5.8053355,23.318147 C 8.281433,24.623225 9.5346983,24.744403 11.24229,25.225638 C 13.020565,26.045721 13.71421,23.442098 11.391664,23.439029 C 5.595222,21.582372 14.60597,20.313273 16.339607,20.02574 C 19.079329,19.571343 21.947434,19.297926 24.714805,19.729635 C 26.204044,21.455045 25.318831,23.34639 23.5883,25.190573 C 22.292762,26.885226 20.313194,28.848319 19.104878,30.691981 C 17.854636,32.322403 17.048431,33.439017 15.709347,35.348329 C 14.482931,37.027917 12.208133,39.37471 14.672203,41.297973 C 17.212774,42.308472 18.040259,40.941081 19.523245,38.153057 z " style="fill:#ff3300;fill-opacity:1" clip-path="url(#clipPath6420)" id="path6453"/>
+ </clipPath>
+ <filter id="filter11470">
+ <feGaussianBlur id="feGaussianBlur11472" stdDeviation="0.7529079" inkscape:collect="always"/>
+ </filter>
+ <filter id="filter18339" height="1.1802717" y="-0.090135835" width="1.2523582" x="-0.12617911">
+ <feGaussianBlur id="feGaussianBlur18341" stdDeviation="1.0283863" inkscape:collect="always"/>
+ </filter>
+ <clipPath id="clipPath24159">
+ <path d="M 39.108029,38.976232 C 41.0251,37.680807 42.511737,34.985767 39.425943,35.758684 C 38.22532,36.721958 37.407594,39.5271 35.599085,37.749906 C 34.730647,36.495933 38.144522,34.171177 39.298324,32.539689 C 40.900068,31.147202 41.722965,27.682431 39.131941,26.72581 C 36.439762,26.262564 34.383959,28.722123 32.481127,30.516287 C 30.591342,32.22304 29.190472,35.044124 27.493355,34.341682 C 26.569685,33.959373 29.751039,30.61274 31.058628,29.117466 C 32.682369,27.504065 33.88448,25.920215 35.41233,23.965607 C 37.194355,21.816137 39.203465,20.156583 40.834678,17.648106 C 42.155501,15.446541 40.270166,14.128343 38.217111,15.849036 C 35.252456,18.389769 31.856376,21.980661 30.178376,24.394185 C 28.912457,26.215 28.273485,26.712784 26.530474,29.252898 C 24.916138,31.605492 22.593491,34.351991 22.736123,36.725694 C 22.601058,38.539324 23.009334,41.010063 25.825906,40.601475 C 27.728253,40.32551 27.422992,38.771436 29.619276,38.719202 C 31.672677,38.670366 31.23974,40.604267 32.030473,41.160686 C 34.601447,42.055396 36.894813,40.680862 39.108029,38.976232 z M 32.259916,33.922691 C 31.979743,32.299792 35.985037,30.907082 34.176072,33.085386 C 33.556736,33.80746 32.561378,34.897488 32.259916,33.922691 z " style="fill:#ff3300;fill-opacity:1" id="path24161"/>
+ </clipPath>
+ <clipPath id="clipPath24175">
+ <path d="M 39.108029,38.976232 C 41.0251,37.680807 42.511737,34.985767 39.425943,35.758684 C 38.22532,36.721958 37.407594,39.5271 35.599085,37.749906 C 34.730647,36.495933 38.144522,34.171177 39.298324,32.539689 C 40.900068,31.147202 41.722965,27.682431 39.131941,26.72581 C 36.439762,26.262564 34.383959,28.722123 32.481127,30.516287 C 30.591342,32.22304 29.190472,35.044124 27.493355,34.341682 C 26.569685,33.959373 29.751039,30.61274 31.058628,29.117466 C 32.682369,27.504065 33.88448,25.920215 35.41233,23.965607 C 37.194355,21.816137 39.203465,20.156583 40.834678,17.648106 C 42.155501,15.446541 40.270166,14.128343 38.217111,15.849036 C 35.252456,18.389769 31.856376,21.980661 30.178376,24.394185 C 28.912457,26.215 28.273485,26.712784 26.530474,29.252898 C 24.916138,31.605492 22.593491,34.351991 22.736123,36.725694 C 22.601058,38.539324 23.009334,41.010063 25.825906,40.601475 C 27.728253,40.32551 27.422992,38.771436 29.619276,38.719202 C 31.672677,38.670366 31.23974,40.604267 32.030473,41.160686 C 34.601447,42.055396 36.894813,40.680862 39.108029,38.976232 z M 32.259916,33.922691 C 31.979743,32.299792 35.985037,30.907082 34.176072,33.085386 C 33.556736,33.80746 32.561378,34.897488 32.259916,33.922691 z " style="fill:#ff3300;fill-opacity:1" id="path24177"/>
+ </clipPath>
+ </defs>
+ <g style="display:inline" id="layer2">
+ <path d="M 40.079025,38.005235 C 41.996096,36.70981 43.482733,34.01477 40.396939,34.787687 C 39.196316,35.750961 38.37859,38.556103 36.570081,36.778909 C 35.701643,35.524936 39.115518,33.20018 40.26932,31.568692 C 41.871064,30.176205 42.693961,26.711434 40.102937,25.754813 C 37.410758,25.291567 35.354955,27.751126 33.452123,29.54529 C 31.562338,31.252043 30.161468,34.073127 28.464351,33.370685 C 27.540681,32.988376 30.722035,29.641743 32.029624,28.146469 C 33.653365,26.533068 34.855476,24.949218 36.383326,22.99461 C 38.165351,20.84514 40.174461,19.185586 41.805674,16.677109 C 43.126497,14.475544 41.241162,13.157346 39.188107,14.878039 C 36.223452,17.418772 32.827372,21.009664 31.149372,23.423188 C 29.883453,25.244003 29.244481,25.741787 27.50147,28.281901 C 25.887134,30.634495 23.564487,33.380994 23.707119,35.754697 C 23.572054,37.568327 23.98033,40.039066 26.796902,39.630478 C 28.699249,39.354513 28.393988,37.800439 30.590272,37.748205 C 32.643673,37.699369 32.210736,39.63327 33.001469,40.189689 C 35.572443,41.084399 37.865809,39.709865 40.079025,38.005235 z M 33.230912,32.951694 C 32.950739,31.328795 36.956033,29.936085 35.147068,32.114389 C 34.527732,32.836463 33.532374,33.926491 33.230912,32.951694 z " style="fill:#ff3300;fill-opacity:1" id="path24163"/>
+ <path d="M 39.108029,38.976232 C 41.0251,37.680807 42.511737,34.985767 39.425943,35.758684 C 38.22532,36.721958 37.407594,39.5271 35.599085,37.749906 C 34.730647,36.495933 38.144522,34.171177 39.298324,32.539689 C 40.900068,31.147202 41.722965,27.682431 39.131941,26.72581 C 36.439762,26.262564 34.383959,28.722123 32.481127,30.516287 C 30.591342,32.22304 29.190472,35.044124 27.493355,34.341682 C 26.569685,33.959373 29.751039,30.61274 31.058628,29.117466 C 32.682369,27.504065 33.88448,25.920215 35.41233,23.965607 C 37.194355,21.816137 39.203465,20.156583 40.834678,17.648106 C 42.155501,15.446541 40.270166,14.128343 38.217111,15.849036 C 35.252456,18.389769 31.856376,21.980661 30.178376,24.394185 C 28.912457,26.215 28.273485,26.712784 26.530474,29.252898 C 24.916138,31.605492 22.593491,34.351991 22.736123,36.725694 C 22.601058,38.539324 23.009334,41.010063 25.825906,40.601475 C 27.728253,40.32551 27.422992,38.771436 29.619276,38.719202 C 31.672677,38.670366 31.23974,40.604267 32.030473,41.160686 C 34.601447,42.055396 36.894813,40.680862 39.108029,38.976232 z M 32.259916,33.922691 C 31.979743,32.299792 35.985037,30.907082 34.176072,33.085386 C 33.556736,33.80746 32.561378,34.897488 32.259916,33.922691 z " transform="translate(0.9104666,-0.9709962)" style="fill:#ff6339;fill-opacity:1;filter:url(#filter11470)" clip-path="url(#clipPath24175)" id="path7430"/>
+ <path d="M 18.925509,37.103373 C 20.044622,34.906158 20.308794,33.697475 21.663074,31.315613 C 22.8973,29.347173 23.358756,28.120439 24.436328,26.424217 C 26.013768,23.941147 26.614805,22.487364 28.319364,20.858573 C 30.311915,18.954593 30.362866,17.939554 29.56104,16.315907 C 28.432584,14.434529 27.524234,12.514263 24.112922,12.44378 C 20.656937,12.505124 16.255292,12.645102 11.734301,13.913092 C 9.2034614,14.812225 7.8622735,15.446558 5.8473015,17.664202 C 4.8799115,18.739999 3.355696,20.831957 5.2075985,22.268463 C 7.683696,23.573541 8.9369614,23.694719 10.644554,24.175954 C 12.422829,24.996037 13.116474,22.392414 10.793928,22.389345 C 4.997485,20.532688 14.008234,19.263589 15.741871,18.976056 C 18.481593,18.521659 21.349698,18.248242 24.117069,18.679951 C 25.606308,20.405361 24.721095,22.296706 22.990564,24.140889 C 21.695026,25.835542 19.715458,27.798635 18.507142,29.642297 C 17.2569,31.272719 16.450695,32.389333 15.111611,34.298645 C 13.885195,35.978233 11.610397,38.325026 14.074467,40.248289 C 16.615038,41.258788 17.442523,39.891397 18.925509,37.103373 z " style="fill:#ff3300;fill-opacity:1;stroke:none;stroke-opacity:1;display:inline" id="path6435"/>
+ <path d="M 19.523245,38.153057 C 20.642358,35.955842 20.90653,34.747159 22.26081,32.365297 C 23.495036,30.396857 23.956492,29.170123 25.034064,27.473901 C 26.611504,24.990831 27.212541,23.537048 28.9171,21.908257 C 30.909651,20.004277 30.960602,18.989238 30.158776,17.365591 C 29.03032,15.484213 28.12197,13.563947 24.710658,13.493464 C 21.254673,13.554808 16.853028,13.694786 12.332037,14.962776 C 9.8011985,15.861909 8.4600105,16.496242 6.4450385,18.713886 C 5.4776485,19.789683 3.9534329,21.881641 5.8053355,23.318147 C 8.281433,24.623225 9.5346983,24.744403 11.24229,25.225638 C 13.020565,26.045721 13.71421,23.442098 11.391664,23.439029 C 5.595222,21.582372 14.60597,20.313273 16.339607,20.02574 C 19.079329,19.571343 22.367968,18.54033 24.714805,19.729635 C 26.624578,20.697449 25.318831,23.34639 23.5883,25.190573 C 22.292762,26.885226 20.313194,28.848319 19.104878,30.691981 C 17.854636,32.322403 17.048431,33.439017 15.709347,35.348329 C 14.482931,37.027917 12.208133,39.37471 14.672203,41.297973 C 17.212774,42.308472 18.040259,40.941081 19.523245,38.153057 z " transform="translate(-0.6052963,-0.9684742)" style="opacity:1;fill:#ff6339;fill-opacity:1;display:inline;filter:url(#filter5442)" clip-path="url(#clipPath6431)" id="path6426"/>
+ <path d="M 19.523245,38.153057 C 20.642358,35.955842 20.90653,34.747159 22.26081,32.365297 C 23.495036,30.396857 23.956492,29.170123 25.034064,27.473901 C 26.611504,24.990831 27.212541,23.537048 28.9171,21.908257 C 30.909651,20.004277 30.960602,18.989238 30.158776,17.365591 C 29.03032,15.484213 28.12197,13.563947 24.710658,13.493464 C 21.254673,13.554808 16.853028,13.694786 12.332037,14.962776 C 9.8011985,15.861909 8.4600105,16.496242 6.4450385,18.713886 C 5.4776485,19.789683 3.9534329,21.881641 5.8053355,23.318147 C 8.281433,24.623225 9.5346983,24.744403 11.24229,25.225638 C 13.020565,26.045721 13.71421,23.442098 11.391664,23.439029 C 5.595222,21.582372 14.60597,20.313273 16.339607,20.02574 C 19.079329,19.571343 22.5865,18.651076 24.714805,19.729635 C 26.84311,20.808194 25.318831,23.34639 23.5883,25.190573 C 22.292762,26.885226 20.313194,28.848319 19.104878,30.691981 C 17.854636,32.322403 17.048431,33.439017 15.709347,35.348329 C 14.482931,37.027917 12.208133,39.37471 14.672203,41.297973 C 17.212774,42.308472 18.040259,40.941081 19.523245,38.153057 z " transform="translate(-0.6052964,-1.0895334)" style="fill:none;fill-opacity:1;stroke:#c80000;stroke-opacity:1;filter:url(#filter5442)" clip-path="url(#clipPath6451)" id="path5446"/>
+ <path d="M 39.108029,38.976232 C 41.0251,37.680807 42.511737,34.985767 39.425943,35.758684 C 38.22532,36.721958 37.407594,39.5271 35.599085,37.749906 C 34.730647,36.495933 38.144522,34.171177 39.298324,32.539689 C 40.900068,31.147202 41.722965,27.682431 39.131941,26.72581 C 36.439762,26.262564 34.383959,28.722123 32.481127,30.516287 C 30.591342,32.22304 29.190472,35.044124 27.493355,34.341682 C 26.569685,33.959373 29.751039,30.61274 31.058628,29.117466 C 32.682369,27.504065 33.88448,25.920215 35.41233,23.965607 C 37.194355,21.816137 39.203465,20.156583 40.834678,17.648106 C 42.155501,15.446541 40.270166,14.128343 38.217111,15.849036 C 35.252456,18.389769 31.856376,21.980661 30.178376,24.394185 C 28.912457,26.215 28.273485,26.712784 26.530474,29.252898 C 24.916138,31.605492 22.593491,34.351991 22.736123,36.725694 C 22.601058,38.539324 23.009334,41.010063 25.825906,40.601475 C 27.728253,40.32551 27.422992,38.771436 29.619276,38.719202 C 31.672677,38.670366 31.23974,40.604267 32.030473,41.160686 C 34.601447,42.055396 36.894813,40.680862 39.108029,38.976232 z M 32.259916,33.922691 C 31.979743,32.299792 35.985037,30.907082 34.176072,33.085386 C 33.556736,33.80746 32.561378,34.897488 32.259916,33.922691 z " transform="translate(0.9104665,-0.9709962)" style="fill:none;fill-opacity:1;stroke:#c80000;stroke-opacity:1;filter:url(#filter18339)" clip-path="url(#clipPath24159)" id="path8493"/>
+ </g>
+</svg> \ No newline at end of file