summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-05-13 22:53:33 +0200
committerNarrat2015-05-13 22:53:33 +0200
commitba5d707221b66cc213e86e7f6f2577cdc18c1f99 (patch)
tree619c3db0431ed12c83633b9ac0589caafc8635f9
downloadaur-ba5d707221b66cc213e86e7f6f2577cdc18c1f99.tar.gz
pyhn: Latest files
History: https://github.com/Narrat/PKGBuilds
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD35
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32d67fc3b6a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = pyhn
+ pkgdesc = Hacker News command line client
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pyhn/
+ arch = any
+ license = AGPL3
+ makedepends = python-urwid
+ makedepends = python-beautifulsoup4
+ makedepends = python-isit
+ makedepends = python2-urwid
+ makedepends = python2-beautifulsoup4
+ makedepends = python2-isit
+ source = http://pypi.python.org/packages/source/p/pyhn/pyhn-0.2.7.tar.gz
+ md5sums = 402823eae417be5f6e5f481a35e74a55
+
+pkgname = pyhn
+ pkgdesc = Hacker News command line client (Python3.x)
+ depends = python-urwid
+ depends = python-beautifulsoup4
+ depends = python-isit
+
+pkgname = pyhn2
+ pkgdesc = Hacker News command line client (Python2.x)
+ depends = python2-urwid
+ depends = python2-beautifulsoup4
+ depends = python2-isit
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3a3642b6f6ff
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*/src
+*/pkg
+*.gz
+*.xz
+*.bz2
+*.zip
+*.part
+*.sig
+*.sign
+*.txt
+*.log
+*.scm
+*/*.pkg
+*/*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6522deb1f68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: alejandrogomez <alejandroogomez@gmail.com>
+
+pkgbase=pyhn
+pkgname=('pyhn' 'pyhn2')
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="Hacker News command line client"
+arch=('any')
+url="http://pypi.python.org/pypi/pyhn/"
+license=('AGPL3')
+makedepends=('python-urwid' 'python-beautifulsoup4' 'python-isit')
+makedepends+=('python2-urwid' 'python2-beautifulsoup4' 'python2-isit')
+source=(http://pypi.python.org/packages/source/p/$pkgbase/$pkgbase-$pkgver.tar.gz)
+md5sums=('402823eae417be5f6e5f481a35e74a55')
+
+
+package_pyhn() {
+ pkgdesc+=" (Python3.x)"
+ depends=('python-urwid' 'python-beautifulsoup4' 'python-isit')
+
+ cd "$srcdir/$pkgbase-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+}
+
+package_pyhn2() {
+ pkgdesc+=" (Python2.x)"
+ depends=('python2-urwid' 'python2-beautifulsoup4' 'python2-isit')
+
+ cd "$srcdir/$pkgbase-$pkgver"
+
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
+ mv $pkgdir/usr/bin/$pkgbase $pkgdir/usr/bin/${pkgbase}2
+}