summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2016-03-13 22:13:53 -0700
committermutantmonkey2016-03-13 22:13:53 -0700
commit6f0f0a976bdbfcf95cfc00b659f8d4d3e4080cf9 (patch)
tree3c1de13d95cc25435e4b967baf2ebc11e55a6e38
downloadaur-6f0f0a976bdbfcf95cfc00b659f8d4d3e4080cf9.tar.gz
Initial upload: pyhugh-git 1.e5c1c48-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c190067e3a47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Mar 14 05:13:53 UTC 2016
+pkgbase = pyhugh-git
+ pkgdesc = Python library for the Hue API,
+ pkgver = 1.e5c1c48
+ pkgrel = 1
+ url = https://github.com/mutantmonkey/pyhugh
+ arch = any
+ license = WTFPL
+ makedepends = git
+ depends = python
+ depends = python-requests>=2.4
+ provides = pyhugh
+ conflicts = pyhugh
+ source = git+https://github.com/mutantmonkey/pyhugh.git
+ sha256sums = SKIP
+
+pkgname = pyhugh-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..812a918a4f1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=pyhugh-git
+_gitname=pyhugh
+pkgver=1.e5c1c48
+pkgrel=1
+pkgdesc="Python library for the Hue API",
+url="https://github.com/mutantmonkey/pyhugh"
+arch=('any')
+license=('WTFPL')
+depends=('python' 'python-requests>=2.4')
+makedepends=('git')
+provides=('pyhugh')
+conflicts=('pyhugh')
+source=('git+https://github.com/mutantmonkey/pyhugh.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_gitname
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd $srcdir/$_gitname
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: