summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranck STAUFFER2020-08-14 08:51:06 +0200
committerFranck STAUFFER2020-08-14 08:51:06 +0200
commitab568079eccb687882646441746ceeb9b48a5253 (patch)
tree2fb668656a1ff80ad02fba1cd37cec211d5d9203
parentd896d9bf72a498881e00016732398bc7e07d8e76 (diff)
downloadaur-ab568079eccb687882646441746ceeb9b48a5253.tar.gz
Update to 2020.8.13
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--no_update.patch98
-rw-r--r--pyidm.changelog13
4 files changed, 44 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3244acfba7ac..11c6d821510b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pyidm
pkgdesc = Python open source alternative to IDM (Internet Download Manager)
- pkgver = 2020.6.27
- pkgrel = 4
+ pkgver = 2020.8.13
+ pkgrel = 1
url = https://github.com/pyIDM/PyIDM
changelog = pyidm.changelog
arch = any
@@ -17,7 +17,7 @@ pkgbase = pyidm
depends = python-pycurl
depends = python-pillow
depends = ffmpeg
- source = pyidm-2020.6.27.tar.gz::https://github.com/pyIDM/PyIDM/archive/2020.6.27.tar.gz
+ source = pyidm-2020.8.13.tar.gz::https://github.com/pyIDM/PyIDM/archive/2020.8.13.tar.gz
source = no_update.patch
b2sums = a697c73d85956920e0ad859dea7bb1f2c4b7dc8a36ccfaabb893553bf037b464945dce482ba2cb8793f25ded2499e9ceaa87e07c250aa764d400d0997a79a20b
b2sums = 584ee8e745066428a688d756ed89c67f681b9f974818a800e96f8eb5c93f05748c7a167612f056dc78d9d3b14e5ad0c64a12d2b08d97845357d1271c3e7ace4c
diff --git a/PKGBUILD b/PKGBUILD
index 70af84c35974..087c5d24efd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Franck Stauffer <franck.stauffer@monaco.mc>
pkgname=pyidm
-pkgver=2020.6.27
-pkgrel=4
+pkgver=2020.8.13
+pkgrel=1
pkgdesc="Python open source alternative to IDM (Internet Download Manager)"
arch=('any')
url="https://github.com/pyIDM/PyIDM"
@@ -20,8 +20,8 @@ makedepends=('python-setuptools' 'python-pip')
changelog=$pkgname.changelog
source=("$pkgname-$pkgver.tar.gz::https://github.com/pyIDM/PyIDM/archive/$pkgver.tar.gz"
"no_update.patch")
-b2sums=('a697c73d85956920e0ad859dea7bb1f2c4b7dc8a36ccfaabb893553bf037b464945dce482ba2cb8793f25ded2499e9ceaa87e07c250aa764d400d0997a79a20b'
- '584ee8e745066428a688d756ed89c67f681b9f974818a800e96f8eb5c93f05748c7a167612f056dc78d9d3b14e5ad0c64a12d2b08d97845357d1271c3e7ace4c')
+b2sums=('6a95c17beeff63e0aecaf6263ea214499b3fb762364ca5d538275074f57fa0719d8a1c8e5b56fb512c80fb0ccef2740f01d3f5c8f8bd696fc64ccbfee00b6fa9'
+ '0e0049941a2cf01da6b43dee63c808f5752da911cd2b158941ca0bbb243ee296a7528700921479567fad70b4bd061863ec7698f0a095fa02fcac5026d6774fc3')
prepare() {
cd "$srcdir/PyIDM-$pkgver"
@@ -40,6 +40,6 @@ package() {
# python-pystray does not work in AUR
pip install pystray
- python setup.py install --root="$pkgdir" --skip-build -O2
+ python setup.py install --root="$pkgdir" --skip-build --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/no_update.patch b/no_update.patch
index 17b0b308f5df..c3d6cc6120e2 100644
--- a/no_update.patch
+++ b/no_update.patch
@@ -1,7 +1,6 @@
-Only in PyIDM: build
-diff --color --unified --recursive --text PyIDM.orig/pyidm/config.py PyIDM/pyidm/config.py
---- PyIDM.orig/pyidm/config.py 2020-08-11 09:17:50.841427964 +0200
-+++ PyIDM/pyidm/config.py 2020-08-11 08:59:33.694722005 +0200
+diff --color --unified --recursive --text PyIDM-2020.8.13.orig/pyidm/config.py PyIDM-2020.8.13/pyidm/config.py
+--- PyIDM-2020.8.13.orig/pyidm/config.py 2020-08-14 08:30:11.528633421 +0200
++++ PyIDM-2020.8.13/pyidm/config.py 2020-08-14 08:31:15.721969874 +0200
@@ -138,11 +138,6 @@
active_downloads = set() # indexes for active downloading items
d_list = []
@@ -23,10 +22,18 @@ diff --color --unified --recursive --text PyIDM.orig/pyidm/config.py PyIDM/pyidm
'log_level', 'download_folder', 'manually_select_dash_audio', 'use_referer', 'referer_url',
'close_action', 'process_playlist', 'keep_temp', 'auto_rename', 'dynamic_theme_change', 'checksum',
'use_proxy_dns', 'use_thread_pool_executor', 'write_metadata']
-diff --color --unified --recursive --text PyIDM.orig/pyidm/gui.py PyIDM/pyidm/gui.py
---- PyIDM.orig/pyidm/gui.py 2020-08-11 09:17:50.844761298 +0200
-+++ PyIDM/pyidm/gui.py 2020-08-11 09:06:29.088070216 +0200
-@@ -469,25 +469,6 @@
+diff --color --unified --recursive --text PyIDM-2020.8.13.orig/pyidm/gui.py PyIDM-2020.8.13/pyidm/gui.py
+--- PyIDM-2020.8.13.orig/pyidm/gui.py 2020-08-14 08:30:11.528633421 +0200
++++ PyIDM-2020.8.13/pyidm/gui.py 2020-08-14 08:47:00.598682433 +0200
+@@ -23,7 +23,6 @@
+ from . import setting
+ from . import config
+ from .config import Status
+-from . import update
+ from .brain import brain
+ from . import video
+ from .video import Video, check_ffmpeg, download_ffmpeg, unzip_ffmpeg, get_ytdl_options, process_video_info, \
+@@ -469,25 +468,6 @@
[sg.T('', size=(1, 1))]
]
@@ -52,17 +59,16 @@ diff --color --unified --recursive --text PyIDM.orig/pyidm/gui.py PyIDM/pyidm/gu
advanced = [
[sg.T('')],
-@@ -506,8 +487,7 @@
+@@ -506,7 +486,7 @@
layout = [
[sg.T('', size=(70, 1)), ],
[sg.TabGroup([[sg.Tab('General ', general), sg.Tab('Network ', network), sg.Tab('SysTray ', systray),
- sg.Tab('Update ', update), sg.Tab('Advanced ', advanced)]],
-- tab_location='lefttop')]
-+ sg.Tab('Advanced ', advanced)]], tab_location='lefttop')]
++ sg.Tab('Advanced ', advanced)]],
+ tab_location='lefttop')]
]
- return layout
-@@ -858,11 +838,6 @@
+@@ -861,11 +841,6 @@
speed_limit = size_format(config.speed_limit) if config.speed_limit > 0 else "_no limit_"
self.window['current_speed_limit'](f'Current value: {speed_limit}')
@@ -74,7 +80,7 @@ diff --color --unified --recursive --text PyIDM.orig/pyidm/gui.py PyIDM/pyidm/gu
# update total speed
total_speed = 0
for i in self.active_downloads:
-@@ -1558,22 +1533,6 @@
+@@ -1561,22 +1536,6 @@
# log('user, pass:', config.username, config.password)
@@ -97,7 +103,7 @@ diff --color --unified --recursive --text PyIDM.orig/pyidm/gui.py PyIDM/pyidm/gu
# systray -------------------------------------------------
elif event in ('radio_close', 'radio_minimize', 'radio_quit'):
config.close_action = event.replace('radio_', '')
-@@ -1641,44 +1600,6 @@
+@@ -1644,44 +1603,6 @@
# check availability of ffmpeg in the system or in same folder with this script
self.ffmpeg_check()
@@ -142,7 +148,7 @@ diff --color --unified --recursive --text PyIDM.orig/pyidm/gui.py PyIDM/pyidm/gu
# reset statusbar periodically
if time.time() - self.statusbar_timer >= 10:
self.statusbar_timer = time.time()
-@@ -2893,59 +2814,6 @@
+@@ -2958,59 +2879,6 @@
# endregion
@@ -202,62 +208,4 @@ diff --color --unified --recursive --text PyIDM.orig/pyidm/gui.py PyIDM/pyidm/gu
# Note every window class must have self.active property and close method
class DownloadWindow:
-@@ -3598,58 +3466,6 @@
-
- self.window.close()
-
--
--class UpdateWindow:
--
-- def __init__(self, update_description):
-- self.active = True # if False, object will be removed from "active windows list"
-- self.update_description = update_description
-- self.window = None
--
-- def setup(self):
--
-- # create gui
-- buttons = []
-- if config.FROZEN: # show update button for Frozen versions only i.e. "windows portable version"
-- buttons.append(sg.B('Update'))
--
-- buttons += [sg.B('website'), sg.Cancel()]
--
-- layout = [
-- [sg.T('New update available:')],
-- [sg.Multiline(self.update_description, size=(70, 10))],
-- buttons
-- ]
--
-- self.window = sg.Window('Update Application', layout, finalize=True, keep_on_top=True)
--
-- def focus(self):
-- self.window.BringToFront()
--
-- def run(self):
--
-- # using this technique we can start gui window from a thread
-- if not self.window:
-- self.setup()
--
-- # read events
-- event, values = self.window.read(timeout=10, timeout_key='_TIMEOUT_')
--
-- if event == 'Update':
-- Thread(target=update.update).start()
-- execute_command('select_tab', 'Log')
--
-- elif event == 'website':
-- update.open_update_link()
--
-- if event != '_TIMEOUT_':
-- self.close()
--
-- def close(self):
-- self.active = False
-- self.window.Close()
--
--
- class SysTray:
- """
- systray icon using pystray package
+Only in PyIDM-2020.8.13.orig/pyidm: update.py
diff --git a/pyidm.changelog b/pyidm.changelog
index 9ec834f40868..09bbe34f15bd 100644
--- a/pyidm.changelog
+++ b/pyidm.changelog
@@ -1,3 +1,16 @@
+2020.8.13:
+- Ability to delete any item while download in progress.
+- added buttons for open log file, or log folder, issue #134
+- Fixed arabic language display on linux issue #88
+- Fixed failed downloads if target folder's name has spaces issue #130
+- Fix for table colors on tkinter 8.6.9
+- Stop log auto scroll if user scroll up.
+- Added horizontal scrollbar for log window.
+- Fixed fetching youtube channel videos as a playlist, issue #146
+- Fixed metadata error issue #138
+- interactive terminal support.
+- Auto correct file name extension (ask user first) issue #137
+
2020.6.27:
- Write metadata info to media files issue #124, Settings>General
- fixed fragmented video download