summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2021-08-17 02:12:34 +0000
committerSam2021-08-17 02:12:34 +0000
commit2f20b67ef103fdef09bd89d3bbe2f7570db2c36d (patch)
tree292d9dea98e892294eae0c704aba21728e230518
parent33a6321176fe54200bae0ebc66655187495ef200 (diff)
downloadaur-2f20b67ef103fdef09bd89d3bbe2f7570db2c36d.tar.gz
updpkg: pyinstaller 4.5.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD60
2 files changed, 36 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0691f09e2fc9..be1b4614bff8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,20 +6,17 @@ pkgbase = pyinstaller
arch = x86_64
arch = i686
arch = aarch64
- arch = ppc64le
- arch = s390x
license = custom:PyInstaller
- makedepends = cmocka
- makedepends = python>=3.6
- makedepends = python-setuptools
- makedepends = git
- makedepends = python-wheel
+ makedepends = python-pip
depends = python-altgraph
depends = pyinstaller-hooks-contrib
optdepends = python-pycrypto: bytecode encryption support
optdepends = upx: executable compression support
- source = git+https://github.com/pyinstaller/pyinstaller
- sha256sums = SKIP
- depends_i686 = lib32-zlib
+ source_x86_64 = https://files.pythonhosted.org/packages/py3/p/pyinstaller/pyinstaller-4.5.1-py3-none-manylinux2014_x86_64.whl
+ sha512sums_x86_64 = 29454c824829a82e85ef14debdcb8e95a0d1b74e32f100509d9d71919c424ce63a8e5e92fc6fe80a2b57fcc410294a24d1addfcb322a662675ed04f65166c29b
+ source_i686 = https://files.pythonhosted.org/packages/py3/p/pyinstaller/pyinstaller-4.5.1-py3-none-manylinux2014_i686.whl
+ sha512sums_i686 = a81c0d7df9b639e2936eb73e7abbac07e2e1f116c8a259370904551ed86e74d0fa7c1c98c2e3fbc8262564dcf4f6da4dcdbd3c1c1e62e47784ef98eb12aabc53
+ source_aarch64 = https://files.pythonhosted.org/packages/py3/p/pyinstaller/pyinstaller-4.5.1-py3-none-manylinux2014_aarch64.whl
+ sha512sums_aarch64 = 4f1fd8da1f3bea146b7f2ea352821465d9f08d70f3aeff4c11845bce4cfe2a590230e5561eb55d1dc97b6c5ce75c0d9a9b6b74ad4b6e899ad63ba7ba8bc6f98e
pkgname = pyinstaller
diff --git a/PKGBUILD b/PKGBUILD
index 91306b5fb905..bf55d79c819b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,42 +12,40 @@ _pkgname=pyinstaller
pkgver=4.5.1
pkgrel=1
pkgdesc="Bundles a Python application and all its dependencies into a single package"
-arch=('x86_64' 'i686' 'aarch64' 'ppc64le' 's390x')
+arch=('x86_64' 'i686' 'aarch64')
url="http://www.pyinstaller.org"
license=('custom:PyInstaller')
depends=('python-altgraph' 'pyinstaller-hooks-contrib')
-depends_i686=('lib32-zlib')
-makedepends=('cmocka' 'python>=3.6' 'python-setuptools' 'git' 'python-wheel')
+makedepends=("python-pip")
optdepends=('python-pycrypto: bytecode encryption support'
'upx: executable compression support')
-source=("git+https://github.com/$_pkgname/$_pkgname")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${_pkgname}" || exit
- ver=$(curl -fSsL "https://api.github.com/repos/$_pkgname/$_pkgname/releases/latest" | grep -oP "tag_name.*$" |
- head -n1 |
- sed -re 's|^tag_name": "(.*)",$|\1|g')
- echo "${ver#v}"
-}
-
-build() {
- cd "$srcdir/$_pkgname" || exit
- git checkout "v$pkgver"
- rm -rvf PyInstaller/bootloader/Darwin*
- rm -rvf PyInstaller/bootloader/Windows*
- [ "$CARCH" != "i686" ] && rm -rvf PyInstaller/bootloader/Linux-32bit*
- export PYTHONHASHSEED=0
- (
- cd bootloader || exit
- python ./waf all
- )
- python setup.py build
-}
+_pkgname_prefix="${_pkgname:0:1}"
+_pkgname_underscored="${_pkgname//-/_}"
+_py="py3"
+_py_hosted_url="https://files.pythonhosted.org/packages/$_py"
+_pkg_whlname_prefix="$_pkgname_underscored-$pkgver-$_py-none-manylinux2014"
+_pkg_whlname_x86_64="${_pkg_whlname_prefix}_x86_64.whl"
+_pkg_whlname_i686="${_pkg_whlname_prefix}_i686.whl"
+_pkg_whlname_aarch64="${_pkg_whlname_prefix}_aarch64.whl"
+source_x86_64=("$_py_hosted_url/$_pkgname_prefix/$_pkgname/$_pkg_whlname_x86_64")
+source_i686=("$_py_hosted_url/$_pkgname_prefix/$_pkgname/$_pkg_whlname_i686")
+source_aarch64=("$_py_hosted_url/$_pkgname_prefix/$_pkgname/$_pkg_whlname_aarch64")
+sha512sums_x86_64=('29454c824829a82e85ef14debdcb8e95a0d1b74e32f100509d9d71919c424ce63a8e5e92fc6fe80a2b57fcc410294a24d1addfcb322a662675ed04f65166c29b')
+sha512sums_i686=('a81c0d7df9b639e2936eb73e7abbac07e2e1f116c8a259370904551ed86e74d0fa7c1c98c2e3fbc8262564dcf4f6da4dcdbd3c1c1e62e47784ef98eb12aabc53')
+sha512sums_aarch64=('4f1fd8da1f3bea146b7f2ea352821465d9f08d70f3aeff4c11845bce4cfe2a590230e5561eb55d1dc97b6c5ce75c0d9a9b6b74ad4b6e899ad63ba7ba8bc6f98e')
package() {
- cd "$srcdir/$_pkgname" || exit
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 COPYING.txt "$pkgdir/usr/share/licenses/$_pkgname/COPYING.txt"
+ cd "$srcdir" || exit
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --root="$pkgdir" \
+ --isolated \
+ --ignore-installed \
+ --no-deps \
+ --no-compile \
+ --no-warn-script-location \
+ "${_pkg_whlname_prefix}_${CARCH}.whl"
+ python -O -m compileall -j "$(nproc)" -s "$pkgdir" "$pkgdir/usr/lib/"
+ mapfile -t direct_url_file < <(find "$pkgdir"/usr/lib -type f -name 'direct_url.json')
+ rm -rvf "${direct_url_file[@]}" || true
+ install -Dm644 "${_pkgname//-/_}-$pkgver.dist-info/COPYING.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}