summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2021-08-02 16:00:30 -0700
committerSam2021-08-02 16:00:30 -0700
commit169ad4319147ad0d4eafd9fd5df202060e990023 (patch)
treefd9ce987ab416ac7a6ba3ddffc26bd04659c57fc
parent61ddab5b95e64907522c6d3d610c14fc99c50e90 (diff)
downloadaur-169ad4319147ad0d4eafd9fd5df202060e990023.tar.gz
updpkg: pyinstaller-git 5.0.dev0.r8021.g0c9c07807-1
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD48
3 files changed, 56 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7892a4eea8f5..5c394a319d94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,28 @@
pkgbase = pyinstaller-git
- pkgdesc = An application to convert python scripts into stand-alone binaries
- pkgver = r6822.e29c0472
+ pkgdesc = Bundles a Python application and all its dependencies into a single package
+ pkgver = 5.0.dev0.r8021.g0c9c07807
pkgrel = 1
url = http://www.pyinstaller.org
- arch = i686
arch = x86_64
- license = GPL2
- makedepends = git
+ arch = i686
+ arch = aarch64
+ arch = ppc64le
+ arch = s390x
+ license = custom:PyInstaller
+ makedepends = cmocka
+ makedepends = python>=3.6
makedepends = python-setuptools
- depends = python
+ makedepends = curl
+ makedepends = git
+ makedepends = python-wheel
depends = python-altgraph
- depends = python-pefile
- depends = python-macholib
+ depends = pyinstaller-hooks-contrib
+ optdepends = python-pycrypto: bytecode encryption support
+ optdepends = upx: executable compression support
provides = pyinstaller
conflicts = pyinstaller
- source = git+https://github.com/pyinstaller/pyinstaller.git
- md5sums = SKIP
+ source = git+https://github.com/pyinstaller/pyinstaller
+ sha256sums = SKIP
+ depends_i686 = lib32-zlib
pkgname = pyinstaller-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..209eaaefe67f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 40dbac980d2f..0a6bc79440fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,50 @@
+# Maintainer: Sam <dev at samarthj dot com>
+# Contributor: xantares
+# Contributor: ase1590
+
+# shellcheck disable=2034,2148,2154
pkgname=pyinstaller-git
-_pyname=pyinstaller
-pkgver=r6822.e29c0472
+_pkgname=pyinstaller
+pkgver=5.0.dev0.r8021.g0c9c07807
pkgrel=1
-pkgdesc="An application to convert python scripts into stand-alone binaries"
-arch=('i686' 'x86_64')
+pkgdesc="Bundles a Python application and all its dependencies into a single package"
+arch=('x86_64' 'i686' 'aarch64' 'ppc64le' 's390x')
url="http://www.pyinstaller.org"
-license=('GPL2')
-depends=('python' 'python-altgraph' 'python-pefile' 'python-macholib')
-makedepends=('git' 'python-setuptools')
+license=('custom:PyInstaller')
+depends=('python-altgraph' 'pyinstaller-hooks-contrib')
+depends_i686=('lib32-zlib')
+makedepends=('cmocka' 'python>=3.6' 'python-setuptools' 'curl' 'git' 'python-wheel')
+optdepends=('python-pycrypto: bytecode encryption support'
+ 'upx: executable compression support')
provides=('pyinstaller')
conflicts=('pyinstaller')
-source=("git+https://github.com/pyinstaller/pyinstaller.git")
-md5sums=('SKIP')
+source=("git+https://github.com/$_pkgname/$_pkgname")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_pyname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}" || exit
+ commit=$(printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
+ ver=$(grep -E "^__version__" PyInstaller/__init__.py | sed -re "s|.* = '(.*)'$|\1|g")
+ echo "${ver//-/_}.${commit}"
}
build() {
- cd "${srcdir}/${_pyname}"
+ cd "$srcdir/$_pkgname" || exit
+ rm -rvf PyInstaller/bootloader/Darwin*
+ rm -rvf PyInstaller/bootloader/Windows*
+ [ "$CARCH" != "i686" ] && rm -rvf PyInstaller/bootloader/Linux-32bit*
+ export PYTHONHASHSEED=0
+ (
+ cd bootloader || exit
+ python ./waf all
+ )
python setup.py build
}
package() {
- cd "${srcdir}/${_pyname}"
- python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+ cd "$srcdir/$_pkgname" || exit
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 COPYING.txt "$pkgdir/usr/share/licenses/$_pkgname/COPYING.txt"
}