summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-09-26 18:05:57 +0200
committerxantares2015-09-26 18:05:57 +0200
commit54cd9b4c936dc5e02e0674fcd5e6975e3f930da2 (patch)
tree84f880e1bcf37839667ced6736b59f36d424e33c
parent6ad262562c3ebe9cac3f8d83107a303137322be3 (diff)
downloadaur-54cd9b4c936dc5e02e0674fcd5e6975e3f930da2.tar.gz
pkgver
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c265495f06ab..a957f7811e3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=pyinstaller-git
_pyname=pyinstaller
-pkgver=2.1
+pkgver=r4623.cd5d9ac
pkgrel=1
pkgdesc="An application to convert python scripts into stand-alone binaries"
arch=('i686' 'x86_64')
@@ -14,6 +14,11 @@ source=("git+https://github.com/pyinstaller/pyinstaller.git")
md5sums=('SKIP')
options=('!strip' '!emptydirs')
+pkgver() {
+ cd "${srcdir}/${_pyname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd "${srcdir}/${_pyname}"
python setup.py build