summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxantares2015-09-26 18:05:01 +0200
committerxantares2015-09-26 18:05:01 +0200
commit6ad262562c3ebe9cac3f8d83107a303137322be3 (patch)
treeb31cab1fa2a7e2e2735c76d06452b748ff3e1611
downloadaur-6ad262562c3ebe9cac3f8d83107a303137322be3.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..365795915754
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pyinstaller-git
+ pkgdesc = An application to convert python scripts into stand-alone binaries
+ pkgver = 2.1
+ pkgrel = 1
+ url = http://www.pyinstaller.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = python
+ provides = pyinstaller
+ conflicts = pyinstaller
+ options = !strip
+ options = !emptydirs
+ source = git+https://github.com/pyinstaller/pyinstaller.git
+ md5sums = SKIP
+
+pkgname = pyinstaller-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c265495f06ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+
+pkgname=pyinstaller-git
+_pyname=pyinstaller
+pkgver=2.1
+pkgrel=1
+pkgdesc="An application to convert python scripts into stand-alone binaries"
+arch=('i686' 'x86_64')
+url="http://www.pyinstaller.org"
+license=('GPL2')
+depends=('python')
+provides=('pyinstaller')
+conflicts=('pyinstaller')
+source=("git+https://github.com/pyinstaller/pyinstaller.git")
+md5sums=('SKIP')
+options=('!strip' '!emptydirs')
+
+build() {
+ cd "${srcdir}/${_pyname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pyname}"
+ python setup.py install --root="${pkgdir}"
+}