summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2023-01-25 23:08:24 +0000
committerSam2023-01-25 23:08:24 +0000
commit6b588cede722775a7fd94f5ad30cde295b933ea6 (patch)
treecf6e4259fe1f82130b1153ef093962f87f3207b2
parent748aebf107771e3cdfc3f044b76f3b088285e0e4 (diff)
downloadaur-6b588cede722775a7fd94f5ad30cde295b933ea6.tar.gz
updpkg: pyinstaller-hooks-contrib-git 2023.0.r460.g7dba7f9-2
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD103
2 files changed, 111 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a09c4e61ffa4..83a960acaf18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,32 @@
pkgbase = pyinstaller-hooks-contrib-git
pkgdesc = Community maintained hooks for PyInstaller
- pkgver = 2021.3.r206.g482bb34
- pkgrel = 1
+ pkgver = 2023.0.r460.g7dba7f9
+ pkgrel = 2
url = https://github.com/pyinstaller/pyinstaller-hooks-contrib
arch = any
- license = GPL
- license = APACHE
- depends = towncrier
- depends = python-setuptools
- depends = python-wheel
- depends = twine
- depends = git
+ license = GPL2
+ license = Apache
+ license = custom:PyInstaller
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = mpdecimal
+ optdepends = python-boto3
+ optdepends = python-pygraphviz
+ optdepends = python-pycparser
+ optdepends = python-pytest
+ optdepends = python-pyusb
+ optdepends = python-pyqt5
+ optdepends = python-pyqt5-webengine
+ optdepends = python-uvloop
+ optdepends = python-importlib-metadata
+ optdepends = python-importlib_resources
provides = pyinstaller-hooks-contrib
conflicts = pyinstaller-hooks-contrib
- source = git+https://github.com/pyinstaller/pyinstaller-hooks-contrib
- sha256sums = SKIP
+ source = git+https://github.com/pyinstaller/pyinstaller-hooks-contrib.git
+ sha512sums = SKIP
+ b2sums = SKIP
pkgname = pyinstaller-hooks-contrib-git
diff --git a/PKGBUILD b/PKGBUILD
index a5384ca366c0..dbd124316f0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,106 @@
# Maintainer: Sam <dev at samarthj dot com>
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
-# shellcheck disable=2034,2148,2154
+# shellcheck disable=2034,2148,2154,2155
pkgname=pyinstaller-hooks-contrib-git
-_pkgname=pyinstaller-hooks-contrib
-pkgver=2021.3.r206.g482bb34
-pkgrel=1
+_pkgbase="${pkgname%-git}"
+_pkgname="${_pkgbase#python-}"
+pkgver=2023.0.r460.g7dba7f9
+pkgrel=2
pkgdesc="Community maintained hooks for PyInstaller"
arch=('any')
-url="https://github.com/pyinstaller/pyinstaller-hooks-contrib"
-license=('GPL' 'APACHE')
-depends=('towncrier' 'python-setuptools' 'python-wheel' 'twine' 'git')
-provides=('pyinstaller-hooks-contrib')
-conflicts=('pyinstaller-hooks-contrib')
-source=("git+https://github.com/pyinstaller/$_pkgname")
-sha256sums=('SKIP')
+license=('GPL2' 'Apache' 'custom:PyInstaller')
+depends=(
+ "mpdecimal"
+)
+makedepends=(
+ "git"
+ "python-build"
+ "python-installer"
+ "python-wheel"
+ "python-setuptools"
+)
+optdepends=(
+ # libraries with referenced hooks that work with tests
+ "python-boto3"
+ "python-pygraphviz"
+ "python-pycparser"
+ "python-pytest"
+ "python-pyusb"
+ "python-pyqt5"
+ "python-pyqt5-webengine"
+ "python-uvloop"
+ "python-importlib-metadata"
+ "python-importlib_resources"
+)
+# checkdepends=(
+# "python-pytest"
+# "python-psutil"
+# # Ability to retry a failed test
+# "python-flaky"
+# # Plugin to abort hanging tests.
+# "python-pytest-timeout>=2.0.0"
+# # allows specifying order without duplicates
+# "python-pytest-drop-dup-tests"
+# # reruns failed flaky tests
+# "python-pytest-rerunfailures"
+# # parallel processing for tests
+# "python-pytest-xdist"
+# "python-execnet>=1.5.0"
+# )
+
+url="https://github.com/pyinstaller/$_pkgname"
+source=("git+$url.git")
+sha512sums=('SKIP')
+b2sums=('SKIP')
+
+provides=("$_pkgbase")
+conflicts=("$_pkgbase")
pkgver() {
- cd "${_pkgname}" || exit
+ cd "$_pkgname" || exit 1
commit=$(printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)")
ver=$(python setup.py --version)
echo "${ver//-/_}.${commit}"
}
+prepare() {
+ local python_version=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
+ if [[ $python_version -lt 39 ]]; then
+ depends+=("python-importlib-metadata")
+ checkdepends+=("python-importlib_resources")
+ fi
+}
+
build() {
- cd "$srcdir/$_pkgname" || exit
- python setup.py build
+ cd "$_pkgname" || exit 1
+ python -m build --wheel --no-isolation
}
+#TODO: Move this into the pyinstaller pkg and be a universal build for 2 targets
+# The both depend on each other and is now causing a cyclical dependency.
+# check() {
+# cd "$_pkgname" || exit 1
+
+# # Disabling several tests that are not relevant to the release of this pkg
+# # darwin, win32, slow - self explanatory
+# # test_cv2_highgui - needs interactive interface
+# # test_pynput - needs interactive interface
+# # test_boto - known to fail for python 3
+# # test_cv2 - needs full suite of libraries
+# QT_QPA_PLATFORM="offscreen" \
+# pytest -c pytest.ini -m "not darwin and not win32 and not slow" \
+# -k "not test_cv2_highgui and not test_pynput and not test_boto and not test_cv2" \
+# --maxfail=3 \
+# -n=auto --maxprocesses="${PYTEST_XDIST_AUTO_NUM_WORKERS:-2}" \
+# --dist=load \
+# --force-flaky --no-flaky-report --reruns=3 --reruns-delay=10
+# }
+
package() {
- cd "$_pkgname" || exit
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_pkgname" || exit 1
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm 644 "LICENSE"* -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -vDm 644 "README"* -t "$pkgdir/usr/share/doc/$pkgname/"
}