summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Torres2015-10-30 15:31:27 +0100
committerJavier Torres2015-10-30 15:31:27 +0100
commit7f9e1a6e29530107a4ac68dc398792cb99a82867 (patch)
treed4c2315926fc9e06dd5aa0acbb61b9470b6bf93e
parent0128e0a51d7f6474cf19ce8163447a3c022a9e66 (diff)
downloadaur-7f9e1a6e29530107a4ac68dc398792cb99a82867.tar.gz
Update to 0.7.17
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--setup-script.patch28
-rw-r--r--templates.patch2
4 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3aa81bd86f12..3c2d1906af55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pykolab
pkgdesc = Kolab Python Utilities
- pkgver = 0.7.13
- pkgrel = 2
+ pkgver = 0.7.17
+ pkgrel = 1
url = http://kolab.org
install = pykolab.install
arch = any
@@ -33,17 +33,17 @@ pkgbase = pykolab
optdepends = kolab-syncroton: ActiveSync support
optdepends = kolab-webadmin: Administration tool
backup = etc/kolab/kolab.conf
- source = http://mirror.kolabsys.com/pub/releases/pykolab-0.7.13.tar.gz
+ source = http://mirror.kolabsys.com/pub/releases/pykolab-0.7.17.tar.gz
source = http://mirror.kolabsys.com/pub/releases/kolab-schema-3.2.tar.gz
source = systemd-services.patch
source = setup-script.patch
source = templates.patch
source = kolabd.tmpfiles
- sha256sums = 842586765921ae4f25acbcb53dc71c1d89907a1b8a9c70f83349d9367c4ecfee
+ sha256sums = c01e8f81a8673fbd0bb38bb5447fc08659d8ebc961463af99a9a0aabd392c6bb
sha256sums = 6995524d755ea3cbf3d36fc572667629716a141e7f757af1a970c2e85f8fa4de
sha256sums = a515f068b5fe12c858f327fa0558087e61b4d39070d67dfba9a2b6d19a83c2c6
- sha256sums = 1ff05a0f7f503443cab6d7b81ce723202df4f10cbbe8f483056d7f4aaea7d460
- sha256sums = 653b49d20dbb0b492962e87009c53acaa9acb2d9825bd22d8335c43386ddd8c7
+ sha256sums = 0f9d45bb7784426b7515eac8158c6cf899b647b20763c5efd302535bd06b1480
+ sha256sums = bbf5b350b0cf5b11cf93710440965c91874652d008e5b6cbd6a541188318a2d5
sha256sums = 4bbb72695b20b7a4c1c0348a93c62f048f0eef9f3bc7135fa2720c62e98e4634
pkgname = pykolab
diff --git a/PKGBUILD b/PKGBUILD
index 18d468af7003..9ef2bb33c01d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Jonas Heinrich <onny@project-insanity.org>
pkgname=pykolab
-pkgver=0.7.13
-pkgrel=2
+pkgver=0.7.17
+pkgrel=1
pkgdesc='Kolab Python Utilities'
arch=('any')
license=('GPL3')
@@ -35,11 +35,11 @@ optdepends=('cyrus-imapd-ldap: Only supported IMAP backend so far'
'kolab-syncroton: ActiveSync support'
'kolab-webadmin: Administration tool')
-sha256sums=('842586765921ae4f25acbcb53dc71c1d89907a1b8a9c70f83349d9367c4ecfee'
+sha256sums=('c01e8f81a8673fbd0bb38bb5447fc08659d8ebc961463af99a9a0aabd392c6bb'
'6995524d755ea3cbf3d36fc572667629716a141e7f757af1a970c2e85f8fa4de'
'a515f068b5fe12c858f327fa0558087e61b4d39070d67dfba9a2b6d19a83c2c6'
- '1ff05a0f7f503443cab6d7b81ce723202df4f10cbbe8f483056d7f4aaea7d460'
- '653b49d20dbb0b492962e87009c53acaa9acb2d9825bd22d8335c43386ddd8c7'
+ '0f9d45bb7784426b7515eac8158c6cf899b647b20763c5efd302535bd06b1480'
+ 'bbf5b350b0cf5b11cf93710440965c91874652d008e5b6cbd6a541188318a2d5'
'4bbb72695b20b7a4c1c0348a93c62f048f0eef9f3bc7135fa2720c62e98e4634')
diff --git a/setup-script.patch b/setup-script.patch
index 630dbe3245a0..4c3422c59db5 100644
--- a/setup-script.patch
+++ b/setup-script.patch
@@ -116,10 +116,10 @@ index c805d20..1786438 100644
if os.path.isfile('/bin/systemctl'):
- subprocess.call(['/bin/systemctl', 'restart', 'dirsrv.target'])
+ subprocess.call(['/bin/systemctl', 'restart', '389-ds-base.target'])
+ time.sleep(20)
elif os.path.isfile('/sbin/service'):
subprocess.call(['/sbin/service', 'dirsrv', 'restart'])
- elif os.path.isfile('/usr/sbin/service'):
-@@ -428,7 +430,7 @@ ServerAdminPwd = %(admin_pass)s
+@@ -429,7 +431,7 @@ ServerAdminPwd = %(admin_pass)s
log.error(_("Could not start the directory server service."))
if os.path.isfile('/bin/systemctl'):
@@ -194,7 +194,7 @@ diff --git a/pykolab/setup/setup_mysql.py b/pykolab/setup/setup_mysql.py
index 174cbc7..1e0d70f 100644
--- a/pykolab/setup/setup_mysql.py
+++ b/pykolab/setup/setup_mysql.py
-@@ -186,7 +186,7 @@ password='%s'
+@@ -206,7 +206,7 @@ password='%s'
p2.communicate()
conf.command_set('kolab_wap', 'sql_uri', 'mysql://kolab:%s@localhost/kolab' % (mysql_kolab_password))
@@ -229,7 +229,7 @@ diff --git a/pykolab/setup/setup_roundcube.py b/pykolab/setup/setup_roundcube.py
index 6558989..fad35fa 100644
--- a/pykolab/setup/setup_roundcube.py
+++ b/pykolab/setup/setup_roundcube.py
-@@ -88,9 +88,9 @@ def execute(*args, **kw):
+@@ -89,9 +89,9 @@ def execute(*args, **kw):
'conf': conf
}
@@ -241,16 +241,16 @@ index 6558989..fad35fa 100644
rc_settings['skin'] = 'chameleon'
else:
rc_settings['skin'] = 'larry'
-@@ -139,13 +139,15 @@ def execute(*args, **kw):
- fp = open('/etc/roundcubemail/%s' % (want_file), 'w')
- elif os.path.isdir('/etc/roundcube'):
- fp = open('/etc/roundcube/%s' % (want_file), 'w')
-+ elif os.path.isdir('/etc/webapps/roundcubemail/config'):
-+ fp = open('/etc/webapps/roundcubemail/config/%s' % (want_file), 'w')
+@@ -140,13 +140,15 @@ def execute(*args, **kw):
+ fp = open('/etc/roundcubemail/%s' % (want_file), 'w')
+ elif os.path.isdir('/etc/roundcube'):
+ fp = open('/etc/roundcube/%s' % (want_file), 'w')
++ elif os.path.isdir('/etc/webapps/roundcubemail/config'):
++ fp = open('/etc/webapps/roundcubemail/config/%s' % (want_file), 'w')
- if not fp == None:
- fp.write(t.__str__())
- fp.close()
+ if not fp == None:
+ fp.write(t.__str__())
+ fp.close()
schema_files = []
- for root, directories, filenames in os.walk('/usr/share/doc/'):
@@ -258,7 +258,7 @@ index 6558989..fad35fa 100644
directories.sort()
for directory in directories:
if directory.startswith("roundcubemail"):
-@@ -164,6 +166,8 @@ def execute(*args, **kw):
+@@ -165,6 +167,8 @@ def execute(*args, **kw):
rcpath = '/usr/share/roundcubemail/'
elif os.path.isdir('/usr/share/roundcube'):
rcpath = '/usr/share/roundcube/'
diff --git a/templates.patch b/templates.patch
index f469c4331bee..24be1dc2ab87 100644
--- a/templates.patch
+++ b/templates.patch
@@ -120,7 +120,7 @@ index 7206a09..b8505e0 100644
\$config['mail_domain'] = '';
-@@ -132,8 +132,8 @@
+@@ -150,8 +150,8 @@
\$config['mime_magic'] = null;
\$config['im_identify_path'] = '/usr/bin/identify';
\$config['im_convert_path'] = '/usr/bin/convert';