summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuu2020-09-28 16:45:50 -0300
committeryuu2020-09-28 16:45:50 -0300
commitb96f78ee2b17e23ba769a204195bba32f52f186b (patch)
tree9ba2084063872d8709984c3694045084b2194e60
downloadaur-b96f78ee2b17e23ba769a204195bba32f52f186b.tar.gz
Initial commit: add 'PKGBUILD', '.SRCINFO', '.gitignore'.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD29
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42a9081dbcb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pylivestream-git
+ pkgdesc = Python FFmpeg-based live streaming to YouTube, Facebook, Periscope, Twitch, etc
+ pkgver = v1.11.1.r0.g6b0d23e
+ pkgrel = 1
+ url = https://github.com/scivision/pylivestream
+ arch = any
+ license = AGPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = ffmpeg>=3.0
+ depends = python>=3.6
+ depends = python-setuptools
+ provides = pylivestream
+ conflicts = pylivestream
+ source = pylivestream::git+https://github.com/scivision/pylivestream.git
+ md5sums = SKIP
+
+pkgname = pylivestream-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..56d6a51e8f38
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+**/pkg
+**/pylivestream*
+**/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b83fe182fc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer : Yuu $(echo \<yuu-tutamail+com\>|sed s/\+/./g\;s/\-/@/)
+
+_pkgname=pylivestream
+pkgname=$_pkgname-git
+pkgver=v1.11.1.r0.g6b0d23e
+pkgrel=1
+pkgdesc="Python FFmpeg-based live streaming to YouTube, Facebook, Periscope, Twitch, etc"
+arch=('any')
+url=https://github.com/scivision/$_pkgname
+license=('AGPL3')
+depends=('ffmpeg>=3.0' 'python>=3.6' 'python-setuptools')
+makedepends=('git' 'python-setuptools')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+md5sums=('SKIP')
+
+# Git, un-annotated tags available.
+# Use the most recent un-annotated tag reachable from the last commit.
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname/"
+ python setup.py install --root="$pkgdir" --optimize=1
+}