summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-09-08 15:18:34 +0200
committerM0Rf302019-09-08 15:18:34 +0200
commitdce4aba76db17b341da5408c29e39a58c00638cf (patch)
treec1e70a4b7821d7d73d903146878f2fd0f157ce21
parent2857aef68d16ef2d0194fce807b3f999fe63cda3 (diff)
downloadaur-dce4aba76db17b341da5408c29e39a58c00638cf.tar.gz
pyload-git: updated
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
-rw-r--r--pyLoadCli3
-rw-r--r--pyLoadCore3
-rw-r--r--pyLoadGui3
-rw-r--r--pyload.conf65
-rw-r--r--pyload.service4
7 files changed, 5 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa987b03b568..53187290beba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,7 +22,6 @@ pkgbase = pyload-git
optdepends = python-pycryptodomex: for low-level crypto routines
optdepends = python-pillow: Captcha resolver
optdepends = python-pyopenssl: ssl support
- optdepends = python-pyxmmp2: notify on xmpp
optdepends = python-send2trash: trash support
provides = pyload
conflicts = pyload
@@ -30,16 +29,8 @@ pkgbase = pyload-git
backup = var/lib/pyload/pyload.conf
source = pyload-git::git+https://github.com/pyload/pyload.git
source = pyload.service
- source = pyload.conf
- source = pyLoadCore
- source = pyLoadCli
- source = pyLoadGui
md5sums = SKIP
- md5sums = 454e974b11ab31533423f336c3a182f2
- md5sums = 32b00d50be868c165930c592b99730a9
- md5sums = 6d764666ec89ce218cd00164e73e0989
- md5sums = 6fc2f343d2f324a66745524bbab93e5c
- md5sums = 806a22a74e8331dffcb8538182e4df2c
+ md5sums = 75069bddcec3ee630d2abea02ffef0b4
pkgname = pyload-git
diff --git a/PKGBUILD b/PKGBUILD
index 2e890093b583..9f3aa413622a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,14 +17,13 @@ optdepends=('python-beautifulsoup4: for web scraping'
'python-pycryptodomex: for low-level crypto routines'
'python-pillow: Captcha resolver'
'python-pyopenssl: ssl support'
- 'python-pyxmmp2: notify on xmpp'
'python-send2trash: trash support'
)
makedepends=('git')
install='pyload-git.install'
source=("$pkgname::git+https://github.com/pyload/pyload.git"
-'pyload.service' 'pyload.conf' 'pyLoadCore' 'pyLoadCli' 'pyLoadGui')
+'pyload.service')
pkgver() {
cd $srcdir/$pkgname
@@ -52,8 +51,4 @@ package() {
}
md5sums=('SKIP'
- '454e974b11ab31533423f336c3a182f2'
- '32b00d50be868c165930c592b99730a9'
- '6d764666ec89ce218cd00164e73e0989'
- '6fc2f343d2f324a66745524bbab93e5c'
-'806a22a74e8331dffcb8538182e4df2c')
+ '75069bddcec3ee630d2abea02ffef0b4')
diff --git a/pyLoadCli b/pyLoadCli
deleted file mode 100644
index d19f87597657..000000000000
--- a/pyLoadCli
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-
-PYTHONPATH=/opt/pyload/module/lib python2 /opt/pyload/pyLoadCli.py "$@" \ No newline at end of file
diff --git a/pyLoadCore b/pyLoadCore
deleted file mode 100644
index cf7d20fc7f72..000000000000
--- a/pyLoadCore
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-
-PYTHONPATH=/opt/pyload/module/lib python2 /opt/pyload/pyLoadCore.py "$@" \ No newline at end of file
diff --git a/pyLoadGui b/pyLoadGui
deleted file mode 100644
index 93399f170176..000000000000
--- a/pyLoadGui
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-
-PYTHONPATH=/opt/pyload/module/lib python2 /opt/pyload/pyLoadGui.py "$@" \ No newline at end of file
diff --git a/pyload.conf b/pyload.conf
deleted file mode 100644
index d5e2a448d25e..000000000000
--- a/pyload.conf
+++ /dev/null
@@ -1,65 +0,0 @@
-version: 1
-
-remote - "Remote":
- int port : "Port" = 7227
- ip listenaddr : "Adress" = 0.0.0.0
- bool nolocalauth : "No authentication on local connections" = True
- bool activated : "Activated" = True
-ssl - "SSL":
- bool activated : "Activated"= False
- file cert : "SSL Certificate" = ssl.crt
- file key : "SSL Key" = ssl.key
-webinterface - "Webinterface":
- bool activated : "Activated" = True
- builtin;threaded;fastcgi;lightweight server : "Server" = builtin
- bool https : "Use HTTPS" = False
- ip host : "IP" = 0.0.0.0
- int port : "Port" = 8001
- str template : "Template" = default
- str prefix: "Path Prefix" =
-log - "Log":
- bool file_log : "File Log" = True
- folder log_folder : "Folder" = Logs
- int log_count : "Count" = 5
- int log_size : "Size in kb" = 100
- bool log_rotate : "Log Rotate" = True
-general - "General":
- en;de;fr;it;es;nl;sv;ru;pl;cs;sr;pt_BR language : "Language" = en
- folder download_folder : "Download Folder" = Downloads
- bool debug_mode : "Debug Mode" = False
- bool checksum : "Use Checksum" = False
- int min_free_space : "Min Free Space (MB)" = 200
- bool folder_per_package : "Create folder for each package" = True
- int renice : "CPU Priority" = 0
-download - "Download":
- int chunks : "Max connections for one download" = 3
- int max_downloads : "Max Parallel Downloads" = 3
- int max_speed : "Max Download Speed in kb/s" = -1
- bool limit_speed : "Limit Download Speed" = False
- str interface : "Download interface to bind (ip or Name)" = None
- bool ipv6 : "Allow IPv6" = False
- bool skip_existing : "Skip already existing files" = False
-permission - "Permissions":
- bool change_user : "Change user of running process" = False
- str user : "Username" = pyload
- str folder : "Folder Permission mode" = 0755
- bool change_file : "Change file mode of downloads" = False
- str file : "Filemode for Downloads" = 0644
- bool change_group : "Change group of running process" = False
- str group : "Groupname" = pyload
- bool change_dl : "Change Group and User of Downloads" = False
-reconnect - "Reconnect":
- bool activated : "Use Reconnect" = False
- str method : "Method" = None
- time startTime : "Start" = 0:00
- time endTime : "End" = 0:00
-downloadTime - "Download Time":
- time start : "Start" = 0:00
- time end : "End" = 0:00
-proxy - "Proxy":
- str address : "Address" = "localhost"
- int port : "Port" = 7070
- http;socks4;socks5 type : "Protocol" = http
- str username : "Username" = None
- password password : "Password" = None
- bool proxy : "Use Proxy" = False
diff --git a/pyload.service b/pyload.service
index 4004c8f323a5..9f8fc0a0965e 100644
--- a/pyload.service
+++ b/pyload.service
@@ -1,9 +1,9 @@
[Unit]
-Description=pyLoad Core
+Description=pyLoad Daemon
After=network.target
[Service]
-ExecStart=/usr/bin/pyLoadCore
+ExecStart=/usr/bin/pyload --daemon
User=pyload
Group=pyload