summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Holthuis2015-06-21 19:41:59 +0200
committerJan Holthuis2015-06-21 19:41:59 +0200
commit4b2ff199018e532fb367c33c655459c866324173 (patch)
treea465088a10e5e6cb1c15257232a93dc52b25f798
downloadaur-4b2ff199018e532fb367c33c655459c866324173.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD50
-rw-r--r--pyload-nightly.install15
-rw-r--r--pyload.conf76
-rw-r--r--pyload.service15
5 files changed, 190 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ddbe57c82b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = pyload-nightly
+ pkgdesc = Downloadtool for One-Click-Hoster written in python. Nightly build of pyload 0.5 public beta.
+ pkgver = 0.4.9.9dev
+ pkgrel = 1
+ url = http://beta.pyload.org/index.php/5-pyload-beta
+ install = pyload-nightly.install
+ arch = any
+ license = GPL
+ depends = python2>=2.5.0
+ depends = python2<2.8.0
+ depends = python2-pycurl
+ depends = python2-jinja
+ depends = python2-beaker
+ optdepends = python2-crypto: RSDF/CCF/DLC support
+ optdepends = tesseract: Automatic captcha recognition for a small amount of plugins
+ optdepends = python2-pillow: Automatic captcha recognition for a small amount of plugins
+ optdepends = js: Used for several hoster, ClickNLoad
+ optdepends = python2-feedparser: Feedparser support
+ optdepends = python2-beautifulsoup4: BeautifulSoup support
+ optdepends = python2-pyopenssl: For SSL connection
+ optdepends = python2-flup: for additional webservers
+ provides = pyload
+ conflicts = pyload
+ conflicts = pyload-hg
+ backup = var/lib/pyload/pyload.conf
+ source = http://nightly.pyload.org/job/Nightly/lastSuccessfulBuild/artifact/dist/pyload-0.4.9.9-dev.tar.gz
+ source = pyload.service
+ source = pyload.conf
+ md5sums = SKIP
+ md5sums = d34a58f919ecf5e53da1c8986e62a1fe
+ md5sums = e8aa7a9b1ef8ba58a3fdaaf3a43e98a3
+
+pkgname = pyload-nightly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..731fa174966d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Holzhaus <jan.holthuis@ruhr-uni-bochum.de>
+
+pkgname='pyload-nightly'
+pkgver=0.4.9.9dev
+pkgrel=1
+pkgdesc="Downloadtool for One-Click-Hoster written in python. Nightly build of pyload 0.5 public beta."
+url="http://beta.pyload.org/index.php/5-pyload-beta"
+license=('GPL')
+arch=('any')
+provides=('pyload')
+conflicts=('pyload' 'pyload-hg')
+backup=('var/lib/pyload/pyload.conf')
+depends=('python2>=2.5.0' 'python2<2.8.0'
+ 'python2-pycurl'
+ 'python2-jinja'
+ 'python2-beaker')
+optdepends=('python2-crypto: RSDF/CCF/DLC support'
+ 'tesseract: Automatic captcha recognition for a small amount of plugins'
+ 'python2-pillow: Automatic captcha recognition for a small amount of plugins'
+ 'js: Used for several hoster, ClickNLoad'
+ 'python2-feedparser: Feedparser support'
+ 'python2-beautifulsoup4: BeautifulSoup support'
+ 'python2-pyopenssl: For SSL connection'
+ 'python2-flup: for additional webservers')
+source=('http://nightly.pyload.org/job/Nightly/lastSuccessfulBuild/artifact/dist/pyload-0.4.9.9-dev.tar.gz'
+ 'pyload.service'
+ 'pyload.conf')
+md5sums=('SKIP'
+ 'd34a58f919ecf5e53da1c8986e62a1fe'
+ 'e8aa7a9b1ef8ba58a3fdaaf3a43e98a3')
+install='pyload-nightly.install'
+
+package() {
+ cd $srcdir
+ tar xzvf pyload-0.4.9.9-dev.tar.gz
+ cd pyload-0.4.9.9-dev
+ sed -i 's_#!/usr/bin/env python$_#!/usr/bin/env python2_' pyload*.py
+ install -d ${pkgdir}/opt/pyload
+
+ cp -r * ${pkgdir}/opt/pyload
+
+ install -d ${pkgdir}/usr/bin
+ ln -s /opt/pyload/pyload.py ${pkgdir}/usr/bin/pyload
+ ln -s /opt/pyload/pyload-cli.py ${pkgdir}/usr/bin/pyload-cli
+
+ # Create pyload service
+ install -Dm 644 ${srcdir}/pyload.service ${pkgdir}/usr/lib/systemd/system/pyload.service
+ install -Dm 644 ${srcdir}/pyload.conf ${pkgdir}/var/lib/pyload/pyload.conf
+}
+
diff --git a/pyload-nightly.install b/pyload-nightly.install
new file mode 100644
index 000000000000..047c49d045f9
--- /dev/null
+++ b/pyload-nightly.install
@@ -0,0 +1,15 @@
+post_install() {
+ getent group pyload &>/dev/null || groupadd -r pyload >/dev/null
+ getent passwd pyload &>/dev/null || useradd -r -g pyload -d /var/lib/pyload -s /bin/false -c pyload pyload >/dev/null
+ chown -R pyload:pyload /var/lib/pyload
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ getent passwd pyload &>/dev/null && userdel pyload >/dev/null
+ getent group pyload &>/dev/null && groupdel pyload >/dev/null
+ true
+}
diff --git a/pyload.conf b/pyload.conf
new file mode 100644
index 000000000000..26bab673c847
--- /dev/null
+++ b/pyload.conf
@@ -0,0 +1,76 @@
+version: 2
+
+[log]
+log_size = 100
+log_folder = Logs
+file_log = True
+log_count = 5
+log_rotate = True
+console_color = True
+color_theme = light
+
+[permission]
+group = users
+change_dl = False
+change_file = False
+user = user
+file = 0644
+change_group = False
+folder = 0755
+change_user = False
+
+[general]
+language = en
+download_folder = Downloads
+checksum = False
+folder_per_package = True
+debug_mode = False
+min_free_space = 200
+renice = 0
+
+[ssl]
+cert = ssl.crt
+activated = False
+key = ssl.key
+
+[webUI]
+template = default
+prefix =
+external = False
+server = auto
+force_server =
+host = 0.0.0.0
+https = False
+port = 8001
+wsHost = 0.0.0.0
+wsPort = 7447
+develop = False
+
+[proxy]
+username =
+proxy = False
+address = localhost
+password =
+type = http
+port = 7070
+
+[reconnect]
+endTime = 0:00
+activated = False
+method = ./reconnect.sh
+startTime = 0:00
+
+[download]
+max_downloads = 3
+limit_speed = False
+interface =
+skip_existing = False
+max_speed = -1
+ipv6 = False
+chunks = 3
+restart_failed = False
+
+[downloadTime]
+start = 0:00
+end = 0:00
+
diff --git a/pyload.service b/pyload.service
new file mode 100644
index 000000000000..892b408af3d4
--- /dev/null
+++ b/pyload.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=pyLoad Core
+After=network.target
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/pyload --daemon --configdir=/var/lib/pyload
+Restart=on-abort
+KillSignal=SIGQUIT
+PIDFile=/var/lib/pyload/pyload.pid
+User=pyload
+Group=pyload
+
+[Install]
+WantedBy=multi-user.target