summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-09-11 20:39:03 +0200
committerM0Rf302019-09-11 20:39:03 +0200
commitddc4a6ac59389166a65b0c76c53cec79ed9a3c49 (patch)
tree25076bf2c86bcb99c8ead2becd3bad59296dd8fa
parent4b2ff199018e532fb367c33c655459c866324173 (diff)
downloadaur-ddc4a6ac59389166a65b0c76c53cec79ed9a3c49.tar.gz
pyload-nightly: first commit
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD71
-rw-r--r--pyload-git.install15
-rw-r--r--pyload.install15
-rw-r--r--pyload.service8
5 files changed, 86 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ddbe57c82b0..6b2e73c75304 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,31 @@
-pkgbase = pyload-nightly
- pkgdesc = Downloadtool for One-Click-Hoster written in python. Nightly build of pyload 0.5 public beta.
- pkgver = 0.4.9.9dev
- pkgrel = 1
- url = http://beta.pyload.org/index.php/5-pyload-beta
- install = pyload-nightly.install
+pkgbase = pyload-git
+ pkgdesc = Downloadtool for One-Click-Hoster written in python. Latest devel branch
+ pkgver = v0.4.9.r4782.gd686d625b
+ pkgrel = 2
+ url = https://github.com/pyload/pyload
arch = any
license = GPL
- depends = python2>=2.5.0
- depends = python2<2.8.0
- depends = python2-pycurl
- depends = python2-jinja
- depends = python2-beaker
- optdepends = python2-crypto: RSDF/CCF/DLC support
- optdepends = tesseract: Automatic captcha recognition for a small amount of plugins
- optdepends = python2-pillow: Automatic captcha recognition for a small amount of plugins
- optdepends = js: Used for several hoster, ClickNLoad
- optdepends = python2-feedparser: Feedparser support
- optdepends = python2-beautifulsoup4: BeautifulSoup support
- optdepends = python2-pyopenssl: For SSL connection
- optdepends = python2-flup: for additional webservers
+ makedepends = git
+ makedepends = python-jinja
+ makedepends = python-setuptools
+ depends = python
+ depends = python-cheroot
+ depends = python-cryptography
+ depends = python-flask
+ depends = python-flask-babel
+ depends = python-filetype
+ depends = python-flask-themes2
+ depends = python-pycurl
+ depends = python-requests-html
+ depends = python-semver
provides = pyload
conflicts = pyload
conflicts = pyload-hg
backup = var/lib/pyload/pyload.conf
- source = http://nightly.pyload.org/job/Nightly/lastSuccessfulBuild/artifact/dist/pyload-0.4.9.9-dev.tar.gz
+ source = pyload-git::git+https://github.com/pyload/pyload.git
source = pyload.service
- source = pyload.conf
md5sums = SKIP
- md5sums = d34a58f919ecf5e53da1c8986e62a1fe
- md5sums = e8aa7a9b1ef8ba58a3fdaaf3a43e98a3
+ md5sums = 75069bddcec3ee630d2abea02ffef0b4
-pkgname = pyload-nightly
+pkgname = pyload-git
diff --git a/PKGBUILD b/PKGBUILD
index 731fa174966d..2fb1d254695b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,45 @@
-# Maintainer: Holzhaus <jan.holthuis@ruhr-uni-bochum.de>
+# Maintainer: robertfoster
-pkgname='pyload-nightly'
-pkgver=0.4.9.9dev
-pkgrel=1
-pkgdesc="Downloadtool for One-Click-Hoster written in python. Nightly build of pyload 0.5 public beta."
-url="http://beta.pyload.org/index.php/5-pyload-beta"
+pkgname='pyload-git'
+pkgver=v0.4.9.r4782.gd686d625b
+pkgrel=2
+pkgdesc="Downloadtool for One-Click-Hoster written in python. Latest devel branch"
+url="https://github.com/pyload/pyload"
license=('GPL')
arch=('any')
provides=('pyload')
conflicts=('pyload' 'pyload-hg')
backup=('var/lib/pyload/pyload.conf')
-depends=('python2>=2.5.0' 'python2<2.8.0'
- 'python2-pycurl'
- 'python2-jinja'
- 'python2-beaker')
-optdepends=('python2-crypto: RSDF/CCF/DLC support'
- 'tesseract: Automatic captcha recognition for a small amount of plugins'
- 'python2-pillow: Automatic captcha recognition for a small amount of plugins'
- 'js: Used for several hoster, ClickNLoad'
- 'python2-feedparser: Feedparser support'
- 'python2-beautifulsoup4: BeautifulSoup support'
- 'python2-pyopenssl: For SSL connection'
- 'python2-flup: for additional webservers')
-source=('http://nightly.pyload.org/job/Nightly/lastSuccessfulBuild/artifact/dist/pyload-0.4.9.9-dev.tar.gz'
- 'pyload.service'
- 'pyload.conf')
-md5sums=('SKIP'
- 'd34a58f919ecf5e53da1c8986e62a1fe'
- 'e8aa7a9b1ef8ba58a3fdaaf3a43e98a3')
-install='pyload-nightly.install'
+depends=('python' 'python-cheroot' 'python-cryptography' 'python-flask' 'python-flask-babel' 'python-filetype' 'python-flask-themes2' 'python-pycurl' 'python-requests-html' 'python-semver')
+makedepends=('git' 'python-jinja' 'python-setuptools')
+#install='pyload-git.install'
-package() {
- cd $srcdir
- tar xzvf pyload-0.4.9.9-dev.tar.gz
- cd pyload-0.4.9.9-dev
- sed -i 's_#!/usr/bin/env python$_#!/usr/bin/env python2_' pyload*.py
- install -d ${pkgdir}/opt/pyload
+source=("$pkgname::git+https://github.com/pyload/pyload.git"
+'pyload.service')
+
+pkgver() {
+ cd $srcdir/$pkgname
+ git describe --long --tags| sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
- cp -r * ${pkgdir}/opt/pyload
+build() {
+ cd $srcdir/$pkgname
+ python setup.py build
+ python setup.py build_locale
+}
+
+package() {
+ cd ${srcdir}/$pkgname
+ python setup.py install --root=$pkgdir --install-data locale
- install -d ${pkgdir}/usr/bin
- ln -s /opt/pyload/pyload.py ${pkgdir}/usr/bin/pyload
- ln -s /opt/pyload/pyload-cli.py ${pkgdir}/usr/bin/pyload-cli
+ # Temporary fix for some not found resources
+ cp -r src/pyload/core/config $pkgdir/usr/lib/python3.7/site-packages/pyload/core
+ cp -r src/pyload/core/network/xdcc $pkgdir/usr/lib/python3.7/site-packages/pyload/core/network
+ cp -r src/pyload/locale $pkgdir/usr/lib/python3.7/site-packages/pyload/
- # Create pyload service
- install -Dm 644 ${srcdir}/pyload.service ${pkgdir}/usr/lib/systemd/system/pyload.service
- install -Dm 644 ${srcdir}/pyload.conf ${pkgdir}/var/lib/pyload/pyload.conf
+ # Create PyLoad service
+ install -D -m 644 ${srcdir}/pyload.service ${pkgdir}/usr/lib/systemd/system/pyload.service
}
+md5sums=('SKIP'
+'75069bddcec3ee630d2abea02ffef0b4')
diff --git a/pyload-git.install b/pyload-git.install
new file mode 100644
index 000000000000..047c49d045f9
--- /dev/null
+++ b/pyload-git.install
@@ -0,0 +1,15 @@
+post_install() {
+ getent group pyload &>/dev/null || groupadd -r pyload >/dev/null
+ getent passwd pyload &>/dev/null || useradd -r -g pyload -d /var/lib/pyload -s /bin/false -c pyload pyload >/dev/null
+ chown -R pyload:pyload /var/lib/pyload
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ getent passwd pyload &>/dev/null && userdel pyload >/dev/null
+ getent group pyload &>/dev/null && groupdel pyload >/dev/null
+ true
+}
diff --git a/pyload.install b/pyload.install
new file mode 100644
index 000000000000..047c49d045f9
--- /dev/null
+++ b/pyload.install
@@ -0,0 +1,15 @@
+post_install() {
+ getent group pyload &>/dev/null || groupadd -r pyload >/dev/null
+ getent passwd pyload &>/dev/null || useradd -r -g pyload -d /var/lib/pyload -s /bin/false -c pyload pyload >/dev/null
+ chown -R pyload:pyload /var/lib/pyload
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ getent passwd pyload &>/dev/null && userdel pyload >/dev/null
+ getent group pyload &>/dev/null && groupdel pyload >/dev/null
+ true
+}
diff --git a/pyload.service b/pyload.service
index 892b408af3d4..9f8fc0a0965e 100644
--- a/pyload.service
+++ b/pyload.service
@@ -1,13 +1,9 @@
[Unit]
-Description=pyLoad Core
+Description=pyLoad Daemon
After=network.target
[Service]
-Type=forking
-ExecStart=/usr/bin/pyload --daemon --configdir=/var/lib/pyload
-Restart=on-abort
-KillSignal=SIGQUIT
-PIDFile=/var/lib/pyload/pyload.pid
+ExecStart=/usr/bin/pyload --daemon
User=pyload
Group=pyload