summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2015-10-04 19:00:24 -0400
committerFlaviu Tamas2015-10-04 19:01:14 -0400
commitfe2189ab58870c1b7326beb60dd7fa66b5ae44b3 (patch)
tree66661763b36e33dd9a48f52aa24f40ca874a59c9
downloadaur-fe2189ab58870c1b7326beb60dd7fa66b5ae44b3.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD25
-rw-r--r--pylote.desktop10
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2494819e6b87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pylote
+ pkgdesc = Software making it possible to draw on the screen of the computer, like handling various instruments of geometry.
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://pascal.peter.free.fr/wiki/Logiciels/Pylote
+ arch = any
+ license = GPL
+ depends = pyqt
+ source = http://pascal.peter.free.fr/wikiuploads/pylote.tar.gz
+ source = pylote.desktop
+ md5sums = d7a1128ab7991a465c17a40e640c4bdb
+ md5sums = 551a544d0f99fff8b4061167ba3b4dd8
+
+pkgname = pylote
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0309f8ece1b1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+# ignore everything
+*
+!.gitignore
+
+# except PKGBUILD needed files
+!PKGBUILD
+!.SRCINFO
+!*.install
+!ChangeLog
+
+# common wing-man files
+!*.diff
+!*.patch
+
+!pylote.desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8307a25aacee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Flaviu Tamas <tamas.flaviu@gmail.com>
+# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
+
+pkgname=pylote
+pkgver=1.3
+pkgrel=1
+pkgdesc="Software making it possible to draw on the screen of the computer, like handling various instruments of geometry."
+url="http://pascal.peter.free.fr/wiki/Logiciels/Pylote"
+license=('GPL')
+arch=('any')
+depends=('pyqt')
+source=(http://pascal.peter.free.fr/wikiuploads/pylote.tar.gz $pkgname.desktop)
+md5sums=('d7a1128ab7991a465c17a40e640c4bdb'
+ '551a544d0f99fff8b4061167ba3b4dd8')
+
+package() {
+ cd ${srcdir}/${pkgname}
+ mkdir -p ${pkgdir}/usr/share/{$pkgname,applications}
+ mkdir -p ${pkgdir}/usr/bin
+ cp -R * ${pkgdir}/usr/share/$pkgname
+ echo "#!/usr/bin/bash
+ cd '/usr/share/pylote/' && python pylote.pyw" > ${pkgdir}/usr/bin/pylote
+ chmod +x ${pkgdir}/usr/bin/pylote
+ cp ${srcdir}/pylote.desktop ${pkgdir}/usr/share/applications
+}
diff --git a/pylote.desktop b/pylote.desktop
new file mode 100644
index 000000000000..8cd81f2ab13c
--- /dev/null
+++ b/pylote.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Exec=pylote
+Icon=/usr/share/pylote/images/icon.png
+Name=pylote
+Categories=Education;
+StartupNotify=true
+Terminal=false
+Type=Application
+X-KDE-SubstituteUID=false
+